]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
- accept new autoconf
[packages/kmplayer.git] / kmplayer.spec
1
2 %bcond_without  gstreamer       # Do not build kgstplayer
3 %bcond_with     koffice         # Build koffice plugin
4 %bcond_without  xine            # Do not build kxineplayer
5
6 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
7 Summary(pl):    Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
8 Name:           kmplayer
9 Version:        0.9.2a
10 Release:        2
11 Epoch:          2
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
15 # Source0-md5:  9e8ab1a03f80249c3ea9332a48817c32
16 #Patch0:                %{name}-mimetypes.patch
17 Patch0:         %{name}-video-size.patch
18 URL:            http://kmplayer.kde.org/
19 BuildRequires:  arts-qt-devel
20 BuildRequires:  artsc-devel
21 BuildRequires:  automake
22 BuildRequires:  gettext-devel
23 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10.0}
24 BuildRequires:  kdelibs-devel >= 9:3.1.92
25 %{?with_koffice:BuildRequires:  koffice-devel}
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.129
28 BuildRequires:  sed >= 4.0
29 #BuildRequires: unsermake
30 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
31 Requires:       kdebase-core >= 9:3.1.90
32 Requires:       kdelibs >= 9:3.4.0-4
33 Requires:       mplayer
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
38 GUI.
39
40 %description -l pl
41 W pe³ni zintegrowany z KDE frontend dla programów
42 MPlayer/Xine/ffmpeg/ffserver/VDR.
43
44 %package gstreamer
45 Summary:        Gstreamer wrapper
46 Summary(pl):    Wrapper gstreamera
47 Group:          X11/Applications/Multimedia
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49
50 %description gstreamer
51 Gstreamer wrapper.
52
53 %description gstreamer -l pl
54 Wrapper gstreamera.
55
56 %package koffice
57 Summary:        Kmplayer integration with Koffice
58 Summary(pl):    Integracja kmplayera z koffice
59 Group:          X11/Applications/Multimedia
60 Requires:       %{name} = %{epoch}:%{version}-%{release}
61 Requires:       koffice-common
62
63 %description koffice
64 Kmplayer integration with Koffice.
65
66 %description koffice -l pl
67 Integracja kmplayera z koffice.
68
69 %package xine
70 Summary:        Xine wrapper
71 Summary(pl):    Wrapper xine
72 Group:          X11/Applications/Multimedia
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74
75 %description xine
76 Xine wrapper.
77
78 %description xine -l pl
79 Wrapper xine.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84
85 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
86         src/kmplayer.desktop \
87
88 #%patch0 -p1
89
90 %build
91 cp /usr/share/automake/config.sub admin
92 %{__autoconf}
93
94 #%{__make} -f admin/Makefile.common cvs
95
96 %configure \
97         --disable-rpath \
98         --enable-final \
99         %{?with_koffice:--enable-koffice-plugin} \
100         %{!?with_gstreamer:--without-gstreamer} \
101         %{!?with_xine:--without-xine} \
102         --with-qt-libraries=%{_libdir}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         kde_htmldir=%{_kdedocdir}
112
113 # remove bogus translation
114 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
115
116 # already in kdelibs
117 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
118
119 %find_lang %{name} --with-kde
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README
127 %attr(755,root,root) %{_bindir}/kmplayer
128 %attr(755,root,root) %{_bindir}/kxvplayer
129 %{_libdir}/libkdeinit_kmplayer.la
130 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
131 %{_libdir}/libkmplayercommon.la
132 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
133 %{_libdir}/kde3/kmplayer.la
134 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
135 %{_libdir}/kde3/libkmplayerpart.la
136 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
137 %{_datadir}/apps/kmplayer
138 %{_datadir}/config/kmplayerrc
139 %{_datadir}/mimelnk/application/x-kmplayer.desktop
140 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
141 %{_datadir}/services/kmplayer_part.desktop
142 %{_desktopdir}/kde/kmplayer.desktop
143 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
144
145 %if %{with gstreamer}
146 %files gstreamer
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/kgstplayer
149 %endif
150
151 %if %{with koffice}
152 %files koffice
153 %defattr(644,root,root,755)
154 %{_libdir}/kde3/libkmplayerkofficepart.la
155 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
156 %{_datadir}/services/kmplayer_koffice.desktop
157 %endif
158
159 %if %{with xine}
160 %files xine
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/kxineplayer
163 %endif
This page took 0.414448 seconds and 3 git commands to generate.