]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
- move to common patch
[packages/kmplayer.git] / kmplayer.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # Do not build kgstplayer
4 %bcond_with     koffice         # Build koffice plugin
5 %bcond_without  xine            # Do not build kxineplayer
6 #
7 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
8 Summary(pl.UTF-8):      Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
9 Name:           kmplayer
10 Version:        0.10.0c
11 Release:        2
12 Epoch:          2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 # http://kmplayer.kde.org/pkgs/kmplayer-0.9.3-pre1.tar.bz2
16 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  3e76147784b2642891c9efbfe260e4c4
18 Patch0:         kde-common-PLD.patch
19 Patch1:         kde-ac260-lt.patch
20 Patch2:         %{name}-flash.patch
21 URL:            http://kmplayer.kde.org/
22 BuildRequires:  arts-qt-devel
23 BuildRequires:  artsc-devel
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  dbus-qt-devel
27 BuildRequires:  expat-devel
28 BuildRequires:  gettext-devel
29 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10.0}
30 BuildRequires:  kdelibs-devel >= 9:3.5.3
31 %{?with_koffice:BuildRequires:  koffice-devel}
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  libpng-devel
34 BuildRequires:  nspr-devel
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(macros) >= 1.357
37 BuildRequires:  sed >= 4.0
38 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
39 BuildRequires:  xorg-lib-libXv-devel
40 BuildRequires:  zlib-devel
41 Requires:       kdebase-core >= 9:3.5.3
42 Requires:       kdelibs >= 9:3.5.3
43 Requires:       mplayer
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
48 GUI.
49
50 %description -l pl.UTF-8
51 W pełni zintegrowany z KDE frontend dla programów
52 MPlayer/Xine/ffmpeg/ffserver/VDR.
53
54 %package gstreamer
55 Summary:        Gstreamer wrapper
56 Summary(pl.UTF-8):      Wrapper gstreamera
57 Group:          X11/Applications/Multimedia
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59
60 %description gstreamer
61 Gstreamer wrapper.
62
63 %description gstreamer -l pl.UTF-8
64 Wrapper gstreamera.
65
66 %package koffice
67 Summary:        Kmplayer integration with Koffice
68 Summary(pl.UTF-8):      Integracja kmplayera z koffice
69 Group:          X11/Applications/Multimedia
70 Requires:       %{name} = %{epoch}:%{version}-%{release}
71 Requires:       koffice-common
72
73 %description koffice
74 Kmplayer integration with Koffice.
75
76 %description koffice -l pl.UTF-8
77 Integracja kmplayera z koffice.
78
79 %package xine
80 Summary:        Xine wrapper
81 Summary(pl.UTF-8):      Wrapper xine
82 Group:          X11/Applications/Multimedia
83 Requires:       %{name} = %{epoch}:%{version}-%{release}
84
85 %description xine
86 Xine wrapper.
87
88 %description xine -l pl.UTF-8
89 Wrapper xine.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96
97 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
98         src/kmplayer.desktop
99 %{__sed} -i -e 's,plugin=/usr/lib/browser-plugins,plugin=%{_browserpluginsdir}', src/kmplayerrc
100
101 mv configure{,.orig}
102
103 %build
104 if [ ! -f configure ]; then
105         cp /usr/share/automake/config.sub admin
106         %{__make} -f admin/Makefile.common cvs
107 fi
108
109 CPPFLAGS="$CPPFLAGS -I/usr/include/nspr"
110 %configure \
111         --disable-rpath \
112         %{?with_koffice:--enable-koffice-plugin} \
113         %{!?with_gstreamer:--without-gstreamer} \
114         %{!?with_xine:--without-xine} \
115         --enable-expat \
116         --enable-npplayer \
117         --with-qt-libraries=%{_libdir}
118
119 %{__make} -j1
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT \
126         kde_htmldir=%{_kdedocdir}
127
128 # remove bogus translation
129 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
130
131 # already in kdelibs
132 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
133
134 %find_lang %{name} --with-kde
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files -f %{name}.lang
140 %defattr(644,root,root,755)
141 %doc AUTHORS ChangeLog README
142 %attr(755,root,root) %{_bindir}/kmplayer
143 %attr(755,root,root) %{_bindir}/knpplayer
144 %attr(755,root,root) %{_bindir}/kxvplayer
145 %{_libdir}/libkdeinit_kmplayer.la
146 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
147 %{_libdir}/libkmplayercommon.la
148 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
149 %{_libdir}/kde3/kmplayer.la
150 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
151 %{_libdir}/kde3/libkmplayerpart.la
152 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
153 %{_datadir}/apps/kmplayer
154 %{_datadir}/config/kmplayerrc
155 %{_datadir}/mimelnk/application/x-kmplayer.desktop
156 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
157 %{_datadir}/services/kmplayer_part.desktop
158 %{_desktopdir}/kde/kmplayer.desktop
159 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
160
161 %if %{with gstreamer}
162 %files gstreamer
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/kgstplayer
165 %endif
166
167 %if %{with koffice}
168 %files koffice
169 %defattr(644,root,root,755)
170 %{_libdir}/kde3/libkmplayerkofficepart.la
171 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
172 %{_datadir}/services/kmplayer_koffice.desktop
173 %endif
174
175 %if %{with xine}
176 %files xine
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_bindir}/kxineplayer
179 %endif
This page took 0.094178 seconds and 3 git commands to generate.