]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
- also adjust LINK for quotes
[packages/kmplayer.git] / kmplayer.spec
1
2 %bcond_without  gstreamer       # Do not build kgstplayer
3 %bcond_with     koffice         # Build koffice plugin
4 %bcond_without  xine            # Do not build kxineplayer
5
6 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
7 Summary(pl):    Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
8 Name:           kmplayer
9 Version:        0.9.3
10 Release:        0.1
11 Epoch:          2
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 # http://kmplayer.kde.org/pkgs/kmplayer-0.9.3-pre1.tar.bz2
15 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
16 # Source0-md5:  b5866658c62995185f3fb63f3804cfa2
17 #Patch0:                %{name}-mimetypes.patch
18 Patch0:         %{name}-video-size.patch
19 URL:            http://kmplayer.kde.org/
20 BuildRequires:  arts-qt-devel
21 BuildRequires:  artsc-devel
22 BuildRequires:  automake
23 BuildRequires:  gettext-devel
24 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10.0}
25 BuildRequires:  kdelibs-devel >= 9:3.5.3
26 %{?with_koffice:BuildRequires:  koffice-devel}
27 BuildRequires:  pkgconfig
28 BuildRequires:  rpmbuild(macros) >= 1.129
29 BuildRequires:  sed >= 4.0
30 #BuildRequires: unsermake
31 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
32 Requires:       kdebase-core >= 9:3.5.3
33 Requires:       kdelibs >= 9:3.5.3
34 Requires:       mplayer
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
39 GUI.
40
41 %description -l pl
42 W pe³ni zintegrowany z KDE frontend dla programów
43 MPlayer/Xine/ffmpeg/ffserver/VDR.
44
45 %package gstreamer
46 Summary:        Gstreamer wrapper
47 Summary(pl):    Wrapper gstreamera
48 Group:          X11/Applications/Multimedia
49 Requires:       %{name} = %{epoch}:%{version}-%{release}
50
51 %description gstreamer
52 Gstreamer wrapper.
53
54 %description gstreamer -l pl
55 Wrapper gstreamera.
56
57 %package koffice
58 Summary:        Kmplayer integration with Koffice
59 Summary(pl):    Integracja kmplayera z koffice
60 Group:          X11/Applications/Multimedia
61 Requires:       %{name} = %{epoch}:%{version}-%{release}
62 Requires:       koffice-common
63
64 %description koffice
65 Kmplayer integration with Koffice.
66
67 %description koffice -l pl
68 Integracja kmplayera z koffice.
69
70 %package xine
71 Summary:        Xine wrapper
72 Summary(pl):    Wrapper xine
73 Group:          X11/Applications/Multimedia
74 Requires:       %{name} = %{epoch}:%{version}-%{release}
75
76 %description xine
77 Xine wrapper.
78
79 %description xine -l pl
80 Wrapper xine.
81
82 %prep
83 %setup -q
84 #%%patch0 -p1
85
86 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
87         src/kmplayer.desktop \
88
89
90 %build
91 cp /usr/share/automake/config.sub admin
92 %{__autoconf}
93
94 #%{__make} -f admin/Makefile.common cvs
95
96 %configure \
97         --disable-rpath \
98         --enable-final \
99         %{?with_koffice:--enable-koffice-plugin} \
100         %{!?with_gstreamer:--without-gstreamer} \
101         %{!?with_xine:--without-xine} \
102         --with-qt-libraries=%{_libdir}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         kde_htmldir=%{_kdedocdir}
112
113 # remove bogus translation
114 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
115
116 # already in kdelibs
117 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
118
119 %find_lang %{name} --with-kde
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README
127 %attr(755,root,root) %{_bindir}/kmplayer
128 %attr(755,root,root) %{_bindir}/kxvplayer
129 %{_libdir}/libkdeinit_kmplayer.la
130 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
131 %{_libdir}/libkmplayercommon.la
132 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
133 %{_libdir}/kde3/kmplayer.la
134 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
135 %{_libdir}/kde3/libkmplayerpart.la
136 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
137 %{_datadir}/apps/kmplayer
138 %{_datadir}/config/kmplayerrc
139 %{_datadir}/mimelnk/application/x-kmplayer.desktop
140 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
141 %{_datadir}/services/kmplayer_part.desktop
142 %{_desktopdir}/kde/kmplayer.desktop
143 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
144
145 %if %{with gstreamer}
146 %files gstreamer
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/kgstplayer
149 %endif
150
151 %if %{with koffice}
152 %files koffice
153 %defattr(644,root,root,755)
154 %{_libdir}/kde3/libkmplayerkofficepart.la
155 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
156 %{_datadir}/services/kmplayer_koffice.desktop
157 %endif
158
159 %if %{with xine}
160 %files xine
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/kxineplayer
163 %endif
This page took 0.044485 seconds and 3 git commands to generate.