]> git.pld-linux.org Git - packages/kicad.git/blob - kicad.spec
- rel 1
[packages/kicad.git] / kicad.spec
1 %define         _release        r304
2 Summary:        KiCad - is a GPL'd suite of programs for EDA
3 Summary(pl.UTF-8):      KiCad jest zestawem programów na licencji GPL zaliczanym do kategorii EDA
4 Name:           kicad
5 Version:        20071004
6 Release:        1
7 License:        GPL
8 Group:          Applications
9 Source0:        http://dl.sourceforge.net/kicad/%{name}-%{version}-%{_release}.tar.bz2
10 # Source0-md5:  8ef6310123e9361c5780d321ec07cc8b
11 URL:            http://kicad.sourceforge.net/
12 BuildRequires:  wxGTK2-unicode-devel
13 BuildRequires:  wxGTK2-gl-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 KiCad consists of a project manager and four main programs:
18 - kicad - the project manager.
19 - eeschema - the schematic editor.
20 - cvpcb - the footprint selector for components used in the circuit
21   design.
22 - pcbnew - the PCB layout program.
23 - gerbview - the Gerber (photoplotter documents) viewer.
24
25 %description -l pl.UTF-8
26 KiCad składa się z menadżera projektów oraz czterych głównych
27 programów:
28 - kicad - menadżer projektów.
29 - eeschema - edytor schematów.
30 - cvpcb - the footprint selector for components used in the circuit
31   design.
32 - pcbnew - the PCB layout program.
33 - gerbview - the Gerber (photoplotter documents) viewer.
34
35 %prep
36 %setup -q -n %{name}
37
38 %build
39 export WX_CONFIG="`which wx-gtk2-unicode-config`"
40 %{__make} -f makefile.gtk \
41         WXXFLAGS="`$WX_CONFIG --cxxflags`" \
42         WXPATH=%{_libdir} \
43         PREFIX_WX_LIBS="lib`$WX_CONFIG --basename`" \
44         SUFFIX_WX_LIBSTD="`$WX_CONFIG --utility=`" \
45         SUFFIX_WX_LIBGL="_gl-`$WX_CONFIG --release`" \
46         LIBVERSION="`$WX_CONFIG --release`" \
47         WXSYSLIB="`$WX_CONFIG --libs std`" \
48         WXSYSLIB_WITH_GL="`$WX_CONFIG --libs std,gl`"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} -f makefile.gtk install \
54         DESTDIR=$RPM_BUILD_ROOT \
55         PREFIX=$RPM_BUILD_ROOT%{_prefix}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc change_log.txt news.txt regex_doc.txt todo.txt version.txt
63 %attr(755,root,root) %{_bindir}/*
64 %{_datadir}/%{name}
65 %{_libdir}/%{name}
66 %{_docdir}/%{name}
This page took 0.057776 seconds and 4 git commands to generate.