]> git.pld-linux.org Git - packages/kf5-sonnet.git/blob - kf5-sonnet.spec
- up to 5.13.0
[packages/kf5-sonnet.git] / kf5-sonnet.spec
1 # TODO:
2 # - fix build with aspell
3 %define         kdeframever     5.13
4 %define         qtver           5.3.2
5 %define         kfname          sonnet
6
7 Summary:        Multi-language spell checker
8 Name:           kf5-%{kfname}
9 Version:        5.13.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  99729551e032db0322b0915a4eba5d68
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5Gui-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  Qt5Widgets-devel >= %{qtver}
20 BuildRequires:  aspell-devel
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  hspell-devel
23 BuildRequires:  hunspell-devel
24 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.164
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 BuildRequires:  zlib-devel
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 Sonnet is a plugin-based spell checking library for Qt-based
36 applications. It supports several different plugins, including HSpell,
37 Enchant, ASpell and HUNSPELL.
38
39 It also supports automated language detection, based on a combination
40 of different algorithms.
41
42 The simplest way to use Sonnet in your application is to use the
43 SpellCheckDecorator class on your QTextEdit.
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kfname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kfname}.
56
57 %prep
58 %setup -q -n %{kfname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ../
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build/ install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %find_lang %{kfname}5_qt --with-qm --all-name
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files -f %{kfname}5_qt.lang
83 %defattr(644,root,root,755)
84 %doc README.md
85 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
86 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
88 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
89 %dir %{qt5dir}/plugins/kf5/sonnet
90 #%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/aspell.so
91 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hspell.so
92 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hunspell.so
93 %dir %{_datadir}/kf5/sonnet
94 %{_datadir}/kf5/sonnet/trigrams.map
95
96 %files devel
97 %defattr(644,root,root,755)
98 %{_includedir}/KF5/SonnetCore
99 %{_includedir}/KF5/SonnetUi
100 %{_includedir}/KF5/sonnet_version.h
101 %{_libdir}/cmake/KF5Sonnet
102 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so
103 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so
104 %{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
105 %{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.06687 seconds and 4 git commands to generate.