]> git.pld-linux.org Git - packages/kf5-sonnet.git/blob - kf5-sonnet.spec
- new
[packages/kf5-sonnet.git] / kf5-sonnet.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 # /usr/lib/qt5/qml/org/kde not packaged
4 # /usr/lib/qt5/plugins/kf5
5 # /usr/share/kf5
6
7 %define         _state          stable
8 %define         orgname         sonnet
9
10 Summary:        Multi-language spell checker
11 Name:           kf5-%{orgname}
12 Version:        5.0.0
13 Release:        0.1
14 License:        LGPL v2.1+
15 Group:          X11/Libraries
16 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
17 # Source0-md5:  b5608009ca1d34e6fdfd4f89c9752eef
18 URL:            http://www.kde.org/
19 BuildRequires:  Qt5Core-devel
20 BuildRequires:  Qt5Gui-devel >= 5.3.1
21 BuildRequires:  Qt5Test-devel
22 BuildRequires:  Qt5Widgets-devel
23 BuildRequires:  aspell-devel
24 BuildRequires:  cmake >= 2.8.12
25 BuildRequires:  hspell-devel
26 BuildRequires:  hunspell-devel
27 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
28 BuildRequires:  qt5-linguist
29 BuildRequires:  rpmbuild(macros) >= 1.164
30 BuildRequires:  zlib-devel
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 Sonnet is a plugin-based spell checking library for Qt-based
37 applications. It supports several different plugins, including HSpell,
38 Enchant, ASpell and HUNSPELL.
39
40 It also supports automated language detection, based on a combination
41 of different algorithms.
42
43 The simplest way to use Sonnet in your application is to use the
44 SpellCheckDecorator class on your QTextEdit.
45
46 %package devel
47 Summary:        Header files for %{orgname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{orgname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{orgname}.
57
58 %prep
59 %setup -q -n %{orgname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DBIN_INSTALL_DIR=%{_bindir} \
66         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
67         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
68         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
69         -DQML_INSTALL_DIR=%{qt5dir}/qml \
70         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
71         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
72         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
73         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
74         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
75         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
76         ../
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build/ install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %find_lang %{orgname}5_qt --with-qm
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files -f %{orgname}5_qt.lang
94 %defattr(644,root,root,755)
95 %doc README.md
96 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
97 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.5.0.0
98 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
99 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.5.0.0
100 %dir %{qt5dir}/plugins/kf5/sonnet
101 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/aspell.so
102 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hspell.so
103 %attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hunspell.so
104 %dir %{_datadir}/kf5/sonnet
105 %{_datadir}/kf5/sonnet/trigrams.map
106
107 %files devel
108 %defattr(644,root,root,755)
109 %{_includedir}/KF5/SonnetCore
110 %{_includedir}/KF5/SonnetUi
111 %{_includedir}/KF5/sonnet_version.h
112 %{_libdir}/cmake/KF5Sonnet
113 %attr(755,root,root) %{_libdir}/libKF5SonnetCore.so
114 %attr(755,root,root) %{_libdir}/libKF5SonnetUi.so
115 %{qt5dir}/mkspecs/modules/qt_SonnetCore.pri
116 %{qt5dir}/mkspecs/modules/qt_SonnetUi.pri
This page took 0.076554 seconds and 4 git commands to generate.