]> git.pld-linux.org Git - packages/kf5-solid.git/blob - kf5-solid.spec
- updated to 5.104.0
[packages/kf5-solid.git] / kf5-solid.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.104
5 %define         qtver           5.15.2
6 %define         kfname          solid
7
8 Summary:        Desktop hardware abstraction
9 Name:           kf5-%{kfname}
10 Version:        5.104.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  a97a2c8b0a766718fe0ed01ba3f17969
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Concurrent-devel >= %{qtver}
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5DBus-devel >= %{qtver}
20 BuildRequires:  Qt5Gui-devel >= %{qtver}
21 BuildRequires:  Qt5Qml-devel >= %{qtver}
22 BuildRequires:  Qt5Test-devel >= %{qtver}
23 BuildRequires:  Qt5Xml-devel >= %{qtver}
24 BuildRequires:  bison >= 3.0
25 BuildRequires:  cmake >= 3.16
26 BuildRequires:  flex
27 BuildRequires:  kf5-extra-cmake-modules >= %{version}
28 BuildRequires:  libimobiledevice-devel
29 BuildRequires:  libmount-devel
30 BuildRequires:  libplist-devel
31 BuildRequires:  ninja
32 BuildRequires:  pkgconfig
33 BuildRequires:  qt5-linguist >= %{qtver}
34 BuildRequires:  rpmbuild(macros) >= 1.736
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  udev-devel
37 BuildRequires:  xz
38 Requires:       Qt5Core >= %{qtver}
39 Requires:       Qt5DBus >= %{qtver}
40 Requires:       Qt5Gui >= %{qtver}
41 Requires:       Qt5Qml >= %{qtver}
42 Requires:       Qt5Xml >= %{qtver}
43 Requires:       kf5-dirs
44 Suggests:       media-player-info
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         qt5dir          %{_libdir}/qt5
48
49 %description
50 Solid is a device integration framework. It provides a way of querying
51 and interacting with hardware independently of the underlying
52 operating system.
53
54 It provides the following features for application developers:
55
56 - Hardware Discovery
57 - Power Management
58 - Network Management
59
60
61 %package devel
62 Summary:        Header files for %{kfname} development
63 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       Qt5Core-devel >= %{qtver}
67 Requires:       cmake >= 3.16
68
69 %description devel
70 Header files for %{kfname} development.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe dla programistów używających %{kfname}.
74
75 %prep
76 %setup -q -n %{kfname}-%{version}
77
78 %build
79 install -d build
80 cd build
81 %cmake -G Ninja \
82         %{!?with_tests:-DBUILD_TESTING=OFF} \
83         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
84         ../
85 %ninja_build
86
87 %if %{with tests}
88 ctest
89 %endif
90
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 %ninja_install -C build
95
96 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files -f %{kfname}5_qt.lang
105 %defattr(644,root,root,755)
106 %doc README.md TODO
107 %attr(755,root,root) %{_bindir}/solid-hardware5
108 %ghost %{_libdir}/libKF5Solid.so.5
109 %attr(755,root,root) %{_libdir}/libKF5Solid.so.*.*
110 %dir %{_libdir}/qt5/qml/org/kde/solid
111 %{_libdir}/qt5/qml/org/kde/solid/qmldir
112 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/solid/libsolidextensionplugin.so
113 %{_datadir}/qlogging-categories5/solid.categories
114 %{_datadir}/qlogging-categories5/solid.renamecategories
115
116 %files devel
117 %defattr(644,root,root,755)
118 %{_includedir}/KF5/Solid
119 %{_libdir}/cmake/KF5Solid
120 %{_libdir}/libKF5Solid.so
121 %{qt5dir}/mkspecs/modules/qt_Solid.pri
This page took 0.125493 seconds and 4 git commands to generate.