]> git.pld-linux.org Git - packages/kf5-kwidgetsaddons.git/blob - kf5-kwidgetsaddons.spec
-updated to 5.24.0; fetch sources
[packages/kf5-kwidgetsaddons.git] / kf5-kwidgetsaddons.spec
1 %define         kdeframever     5.24
2 %define         qtver           5.3.2
3 %define         kfname          kwidgetsaddons
4
5 Summary:        Large set of desktop widgets
6 Name:           kf5-%{kfname}
7 Version:        5.24.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  841740260585143afbdf6240289cce31
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5UiTools-devel >= %{qtver}
18 BuildRequires:  Qt5Widgets-devel >= %{qtver}
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  qt5-linguist >= %{qtver}
22 BuildRequires:  rpmbuild(macros) >= 1.164
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 Requires:       kf5-dirs
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         qt5dir          %{_libdir}/qt5
29
30 %description
31 This repository contains add-on widgets and classes for applications
32 that use the Qt Widgets module. If you are porting applications from
33 KDE Platform 4 "kdeui" library, you will find many of its classes
34 here.
35
36 Provided are action classes that can be added to toolbars or menus, a
37 wide range of widgets for selecting characters, fonts, colors,
38 actions, dates and times, or MIME types, as well as platform-aware
39 dialogs for configuration pages, message boxes, and password requests.
40
41 Further widgets and classes can be found in other KDE frameworks. For
42 a full list, please see
43 <https://projects.kde.org/projects/frameworks/>
44
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{kfname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{kfname}.
57
58 %prep
59 %setup -q -n %{kfname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ../
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build/ install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kfname}5_qt.lang
84 %defattr(644,root,root,755)
85 %doc README.md
86 %attr(755,root,root) %ghost %{_libdir}/libKF5WidgetsAddons.so.5
87 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so.*.*
88 %dir %{_datadir}/kf5/kcharselect
89 %{_datadir}/kf5/kcharselect/kcharselect-data
90
91 %files devel
92 %defattr(644,root,root,755)
93 %{_includedir}/KF5/KWidgetsAddons
94 %{_includedir}/KF5/kwidgetsaddons_version.h
95 %{_libdir}/cmake/KF5WidgetsAddons
96 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so
97 %{qt5dir}/mkspecs/modules/qt_KWidgetsAddons.pri
This page took 0.067845 seconds and 4 git commands to generate.