]> git.pld-linux.org Git - packages/kf5-kwidgetsaddons.git/blob - kf5-kwidgetsaddons.spec
- updated to 5.112.0
[packages/kf5-kwidgetsaddons.git] / kf5-kwidgetsaddons.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.112
5 %define         qtver           5.15.2
6 %define         kfname          kwidgetsaddons
7
8 Summary:        Large set of desktop widgets
9 Name:           kf5-%{kfname}
10 Version:        5.112.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  3ea2b36c47f8da3d224174b2493dbff3
16 Patch0:         failed-tests.patch
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Core-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5UiTools-devel >= %{qtver}
21 BuildRequires:  Qt5Widgets-devel >= %{qtver}
22 BuildRequires:  cmake >= 3.16
23 BuildRequires:  kf5-extra-cmake-modules >= %{version}
24 BuildRequires:  ninja
25 BuildRequires:  qt5-linguist >= %{qtver}
26 BuildRequires:  rpmbuild(macros) >= 1.736
27 BuildRequires:  tar >= 1:1.22
28 BuildRequires:  xz
29 Requires:       Qt5Widgets >= %{qtver}
30 Requires:       kf5-dirs
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         qt5dir          %{_libdir}/qt5
34
35 %description
36 This repository contains add-on widgets and classes for applications
37 that use the Qt Widgets module. If you are porting applications from
38 KDE Platform 4 "kdeui" library, you will find many of its classes
39 here.
40
41 Provided are action classes that can be added to toolbars or menus, a
42 wide range of widgets for selecting characters, fonts, colors,
43 actions, dates and times, or MIME types, as well as platform-aware
44 dialogs for configuration pages, message boxes, and password requests.
45
46 Further widgets and classes can be found in other KDE frameworks. For
47 a full list, please see
48 <https://projects.kde.org/projects/frameworks/>
49
50
51 %package devel
52 Summary:        Header files for %{kfname} development
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       Qt5Widgets-devel >= %{qtver}
57 Requires:       cmake >= 3.16
58
59 %description devel
60 Header files for %{kfname} development.
61
62 %description devel -l pl.UTF-8
63 Pliki nagłówkowe dla programistów używających %{kfname}.
64
65 %prep
66 %setup -q -n %{kfname}-%{version}
67 #%%patch0 -p1
68
69 %build
70 %cmake -B build \
71         -G Ninja \
72         %{!?with_tests:-DBUILD_TESTING=OFF} \
73         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
74
75 %ninja_build -C build
76
77 %if %{with tests}
78 %ninja_build -C build test
79 %endif
80
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 %ninja_install -C build
85
86 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files -f %{kfname}5_qt.lang
95 %defattr(644,root,root,755)
96 %doc README.md
97 %ghost %{_libdir}/libKF5WidgetsAddons.so.5
98 %attr(755,root,root) %{_libdir}/libKF5WidgetsAddons.so.*.*
99 %attr(755,root,root) %{_libdir}/qt5/plugins/designer/kwidgetsaddons5widgets.so
100 %dir %{_datadir}/kf5/kcharselect
101 %{_datadir}/kf5/kcharselect/kcharselect-data
102 %{_datadir}/qlogging-categories5/kwidgetsaddons.categories
103
104 %files devel
105 %defattr(644,root,root,755)
106 %{_includedir}/KF5/KWidgetsAddons
107 %{_libdir}/cmake/KF5WidgetsAddons
108 %{_libdir}/libKF5WidgetsAddons.so
109 %{qt5dir}/mkspecs/modules/qt_KWidgetsAddons.pri
This page took 0.041821 seconds and 3 git commands to generate.