]> git.pld-linux.org Git - packages/kf5-kpty.git/blob - kf5-kpty.spec
b6b73a63e5928e4927e8bcc7204f0186996f3d02
[packages/kf5-kpty.git] / kf5-kpty.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeframever     5.104
5 %define         qtver           5.15.2
6 %define         kfname          kpty
7
8 Summary:        Interfacing with pseudo terminal devices
9 Name:           kf5-%{kfname}
10 Version:        5.104.0
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          X11/Libraries
14 Source0:        https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
15 # Source0-md5:  431982275af2b1d476a71eeb3c30b3a5
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  Qt5Test-devel >= %{qtver}
19 BuildRequires:  cmake >= 3.16
20 BuildRequires:  kf5-extra-cmake-modules >= %{version}
21 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
22 BuildRequires:  kf5-ki18n-devel >= %{version}
23 BuildRequires:  libutempter-devel
24 BuildRequires:  ninja
25 BuildRequires:  rpmbuild(macros) >= 1.736
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       Qt5Core >= %{qtver}
29 Requires:       kf5-dirs
30 Requires:       kf5-kcoreaddons >= %{version}
31 Requires:       kf5-ki18n >= %{version}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 This library provides primitives to interface with pseudo terminal
38 devices as well as a KProcess derived class for running child
39 processes and communicating with them using a pty.
40
41 %package devel
42 Summary:        Header files for %{kfname} development
43 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
44 Group:          X11/Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       kf5-kcoreaddons-devel >= %{version}
47
48 %description devel
49 Header files for %{kfname} development.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe dla programistów używających %{kfname}.
53
54 %prep
55 %setup -q -n %{kfname}-%{version}
56
57 %build
58 install -d build
59 cd build
60 %cmake -G Ninja \
61         %{!?with_tests:-DBUILD_TESTING=OFF} \
62         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
63         ../
64 %ninja_build
65
66 %if %{with tests}
67 ctest
68 %endif
69
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %ninja_install -C build
74
75 %find_lang %{kfname}5
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files -f %{kfname}5.lang
84 %defattr(644,root,root,755)
85 %doc README.md
86 %ghost %{_libdir}/libKF5Pty.so.5
87 %attr(755,root,root) %{_libdir}/libKF5Pty.so.*.*
88 %{_datadir}/qlogging-categories5/kpty.categories
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_includedir}/KF5/KPty
93 %{_libdir}/cmake/KF5Pty
94 %{_libdir}/libKF5Pty.so
95 %{qt5dir}/mkspecs/modules/qt_KPty.pri
This page took 0.089638 seconds and 3 git commands to generate.