]> git.pld-linux.org Git - packages/kf5-kplotting.git/blob - kf5-kplotting.spec
- Up to 5.65.0.
[packages/kf5-kplotting.git] / kf5-kplotting.spec
1 %define         kdeframever     5.65
2 %define         qtver           5.9.0
3 %define         kfname          kplotting
4 #
5 Summary:        Data plotting
6 Name:           kf5-%{kfname}
7 Version:        5.65.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  b91d8d841efdb994b674860abffcb064
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel
15 BuildRequires:  Qt5Gui-devel >= 5.3.1
16 BuildRequires:  Qt5Test-devel
17 BuildRequires:  Qt5Widgets-devel
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
20 BuildRequires:  ninja
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 Requires:       kf5-dirs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 KPlotWidget is a QWidget-derived class that provides a virtual base
31 class for easy data-plotting. The idea behind KPlotWidget is that you
32 only have to specify information in "data units"; i.e., the natural
33 units of the data being plotted. KPlotWidget automatically converts
34 everything to screen pixel units.
35
36 KPlotWidget draws X and Y axes with tick marks and tick labels. It
37 automatically determines how many tick marks to use and where they
38 should be, based on the data limits specified for the plot. You change
39 the limits by calling `setLimits(double x1, double x2, double y1,
40 double y2)`.
41
42 Data to be plotted are stored using the KPlotObject class. KPlotObject
43 consists of a QList of QPointF's, each specifying the X,Y coordinates
44 of a data point. KPlotObject also specifies the "type" of data to be
45 plotted (POINTS or CURVE or POLYGON or LABEL).
46
47 %package devel
48 Summary:        Header files for %{kfname} development
49 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
50 Group:          X11/Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for %{kfname} development.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe dla programistów używających %{kfname}.
58
59 %prep
60 %setup -q -n %{kfname}-%{version}
61
62 %build
63 install -d build
64 cd build
65 %cmake -G Ninja \
66         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
67         ../
68 %ninja_build
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %ninja_install -C build
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README.md
83 %attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
84 %attr(755,root,root) %{_libdir}/libKF5Plotting.so.*.**
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_includedir}/KF5/KPlotting
89 %{_includedir}/KF5/kplotting_version.h
90 %{_libdir}/cmake/KF5Plotting
91 %attr(755,root,root) %{_libdir}/libKF5Plotting.so
92 %{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.082901 seconds and 4 git commands to generate.