]> git.pld-linux.org Git - packages/kf5-kplotting.git/blob - kf5-kplotting.spec
tar.xz deps
[packages/kf5-kplotting.git] / kf5-kplotting.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kplotting
5
6 Summary:        Data plotting
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  28eae81acd540a79c91acad75f0c725c
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5Gui-devel >= 5.3.1
17 BuildRequires:  Qt5Test-devel
18 BuildRequires:  Qt5Widgets-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 KPlotWidget is a QWidget-derived class that provides a virtual base
30 class for easy data-plotting. The idea behind KPlotWidget is that you
31 only have to specify information in "data units"; i.e., the natural
32 units of the data being plotted. KPlotWidget automatically converts
33 everything to screen pixel units.
34
35 KPlotWidget draws X and Y axes with tick marks and tick labels. It
36 automatically determines how many tick marks to use and where they
37 should be, based on the data limits specified for the plot. You change
38 the limits by calling `setLimits(double x1, double x2, double y1,
39 double y2)`.
40
41 Data to be plotted are stored using the KPlotObject class. KPlotObject
42 consists of a QList of QPointF's, each specifying the X,Y coordinates
43 of a data point. KPlotObject also specifies the "type" of data to be
44 plotted (POINTS or CURVE or POLYGON or LABEL).
45
46 %package devel
47 Summary:        Header files for %{orgname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{orgname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{orgname}.
57
58 %prep
59 %setup -q -n %{orgname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DBIN_INSTALL_DIR=%{_bindir} \
66         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
67         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
68         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
69         -DQML_INSTALL_DIR=%{qt5dir}/qml \
70         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
71         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
72         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
73         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
74         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
75         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
76         ../
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} -C build/ install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README.md
94 %attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
95 %attr(755,root,root) %{_libdir}/libKF5Plotting.so.5.0.0
96
97 %files devel
98 %defattr(644,root,root,755)
99 %{_includedir}/KF5/KPlotting
100 %{_includedir}/KF5/kplotting_version.h
101 %{_libdir}/cmake/KF5Plotting
102 %attr(755,root,root) %{_libdir}/libKF5Plotting.so
103 %{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.088117 seconds and 4 git commands to generate.