]> git.pld-linux.org Git - packages/kf5-kplotting.git/blob - kf5-kplotting.spec
- up to 5.43.0
[packages/kf5-kplotting.git] / kf5-kplotting.spec
1 %define         kdeframever     5.43
2 %define         qtver           5.3.2
3 %define         kfname          kplotting
4 #
5 Summary:        Data plotting
6 Name:           kf5-%{kfname}
7 Version:        5.43.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  a78c532acdb8dbfb6fb07e78fd55bfd0
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel
15 BuildRequires:  Qt5Gui-devel >= 5.3.1
16 BuildRequires:  Qt5Test-devel
17 BuildRequires:  Qt5Widgets-devel
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       kf5-dirs
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 KPlotWidget is a QWidget-derived class that provides a virtual base
30 class for easy data-plotting. The idea behind KPlotWidget is that you
31 only have to specify information in "data units"; i.e., the natural
32 units of the data being plotted. KPlotWidget automatically converts
33 everything to screen pixel units.
34
35 KPlotWidget draws X and Y axes with tick marks and tick labels. It
36 automatically determines how many tick marks to use and where they
37 should be, based on the data limits specified for the plot. You change
38 the limits by calling `setLimits(double x1, double x2, double y1,
39 double y2)`.
40
41 Data to be plotted are stored using the KPlotObject class. KPlotObject
42 consists of a QList of QPointF's, each specifying the X,Y coordinates
43 of a data point. KPlotObject also specifies the "type" of data to be
44 plotted (POINTS or CURVE or POLYGON or LABEL).
45
46 %package devel
47 Summary:        Header files for %{kfname} development
48 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
49 Group:          X11/Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51
52 %description devel
53 Header files for %{kfname} development.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla programistów używających %{kfname}.
57
58 %prep
59 %setup -q -n %{kfname}-%{version}
60
61 %build
62 install -d build
63 cd build
64 %cmake \
65         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
66         ../
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C build/ install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.md
84 %attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
85 %attr(755,root,root) %{_libdir}/libKF5Plotting.so.*.**
86
87 %files devel
88 %defattr(644,root,root,755)
89 %{_includedir}/KF5/KPlotting
90 %{_includedir}/KF5/kplotting_version.h
91 %{_libdir}/cmake/KF5Plotting
92 %attr(755,root,root) %{_libdir}/libKF5Plotting.so
93 %{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.061327 seconds and 4 git commands to generate.