]> git.pld-linux.org Git - packages/kf5-kplotting.git/blob - kf5-kplotting.spec
- new
[packages/kf5-kplotting.git] / kf5-kplotting.spec
1 # TODO:
2 # - dir /usr/include/KF5 not packaged
3 %define         _state          stable
4 %define         orgname         kplotting
5
6 Summary:        Data plotting
7 Name:           kf5-%{orgname}
8 Version:        5.0.0
9 Release:        0.1
10 License:        LGPL v2.1+
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
13 # Source0-md5:  28eae81acd540a79c91acad75f0c725c
14 URL:            http://www.kde.org/
15 BuildRequires:  Qt5Core-devel
16 BuildRequires:  Qt5Gui-devel >= 5.3.1
17 BuildRequires:  Qt5Test-devel
18 BuildRequires:  Qt5Widgets-devel
19 BuildRequires:  cmake >= 2.8.12
20 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         qt5dir          %{_libdir}/qt5
25
26 %description
27 KPlotWidget is a QWidget-derived class that provides a virtual base
28 class for easy data-plotting. The idea behind KPlotWidget is that you
29 only have to specify information in "data units"; i.e., the natural
30 units of the data being plotted. KPlotWidget automatically converts
31 everything to screen pixel units.
32
33 KPlotWidget draws X and Y axes with tick marks and tick labels. It
34 automatically determines how many tick marks to use and where they
35 should be, based on the data limits specified for the plot. You change
36 the limits by calling `setLimits(double x1, double x2, double y1,
37 double y2)`.
38
39 Data to be plotted are stored using the KPlotObject class. KPlotObject
40 consists of a QList of QPointF's, each specifying the X,Y coordinates
41 of a data point. KPlotObject also specifies the "type" of data to be
42 plotted (POINTS or CURVE or POLYGON or LABEL).
43
44 %package devel
45 Summary:        Header files for %{orgname} development
46 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{orgname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{orgname}.
55
56 %prep
57 %setup -q -n %{orgname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -DBIN_INSTALL_DIR=%{_bindir} \
64         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
65         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
66         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
67         -DQML_INSTALL_DIR=%{qt5dir}/qml \
68         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
69         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
70         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
71         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
72         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
73         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
74         ../
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build/ install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc README.md
92 %attr(755,root,root) %ghost %{_libdir}/libKF5Plotting.so.5
93 %attr(755,root,root) %{_libdir}/libKF5Plotting.so.5.0.0
94
95 %files devel
96 %defattr(644,root,root,755)
97 %{_includedir}/KF5/KPlotting
98 %{_includedir}/KF5/kplotting_version.h
99 %{_libdir}/cmake/KF5Plotting
100 %attr(755,root,root) %{_libdir}/libKF5Plotting.so
101 %{qt5dir}/mkspecs/modules/qt_KPlotting.pri
This page took 0.206297 seconds and 4 git commands to generate.