]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blob - kf5-kitemmodels.spec
- updated to 5.39.0
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
1 %define         kdeframever     5.39
2 %define         qtver           5.3.2
3 %define         kfname          kitemmodels
4
5 Summary:        Set of item models extending the Qt model-view framework
6 Name:           kf5-%{kfname}
7 Version:        5.39.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  643ab111eabcca08e964062ee8c53041
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 Requires:       kf5-dirs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 KItemModels provides the following models:
31
32 - KBreadcrumbSelectionModel - Selects the parents of selected items to
33   create breadcrumbs
34 - KCheckableProxyModel - Adds a checkable capability to a source model
35 - KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
36   list
37 - KLinkItemSelectionModel - Share a selection in multiple views which
38   do not have the same source model
39 - KModelIndexProxyMapper - Mapping of indexes and selections through
40   proxy models
41 - KRecursiveFilterProxyModel - Recursive filtering of models
42 - KSelectionProxyModel - A Proxy Model which presents a subset of its
43   source model to observers
44
45 %package devel
46 Summary:        Header files for %{kfname} development
47 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
48 Group:          X11/Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for %{kfname} development.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla programistów używających %{kfname}.
56
57 %prep
58 %setup -q -n %{kfname}-%{version}
59
60 %build
61 install -d build
62 cd build
63 %cmake \
64         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
65         ../
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} -C build/ install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README.md
83 %attr(755,root,root) %ghost %{_libdir}/libKF5ItemModels.so.5
84 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so.*.*
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_includedir}/KF5/KItemModels
89 %{_includedir}/KF5/kitemmodels_version.h
90 %{_libdir}/cmake/KF5ItemModels
91 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so
92 %{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.54757 seconds and 4 git commands to generate.