]> git.pld-linux.org Git - packages/kf5-kitemmodels.git/blob - kf5-kitemmodels.spec
- up to 5.13.0
[packages/kf5-kitemmodels.git] / kf5-kitemmodels.spec
1 %define         kdeframever     5.13
2 %define         qtver           5.3.2
3 %define         kfname          kitemmodels
4
5 Summary:        Set of item models extending the Qt model-view framework
6 Name:           kf5-%{kfname}
7 Version:        5.13.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  9de370faf78290dbb7faecb4f8f70f73
13 URL:            http://www.kde.org/
14 BuildRequires:  Qt5Core-devel >= %{qtver}
15 BuildRequires:  Qt5Gui-devel >= %{qtver}
16 BuildRequires:  Qt5Test-devel >= %{qtver}
17 BuildRequires:  Qt5Widgets-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
20 BuildRequires:  qt5-linguist >= %{qtver}
21 BuildRequires:  rpmbuild(macros) >= 1.164
22 BuildRequires:  tar >= 1:1.22
23 BuildRequires:  xz
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         qt5dir          %{_libdir}/qt5
27
28 %description
29 KItemModels provides the following models:
30
31 - KBreadcrumbSelectionModel - Selects the parents of selected items to
32   create breadcrumbs
33 - KCheckableProxyModel - Adds a checkable capability to a source model
34 - KDescendantsProxyModel - Proxy Model for restructuring a Tree into a
35   list
36 - KLinkItemSelectionModel - Share a selection in multiple views which
37   do not have the same source model
38 - KModelIndexProxyMapper - Mapping of indexes and selections through
39   proxy models
40 - KRecursiveFilterProxyModel - Recursive filtering of models
41 - KSelectionProxyModel - A Proxy Model which presents a subset of its
42   source model to observers
43
44 %package devel
45 Summary:        Header files for %{kfname} development
46 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
47 Group:          X11/Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for %{kfname} development.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe dla programistów używających %{kfname}.
55
56 %prep
57 %setup -q -n %{kfname}-%{version}
58
59 %build
60 install -d build
61 cd build
62 %cmake \
63         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
64         ../
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} -C build/ install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post -p /sbin/ldconfig
77 %postun -p /sbin/ldconfig
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README.md
82 %attr(755,root,root) %ghost %{_libdir}/libKF5ItemModels.so.5
83 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so.*.*
84
85 %files devel
86 %defattr(644,root,root,755)
87 %{_includedir}/KF5/KItemModels
88 %{_includedir}/KF5/kitemmodels_version.h
89 %{_libdir}/cmake/KF5ItemModels
90 %attr(755,root,root) %{_libdir}/libKF5ItemModels.so
91 %{qt5dir}/mkspecs/modules/qt_KItemModels.pri
This page took 0.040281 seconds and 4 git commands to generate.