]> git.pld-linux.org Git - packages/kf5-kinit.git/blob - kf5-kinit.spec
- updated to 5.80.0
[packages/kf5-kinit.git] / kf5-kinit.spec
1 %define         kdeframever     5.80
2 %define         qtver           5.9.0
3 %define         kfname          kinit
4
5 Summary:        Helper library to speed up start of applications on KDE workspaces
6 Name:           kf5-%{kfname}
7 Version:        5.80.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  42d9d85b0dce1d068e290c191627ee81
13 URL:            http://www.kde.org/
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  gettext-devel
16 BuildRequires:  kf5-extra-cmake-modules >= %{version}
17 BuildRequires:  kf5-kio-devel >= %{version}
18 BuildRequires:  libcap-devel
19 BuildRequires:  ninja
20 BuildRequires:  rpmbuild(macros) >= 1.164
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xorg-lib-libX11-devel
23 BuildRequires:  xz
24 Requires:       kf5-dirs
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         qt5dir          %{_libdir}/qt5
28
29 %description
30 kdeinit is a process launcher somewhat similar to the famous init used
31 for booting UNIX.
32
33 It launches processes by forking and then loading a dynamic library
34 which should contain a 'kdemain(...)' function.
35
36 Using kdeinit to launch KDE applications makes starting a typical KDE
37 applications 2.5 times faster (100ms instead of 250ms on a P-III 500)
38 It reduces memory consumption by approx. 350Kb per application.
39
40 %package devel
41 Summary:        Header files for %{kfname} development
42 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
43 Group:          X11/Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for %{kfname} development.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe dla programistów używających %{kfname}.
51
52 %prep
53 %setup -q -n %{kfname}-%{version}
54
55 %build
56 install -d build
57 cd build
58 %cmake -G Ninja \
59         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
60         ../
61 %ninja_build
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 %ninja_install -C build
66
67 %find_lang %{kfname}5
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files -f %{kfname}5.lang
76 %defattr(644,root,root,755)
77 %doc README.md
78 %attr(755,root,root) %{_bindir}/kdeinit5
79 %attr(755,root,root) %{_bindir}/kdeinit5_shutdown
80 %attr(755,root,root) %{_bindir}/kdeinit5_wrapper
81 %attr(755,root,root) %{_bindir}/kshell5
82 %attr(755,root,root) %{_bindir}/kwrapper5
83 %attr(755,root,root) %{_libexecdir}/kf5/klauncher
84 %attr(755,root,root) %{_libexecdir}/kf5/start_kdeinit
85 %attr(755,root,root) %{_libexecdir}/kf5/start_kdeinit_wrapper
86 %attr(755,root,root) %{_libdir}/libkdeinit5_klauncher.so
87 %{_datadir}/dbus-1/interfaces/kf5_org.kde.KLauncher.xml
88 %{_datadir}/qlogging-categories5/kinit.categories
89 %{_mandir}/man8/kdeinit5.8*
90 %lang(ca) %{_mandir}/ca/man8/kdeinit5.8*
91 %lang(de) %{_mandir}/de/man8/kdeinit5.8*
92 %lang(es) %{_mandir}/es/man8/kdeinit5.8*
93 %lang(it) %{_mandir}/it/man8/kdeinit5.8*
94 %lang(nl) %{_mandir}/nl/man8/kdeinit5.8*
95 %lang(pt) %{_mandir}/pt/man8/kdeinit5.8*
96 %lang(pt_BR) %{_mandir}/pt_BR/man8/kdeinit5.8*
97 %lang(sv) %{_mandir}/sv/man8/kdeinit5.8*
98 %lang(uk) %{_mandir}/uk/man8/kdeinit5.8*
99 %lang(fr) %{_mandir}/fr/man8/kdeinit5.8*
100 %{_datadir}/qlogging-categories5/kinit.renamecategories
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_libdir}/cmake/KF5Init
This page took 0.032185 seconds and 4 git commands to generate.