]> git.pld-linux.org Git - packages/kf5-kinit.git/blob - kf5-kinit.spec
- updated to 5.19.0
[packages/kf5-kinit.git] / kf5-kinit.spec
1 %define         kdeframever     5.19
2 %define         qtver           5.3.2
3 %define         kfname          kinit
4
5 Summary:        Helper library to speed up start of applications on KDE workspaces
6 Name:           kf5-%{kfname}
7 Version:        5.19.0
8 Release:        1
9 License:        LGPL v2.1+
10 Group:          X11/Libraries
11 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
12 # Source0-md5:  3c40a568bfe04957ad68b9fa1afe54fd
13 URL:            http://www.kde.org/
14 BuildRequires:  cmake >= 2.8.12
15 BuildRequires:  gettext-devel
16 BuildRequires:  kf5-extra-cmake-modules >= 1.4.0
17 BuildRequires:  kf5-kio-devel >= %{version}
18 BuildRequires:  libcap-devel
19 BuildRequires:  rpmbuild(macros) >= 1.164
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xorg-lib-libX11-devel
22 BuildRequires:  xz
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         qt5dir          %{_libdir}/qt5
26
27 %description
28 kdeinit is a process launcher somewhat similar to the famous init used
29 for booting UNIX.
30
31 It launches processes by forking and then loading a dynamic library
32 which should contain a 'kdemain(...)' function.
33
34 Using kdeinit to launch KDE applications makes starting a typical KDE
35 applications 2.5 times faster (100ms instead of 250ms on a P-III 500)
36 It reduces memory consumption by approx. 350Kb per application.
37
38 %package devel
39 Summary:        Header files for %{kfname} development
40 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
41 Group:          X11/Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for %{kfname} development.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe dla programistów używających %{kfname}.
49
50 %prep
51 %setup -q -n %{kfname}-%{version}
52
53 %build
54 install -d build
55 cd build
56 %cmake \
57         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
58         ../
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} -C build/ install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %find_lang %{kfname}5
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post -p /sbin/ldconfig
73 %postun -p /sbin/ldconfig
74
75 %files -f %{kfname}5.lang
76 %defattr(644,root,root,755)
77 %doc README.md
78 %attr(755,root,root) %{_bindir}/kdeinit5
79 %attr(755,root,root) %{_bindir}/kdeinit5_shutdown
80 %attr(755,root,root) %{_bindir}/kdeinit5_wrapper
81 %attr(755,root,root) %{_bindir}/kshell5
82 %attr(755,root,root) %{_bindir}/kwrapper5
83 %attr(755,root,root) %{_libdir}/kf5/klauncher
84 %attr(755,root,root) %{_libdir}/kf5/start_kdeinit
85 %attr(755,root,root) %{_libdir}/kf5/start_kdeinit_wrapper
86 %attr(755,root,root) %{_libdir}/libkdeinit5_klauncher.so
87 %{_datadir}/dbus-1/interfaces/kf5_org.kde.KLauncher.xml
88 %{_mandir}/man8/kdeinit5.8*
89
90 %files devel
91 %defattr(644,root,root,755)
92 %{_libdir}/cmake/KF5Init
This page took 0.057029 seconds and 4 git commands to generate.