]> git.pld-linux.org Git - packages/kf5-kauth.git/blob - kf5-kauth.spec
- updated to 5.19.0
[packages/kf5-kauth.git] / kf5-kauth.spec
1 # TODO:
2 # - runtime Requires if any
3 %define         kdeframever     5.19
4 %define         qtver           5.3.2
5 %define         kfname          kauth
6
7 Summary:        Execute actions as privileged user
8 Name:           kf5-%{kfname}
9 Version:        5.19.0
10 Release:        1
11 License:        GPL v2+/LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
14 # Source0-md5:  ab6498a04ed69236cb582677df829c91
15 URL:            http://www.kde.org/
16 BuildRequires:  Qt5Core-devel >= %{qtver}
17 BuildRequires:  Qt5DBus-devel >= %{qtver}
18 BuildRequires:  Qt5Gui-devel >= %{qtver}
19 BuildRequires:  Qt5Test-devel >= %{qtver}
20 BuildRequires:  Qt5Widgets-devel >= %{qtver}
21 BuildRequires:  cmake >= 2.8.12
22 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
23 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
24 BuildRequires:  polkit-qt5-1-devel
25 BuildRequires:  polkit-qt5-1-gui-devel
26 BuildRequires:  qt5-linguist
27 BuildRequires:  rpmbuild(macros) >= 1.164
28 BuildRequires:  tar >= 1:1.22
29 BuildRequires:  xz
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         qt5dir          %{_libdir}/qt5
33
34 %description
35 KAuth provides a convenient, system-integrated way to offload actions
36 that need to be performed as a privileged user (root, for example) to
37 small (hopefully secure) helper utilities.
38
39 %package devel
40 Summary:        Header files for %{kfname} development
41 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{kfname}
42 Group:          X11/Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44
45 %description devel
46 Header files for %{kfname} development.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe dla programistów używających %{kfname}.
50
51 %prep
52 %setup -q -n %{kfname}-%{version}
53
54 %build
55 install -d build
56 cd build
57 %cmake \
58         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
59         ../
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} -C build/ install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %find_lang %{kfname}5_qt --with-qm --all-name --with-kde
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post -p /sbin/ldconfig
74 %postun -p /sbin/ldconfig
75
76 %files -f %{kfname}5_qt.lang
77 %defattr(644,root,root,755)
78 %doc README.md
79 /etc/dbus-1/system.d/org.kde.kf5auth.conf
80 %attr(755,root,root) %ghost %{_libdir}/libKF5Auth.so.5
81 %attr(755,root,root) %{_libdir}/libKF5Auth.so.*.*
82 %dir %{qt5dir}/plugins/kauth
83 %dir %{qt5dir}/plugins/kauth/backend
84 %attr(755,root,root) %{qt5dir}/plugins/kauth/backend/kauth_backend_plugin.so
85 %dir %{qt5dir}/plugins/kauth/helper
86 %attr(755,root,root) %{qt5dir}/plugins/kauth/helper/kauth_helper_plugin.so
87 %dir %{_libdir}/kauth
88 %attr(755,root,root) %{_libdir}/kauth/kauth-policy-gen
89 %dir %{_datadir}/kf5/kauth
90 %{_datadir}/kf5/kauth/dbus_policy.stub
91 %{_datadir}/kf5/kauth/dbus_service.stub
92
93 %files devel
94 %defattr(644,root,root,755)
95 %{_includedir}/KF5/KAuth
96 %{_includedir}/KF5/kauth_version.h
97 %{_libdir}/cmake/KF5Auth
98 %attr(755,root,root) %{_libdir}/libKF5Auth.so
99 %{qt5dir}/mkspecs/modules/qt_KAuth.pri
This page took 0.062499 seconds and 4 git commands to generate.