]> git.pld-linux.org Git - packages/kf5-kauth.git/blob - kf5-kauth.spec
- more cmake variables
[packages/kf5-kauth.git] / kf5-kauth.spec
1 # TODO:
2 # - proper place for *.pri,
3 # - set ECM_MKSPECS_INSTALL_DIR in kde5-extra-cmake-modules
4 # - _IMPORT_PREFIX also must be set somewhere
5 # - runtime Requires if any
6 # - these dirs are not own by any package
7 #  /usr/include/KF5
8 #  /usr/lib/libexec
9 #  /usr/lib/plugins
10 #  /usr/share/kf5
11 %define         _state          stable
12 %define         orgname         kauth
13
14 Summary:        Execute actions as privileged user
15 Name:           kf5-%{orgname}
16 Version:        5.0.0
17 Release:        0.1
18 License:        GPL v2+/LGPL v2.1+
19 Group:          X11/Libraries
20 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
21 # Source0-md5:  eeb5e576c9d0d098cfb9def812f04089
22 URL:            http://www.kde.org/
23 BuildRequires:  Qt5Core-devel >= 5.2.0
24 BuildRequires:  Qt5DBus-devel
25 BuildRequires:  Qt5Gui-devel >= 5.3.1
26 BuildRequires:  Qt5Test-devel
27 BuildRequires:  Qt5Widgets-devel
28 BuildRequires:  cmake >= 2.8.12
29 BuildRequires:  kf5-extra-cmake-modules >= 1.0.0
30 BuildRequires:  kf5-kcoreaddons-devel >= %{version}
31 BuildRequires:  polkit-qt-1-devel
32 BuildRequires:  qt5-linguist
33 BuildRequires:  rpmbuild(macros) >= 1.164
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         qt5dir          %{_libdir}/qt5
37
38 %description
39 KAuth provides a convenient, system-integrated way to offload actions
40 that need to be performed as a privileged user (root, for example) to
41 small (hopefully secure) helper utilities.
42
43 %package devel
44 Summary:        Header files for %{orgname} development
45 Summary(pl.UTF-8):      Pliki nagłówkowe dla programistów używających %{orgname}
46 Group:          X11/Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description devel
50 Header files for %{orgname} development.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe dla programistów używających %{orgname}.
54
55 %prep
56 %setup -q -n %{orgname}-%{version}
57
58 %build
59 install -d build
60 cd build
61 %cmake \
62         -DBIN_INSTALL_DIR=%{_bindir} \
63         -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
64         -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
65         -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
66         -DQML_INSTALL_DIR=%{qt5dir}/qml \
67         -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
68         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
69         -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
70         -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
71         -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
72         -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
73         -D_IMPORT_PREFIX=%{_prefix} \
74         ../
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} -C build/ install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %find_lang %{orgname}5_qt --with-qm
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files -f %{orgname}5_qt.lang
92 %defattr(644,root,root,755)
93 %doc README.md
94 /etc/dbus-1/system.d/org.kde.kf5auth.conf
95 %attr(755,root,root) %ghost %{_libdir}/libKF5Auth.so.5
96 %attr(755,root,root) %{_libdir}/libKF5Auth.so.5.0.0
97 %dir %{qt5dir}/plugins/kauth
98 %dir %{qt5dir}/plugins/kauth/backend
99 %attr(755,root,root) %{qt5dir}/plugins/kauth/backend/kauth_backend_plugin.so
100 %dir %{qt5dir}/plugins/kauth/helper
101 %attr(755,root,root) %{qt5dir}/plugins/kauth/helper/kauth_helper_plugin.so
102 %dir %{_libdir}/kauth
103 %attr(755,root,root) %{_libdir}/kauth/kauth-policy-gen
104 %{_datadir}/kf5/kauth/dbus_policy.stub
105 %{_datadir}/kf5/kauth/dbus_service.stub
106
107 %files devel
108 %defattr(644,root,root,755)
109 %{_includedir}/KF5/KAuth
110 %{_includedir}/KF5/kauth_version.h
111 %{_libdir}/cmake/KF5Auth
112 %attr(755,root,root) %{_libdir}/libKF5Auth.so
113 %{qt5dir}/mkspecs/modules/qt_KAuth.pri
This page took 0.06153 seconds and 4 git commands to generate.