]> git.pld-linux.org Git - packages/kexec-tools.git/blob - kexec-tools.spec
- updated to 2.0.8
[packages/kexec-tools.git] / kexec-tools.spec
1 #
2 # Conditional build:
3 %bcond_without  xen             # Xen support
4 %bcond_with     booke           # [PPC] build for BookE
5 %bcond_with     gamecube        # [PPC] build for GameCube
6
7 Summary:        Tool for starting new kernel without reboot
8 Summary(pl.UTF-8):      Narzędzie pozwalające załadować nowe jądro bez konieczności restartu
9 Name:           kexec-tools
10 Version:        2.0.8
11 Release:        1
12 License:        GPL v2
13 Group:          Applications/System
14 Source0:        https://www.kernel.org/pub/linux/utils/kernel/kexec/%{name}-%{version}.tar.xz
15 # Source0-md5:  2c4dec4e857e84ca530478bac0ec114b
16 Source1:        kexec.init
17 Source2:        kexec.sysconfig
18 Patch0:         %{name}-format.patch
19 URL:            https://www.kernel.org/pub/linux/utils/kernel/kexec/
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  rpmbuild(macros) >= 1.228
22 BuildRequires:  tar >= 1:1.22
23 %{?with_xen:BuildRequires:      xen-devel >= 4.4}
24 BuildRequires:  xz
25 BuildRequires:  xz-devel
26 BuildRequires:  zlib-devel
27 Requires(post,preun):   /sbin/chkconfig
28 Requires:       rc-scripts >= 0.4.0.9
29 ExclusiveArch:  %{ix86} %{x8664} alpha arm ia64 mips ppc ppc64 s390 s390x sh
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %define         _sbindir        /sbin
33
34 %description
35 kexec is a set of system calls that allows you to load another kernel
36 from the currently executing Linux kernel. The current implementation
37 has only been tested, and had the kinks worked out on x86, but the
38 generic code should work on any architecture.
39
40 %description -l pl.UTF-8
41 kexec to zestaw wywołań systemowych pozwalających załadować następne
42 jądro z poziomu aktualnie działającego jądra Linuksa. Aktualna
43 implementacja była testowana tylko na x86, ale ogólny kod powinien
44 działać na każdej architekturze.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 %{__autoconf}
52 %configure \
53         %{?with_booke:--with-booke} \
54         %{?with_gamecube:--with-gamecube} \
55         %{!?with_xen:--without-xen}
56 %{__make}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/kexec
66 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/kexec
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %post
72 /sbin/chkconfig --add kexec
73 %service kexec restart
74
75 %preun
76 if [ "$1" = "0" ]; then
77         %service -q kexec stop
78         /sbin/chkconfig --del kexec
79 fi
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS News TODO
84 %attr(754,root,root) /etc/rc.d/init.d/kexec
85 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/kexec
86 %attr(755,root,root) %{_sbindir}/kdump
87 %attr(755,root,root) %{_sbindir}/kexec
88 %attr(755,root,root) %{_sbindir}/vmcore-dmesg
89 %{_mandir}/man8/kdump.8*
90 %{_mandir}/man8/kexec.8*
91 %{_mandir}/man8/vmcore-dmesg.8*
92 %ifarch %{ix86}
93 %dir %{_libdir}/kexec-tools
94 # what is this anyway, is it needed on other arches?
95 %attr(755,root,root) %{_libdir}/kexec-tools/kexec_test
96 %endif
This page took 0.125421 seconds and 4 git commands to generate.