]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
- release 2 (by relup.sh)
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - add bcond to disable building docs (perf docs)
5 # - install of perf links perf binary again
6
7 # Conditional build:
8 %bcond_without  verbose         # verbose build (V=1)
9 %bcond_without  cpupower        # cpupower tools
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # GTK+ 2.x perf support
12 %bcond_without  libunwind       # libunwind perf support
13 %bcond_without  multilib        # multilib perf support
14 %bcond_without  usbip           # usbip utils
15
16 %ifarch x32
17 %undefine       with_libunwind
18 %endif
19 %ifnarch %{x8664}
20 %undefine       with_multilib
21 %endif
22
23 %define         basever         4.15
24 %define         postver         .0
25 Summary:        Assortment of tools for the Linux kernel
26 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
27 Name:           kernel-tools
28 Version:        %{basever}%{postver}
29 Release:        2
30 License:        GPL v2
31 Group:          Applications/System
32 Source0:        https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
33 # Source0-md5:  0d701ac1e2a67d47ce7127432df2c32b
34 Source1:        cpupower.service
35 Source2:        cpupower.config
36 %if "%{postver}" != ".0"
37 Patch0:         https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
38 # Patch0-md5:   de16c219ce4548d63ff7d6c670340a9e
39 %endif
40 Patch1:         x32.patch
41 Patch3:         %{name}-perf-update.patch
42 Patch4:         binutils-2.29.patch
43 URL:            http://www.kernel.org/
44 BuildRequires:  bison
45 BuildRequires:  flex
46 BuildRequires:  gettext-tools
47 BuildRequires:  linux-libc-headers >= 7:4.12
48 BuildRequires:  ncurses-devel
49 BuildRequires:  pciutils-devel
50 BuildRequires:  pkgconfig
51 BuildRequires:  rpmbuild(macros) >= 1.673
52 BuildRequires:  tar >= 1:1.22
53 BuildRequires:  xz
54 %if %{with perf}
55 BuildRequires:  asciidoc
56 BuildRequires:  audit-libs-devel
57 BuildRequires:  binutils-devel >= 4:2.29
58 BuildRequires:  docbook-dtd45-xml
59 BuildRequires:  docbook-style-xsl
60 BuildRequires:  elfutils-devel
61 %if %{with multilib}
62 BuildRequires:  gcc-multilib-32
63 BuildRequires:  gcc-multilib-x32
64 %endif
65 %{?with_libunwind:BuildRequires:        libunwind-devel >= 0.99}
66 BuildRequires:  numactl-devel
67 BuildRequires:  perl-devel >= 5.1
68 BuildRequires:  python-devel
69 BuildRequires:  rpm-pythonprov
70 BuildRequires:  slang-devel
71 BuildRequires:  xmlto
72 %if %{with gtk}
73 BuildRequires:  gtk+2-devel >= 2.0
74 %endif
75 %endif
76 %if %{with usbip}
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake >= 1:1.9
79 BuildRequires:  gcc >= 6:4.0
80 BuildRequires:  libtool >= 2:2
81 BuildRequires:  libwrap-devel
82 BuildRequires:  udev-devel
83 %endif
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 # otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
87 %define         _enable_debug_packages  0
88
89 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
90
91 %description
92 This package contains the software from tools/ subdirectory from Linux
93 kernel source and the supporting documentation.
94
95 %description -l pl.UTF-8
96 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
97 Linuksa oraz związaną z nim dokumentację.
98
99 %package cpupower
100 Summary:        cpupower - Shows and sets processor power related values
101 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
102 Group:          Applications/System
103 Requires(post,preun,postun):    systemd-units >= 38
104 Requires:       %{name}-cpupower-libs = %{version}-%{release}
105 Requires:       systemd-units >= 0.38
106 Provides:       cpupowerutils = 1:009-0.6.p1
107 Obsoletes:      cpupowerutils < 1:009-0.6.p1
108 Obsoletes:      cpuspeed < 1:1.5-16
109
110 %description cpupower
111 cpupower is a collection of tools to examine and tune power saving
112 related features of your processor.
113
114 %description cpupower -l pl.UTF-8
115 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
116 związanych z oszczędzaniem energii.
117
118 %package cpupower-libs
119 Summary:        cpupower library
120 Summary(pl.UTF-8):      Biblioteka cpupower
121 Group:          Libraries
122
123 %description cpupower-libs
124 cpupower library.
125
126 %description cpupower-libs -l pl.UTF-8
127 Biblioteka cpupower.
128
129 %package cpupower-libs-devel
130 Summary:        Development files for the cpupower library
131 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
132 Group:          Development/Libraries
133 Requires:       %{name}-cpupower-libs = %{version}-%{release}
134 Provides:       cpupowerutils-devel = 1:009-0.6.p1
135 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
136 Conflicts:      cpufrequtils-devel
137
138 %description cpupower-libs-devel
139 Development files for the cpupower library.
140
141 %description cpupower-libs-devel -l pl.UTF-8
142 Pliki programistyczne biblioteki cpupower.
143
144 %package hv
145 Summary:        Hyper-V virtualization tools
146 Summary(pl.UTF-8):      Narzędzia do wirtualizacji Hyper-V
147 Group:          Applications/System
148
149 %description hv
150 Hyper-V virtualization tools.
151
152 %description hv -l pl.UTF-8
153 Narzędzia do wirtualizacji Hyper-V.
154
155 %package perf
156 Summary:        perf profiler tool
157 Summary(pl.UTF-8):      Narzędzie profilujące perf
158 Group:          Applications/System
159 Suggests:       binutils
160 Obsoletes:      perf-core
161 Obsoletes:      perf-slang
162
163 %description perf
164 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
165 away CPU hardware differences in Linux performance measurements and
166 presents a simple commandline interface. Perf is based on the
167 perf_events interface exported by recent versions of the Linux kernel.
168
169 This package contains core files, scripts and text interface (TUI).
170
171 %description perf -l pl.UTF-8
172 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
173 odseparowujące od różnic sprzętowych między pomiarami wydajności w
174 zależności od procesora oraz udostępniające prosty interfejs linii
175 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
176 przez nowe wersje jądra Linuksa.
177
178 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
179 (TUI).
180
181 %package perf-vdso32
182 Summary:        perf profiler tool - VDSO 32-bit ABI reader
183 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
184 Group:          Applications/System
185 Requires:       %{name}-perf = %{version}-%{release}
186
187 %description perf-vdso32
188 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
189 away CPU hardware differences in Linux performance measurements and
190 presents a simple commandline interface. Perf is based on the
191 perf_events interface exported by recent versions of the Linux kernel.
192
193 This package contains perf-read-vdso32 tool for reading the 32-bit
194 compatibility VDSO in 64-bit mode.
195
196 %description perf-vdso32 -l pl.UTF-8
197 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
198 odseparowujące od różnic sprzętowych między pomiarami wydajności w
199 zależności od procesora oraz udostępniające prosty interfejs linii
200 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
201 przez nowe wersje jądra Linuksa.
202
203 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
204 binariów 32-bitowych w trybie 64-bitowym.
205
206 %package perf-vdsox32
207 Summary:        perf profiler tool - VDSO x32 ABI reader
208 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI x32
209 Group:          Applications/System
210 Requires:       %{name}-perf = %{version}-%{release}
211
212 %description perf-vdsox32
213 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
214 away CPU hardware differences in Linux performance measurements and
215 presents a simple commandline interface. Perf is based on the
216 perf_events interface exported by recent versions of the Linux kernel.
217
218 This package contains perf-read-vdso32 tool for reading the x32 mode
219 32-bit compatibility VDSO in 64-bit mode.
220
221 %description perf-vdsox32 -l pl.UTF-8
222 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
223 odseparowujące od różnic sprzętowych między pomiarami wydajności w
224 zależności od procesora oraz udostępniające prosty interfejs linii
225 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
226 przez nowe wersje jądra Linuksa.
227
228 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
229 binariów ABI x32 w trybie 64-bitowym.
230
231 %package perf-gtk
232 Summary:        perf profiler tool (GTK+ 2 GUI)
233 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
234 Group:          X11/Applications
235 Requires:       %{name}-perf = %{version}-%{release}
236
237 %description perf-gtk
238 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
239 away CPU hardware differences in Linux performance measurements and
240 presents a simple commandline interface. Perf is based on the
241 perf_events interface exported by recent versions of the Linux kernel.
242
243 This package contains GTK+ 2 based GUI.
244
245 %description perf-gtk -l pl.UTF-8
246 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
247 odseparowujące od różnic sprzętowych między pomiarami wydajności w
248 zależności od procesora oraz udostępniające prosty interfejs linii
249 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
250 przez nowe wersje jądra Linuksa.
251
252 Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
253
254 %package -n bash-completion-perf
255 Summary:        Bash completion for perf command
256 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
257 Group:          Applications/Shells
258 Requires:       %{name}-perf = %{version}-%{release}
259 Requires:       bash-completion
260 %if "%{_rpmversion}" >= "5"
261 BuildArch:      noarch
262 %endif
263
264 %description -n bash-completion-perf
265 Bash completion for perf command.
266
267 %description -n bash-completion-perf -l pl.UTF-8
268 Bashowe uzupełnianie parametrów dla polecenia perf.
269
270 %package -n bash-completion-kernel-tools
271 Summary:        Bash completion for kernel-tools commands
272 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń kernel-tools
273 Group:          Applications/Shells
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       bash-completion >= 2.0
276 %if "%{_rpmversion}" >= "5"
277 BuildArch:      noarch
278 %endif
279
280 %description -n bash-completion-kernel-tools
281 Bash completion for kernel-tools commands (currently bpftool).
282
283 %description -n bash-completion-kernel-tools -l pl.UTF-8
284 Bashowe uzupełnianie parametrów dla poleceń kernel-tools (obecnie
285 bpftool).
286
287 %package -n usbip
288 Summary:        USB device sharing system over IP network
289 Summary(pl.UTF-8):      System współdzielenia urządzeń USB po sieci IP
290 Group:          Networking/Utilities
291 Requires:       usbip-libs = %{version}-%{release}
292 # /lib/hwdata/usb.ids (note: only uncompressed file supported)
293 Requires:       hwdata >= 0.243-2
294
295 %description -n usbip
296 The USB/IP Project aims to develop a general USB device sharing system
297 over IP network. To share USB devices between computers with their
298 full functionality, USB/IP encapsulates "USB requests" into IP packets
299 and transmits them between computers. Original USB device drivers and
300 applications can be also used for remote USB devices without any
301 modification of them. A computer can use remote USB devices as if they
302 were directly attached; for example, we can:
303  - USB storage devices: fdisk, mkfs, mount/umount, file operations,
304    play a DVD movie and record a DVD-R media.
305  - USB keyboards and USB mice: use with Linux console and X Window
306    System.
307  - USB webcams and USB speakers: view webcam, capture image data and
308    play some music.
309  - USB printers, USB scanners, USB serial converters and USB Ethernet
310    interfaces: ok, use fine.
311
312 %description -n usbip -l pl.UTF-8
313 Projekt USB/IP ma na celu stworzenie ogólnego systemu współdzielenia
314 urządzeń USB po sieci IP. W celu współdzielenia urządzeń USB między
315 komputerami z zachowaniem pełnej funkcjonalności, USB/IP obudowuje
316 żądania SUB w pakiety IP i przesyła je między komputerami. Oryginalne
317 sterowniki urządzeń USB oraz aplikacje mogą być używane bez żadnych
318 modyfikacji. Komputer może wykorzystywać zdaln urządzenia USB tak,
319 jakby były podłączone bezpośrednio. Przykładowe możliwości:
320  - urządzenia USB do przechowywania danych: można używać programów
321    fdisk, mkfs, mount/umount, operacji na plikach, odtwarzać filmy
322    DVD oraz nagrywać nośniki DVD-R
323  - klawiatury i myszy USB: można ich używać na linuksowej konsoli oraz
324    w systemie X Window
325  - kamery i głośniki USB: można oglądać obraz z kamery, robić zdjęcia
326    i odtwarzać muzykę
327  - drukarki, skanery, konwertery portów szeregowych oraz interfejsy
328    sieciowe USB: można ich normalnie używać
329
330 %package -n usbip-libs
331 Summary:        USB/IP library
332 Summary(pl.UTF-8):      Biblioteka USB/IP
333 Group:          Libraries
334
335 %description -n usbip-libs
336 USB over IP library.
337
338 %description -n usbip-libs -l pl.UTF-8
339 Biblioteka USB po IP.
340
341 %package -n usbip-devel
342 Summary:        Header files for usbip library
343 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki usbip
344 Group:          Development/Libraries
345 Requires:       usbip-libs = %{version}-%{release}
346
347 %description -n usbip-devel
348 This package contains the header files needed to develop programs
349 which make use of USB/IP.
350
351 %description -n usbip-devel -l pl.UTF-8
352 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
353 wykorzystujących USB/IP.
354
355 %package -n usbip-static
356 Summary:        Static usbip library
357 Summary(pl.UTF-8):      Statyczna biblioteka usbip
358 Group:          Development/Libraries
359 Requires:       usbip-devel = %{version}-%{release}
360
361 %description -n usbip-static
362 Static usbip library.
363
364 %description -n usbip-static -l pl.UTF-8
365 Statyczna biblioteka usbip.
366
367 %prep
368 %setup -qc
369 cd linux-%{basever}
370
371 %if "%{postver}" != ".0"
372 %patch0 -p1
373 %endif
374
375 %patch1 -p1
376 %patch3 -p1
377 %patch4 -p1
378
379 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
380 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
381 %{__sed} -i -e 's#libexec/perf-core#share/perf-core#g' tools/perf/Makefile.config
382
383 %build
384 cd linux-%{basever}
385
386 # Simple Disk Sleep Monitor
387 %{__make} -C tools/laptop/dslm \
388         %{makeopts} \
389         EXTRA_CFLAGS="%{rpmcflags}"
390
391 # tools common (used eg. by tools/vm)
392 %{__make} -C tools/lib/api \
393         %{makeopts} \
394         EXTRA_CFLAGS="%{rpmcflags}"
395
396 # lsgpio
397 CFLAGS="%{rpmcflags}" \
398 %{__make} -C tools/gpio -j1 \
399         %{makeopts}
400
401 # HyperV is Windows based, x86 specific
402 %ifarch %{ix86} %{x8664} x32
403 %{__make} -C tools/hv \
404         CC="%{__cc}" \
405         OPTFLAGS="%{rpmcflags}"
406 %endif
407
408 CFLAGS="%{rpmcflags}" \
409 %{__make} -C tools/iio -j1 \
410         CC="%{__cc}"
411
412 %{__make} -C tools/laptop/freefall \
413         CC="%{__cc}" \
414         CFLAGS="%{rpmcflags}"
415
416 CFLAGS="%{rpmcflags}" \
417 %{__make} -C tools/bpf \
418         CC="%{__cc}"
419
420 # perf
421 %if %{with perf}
422 %{__make} -C tools/perf all man \
423 %ifarch %{x8664}
424         IS_X86_64=1 \
425         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
426 %endif
427         %{!?with_gtk:NO_GTK2=1} \
428         %{!?with_libunwind:NO_LIBUNWIND=1} \
429         %{makeopts} \
430         CFLAGS_OPTIMIZE="%{rpmcflags}" \
431         WERROR=0 \
432         prefix=%{_prefix} \
433         perfexecdir=%{_datadir}/perf-core \
434         lib=%{_lib} \
435         template_dir=%{_datadir}/perf-core/templates
436 %endif
437
438 # cpupower
439 %if %{with cpupower}
440 %{__make} -C tools/power/cpupower \
441         %{makeopts} \
442         CPUFREQ_BENCH=false \
443         OPTIMIZATION="%{rpmcflags}" \
444         STRIPCMD=true
445
446 %ifarch %{ix86} x32
447 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
448         CC="%{__cc}" \
449         CFLAGS="%{rpmcflags}"
450 %endif
451
452 %ifarch %{x8664} x32
453 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
454         CC="%{__cc}" \
455         CFLAGS="%{rpmcflags}"
456 %endif
457 %endif
458
459 %ifarch %{ix86} %{x8664} x32
460 CFLAGS="%{rpmcflags}" \
461 %{__make} -C tools/power/x86/x86_energy_perf_policy \
462         CC="%{__cc}"
463
464 CFLAGS="%{rpmcflags}" \
465 %{__make} -C tools/power/x86/turbostat \
466         CC="%{__cc}"
467 %endif
468
469 %{__make} -C tools/thermal/tmon \
470         CC="%{__cc}" \
471         OPTFLAGS="%{rpmcflags}"
472
473 # usbip-utils
474 %if %{with usbip}
475 cd tools/usb/usbip
476 %{__libtoolize}
477 %{__aclocal}
478 %{__autoconf}
479 %{__autoheader}
480 %{__automake}
481 %configure \
482         --disable-silent-rules \
483         --with-usbids-dir=/lib/hwdata
484 %{__make}
485 cd ../../..
486 %endif
487
488 # page-types, slabinfo
489 %{__make} -C tools/vm page-types slabinfo \
490         CC="%{__cc}" \
491         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
492
493 # gen_init_cpio
494 %{__make} -C usr gen_init_cpio \
495         %{makeopts} \
496         CFLAGS="%{rpmcflags}"
497
498 %install
499 rm -rf $RPM_BUILD_ROOT
500
501 cd linux-%{basever}
502
503 %if %{with cpupower}
504 %{__make} -C tools/power/cpupower install \
505         DESTDIR=$RPM_BUILD_ROOT \
506         libdir=%{_libdir} \
507         mandir=%{_mandir} \
508         CPUFREQ_BENCH=false
509
510 %find_lang cpupower
511 mv cpupower.lang ..
512
513 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
514 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
515 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
516
517 %ifarch %{ix86} x32
518 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
519 %endif
520 %ifarch %{x8664} x32
521 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
522 %endif
523 %endif
524
525 %if %{with perf}
526 %{__make} -C tools/perf -j1 install install-man \
527 %ifarch %{x8664}
528         IS_X86_64=1 \
529         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
530 %endif
531         %{!?with_gtk:NO_GTK2=1} \
532         %{!?with_libunwind:NO_LIBUNWIND=1} \
533         CC="%{__cc}" \
534         CFLAGS_OPTIMIZE="%{rpmcflags}" \
535         WERROR=0 \
536         %{?with_verbose:V=1} \
537         prefix=%{_prefix} \
538         perfexecdir=%{_datadir}/perf-core \
539         template_dir=%{_datadir}/perf-core/templates \
540         lib=%{_lib} \
541         DESTDIR=$RPM_BUILD_ROOT
542
543 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
544 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
545
546 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
547 %endif
548
549 %if %{with usbip}
550 %{__make} -C tools/usb/usbip install \
551         DESTDIR=$RPM_BUILD_ROOT
552
553 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusbip.la
554 %endif
555
556 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8}
557
558 install -p tools/laptop/dslm/dslm $RPM_BUILD_ROOT%{_sbindir}
559
560 install -p tools/gpio/lsgpio $RPM_BUILD_ROOT%{_bindir}
561
562 %ifarch %{ix86} %{x8664} x32
563 install -p tools/hv/hv_{fcopy,kvp,vss}_daemon $RPM_BUILD_ROOT%{_sbindir}
564 # TODO: PLD-specific hv_get_dhcp_info,hv_get_dns_info,hv_set_ifconfig
565 %{__sed} -e '1s,/usr/bin/env python,%{__python},' tools/hv/lsvmbus >$RPM_BUILD_ROOT%{_bindir}/lsvmbus
566 chmod 755 $RPM_BUILD_ROOT%{_bindir}/lsvmbus
567 %endif
568
569 install -p tools/iio/{iio_event_monitor,iio_generic_buffer,lsiio} $RPM_BUILD_ROOT%{_bindir}
570
571 install -p tools/laptop/freefall/freefall $RPM_BUILD_ROOT%{_sbindir}
572
573 %{__make} -C tools/bpf install \
574         prefix=$RPM_BUILD_ROOT%{_prefix} \
575         bash_compdir=$RPM_BUILD_ROOT%{bash_compdir}
576 %{__make} -C tools/bpf/bpftool doc-install \
577         prefix=$RPM_BUILD_ROOT%{_prefix}
578
579 install -p tools/thermal/tmon/tmon $RPM_BUILD_ROOT%{_bindir}
580 cp -p tools/thermal/tmon/tmon.8 $RPM_BUILD_ROOT%{_mandir}/man8
581
582 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
583 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
584
585 %ifarch %{ix86} %{x8664} x32
586 install -d $RPM_BUILD_ROOT%{_mandir}/man8
587 %{__make} -C tools/power/x86/x86_energy_perf_policy install \
588         DESTDIR=$RPM_BUILD_ROOT
589
590 %{__make} -C tools/power/x86/turbostat install \
591         DESTDIR=$RPM_BUILD_ROOT
592 %endif
593
594 # gen_init_cpio
595 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
596
597 %clean
598 rm -rf $RPM_BUILD_ROOT
599
600 %post   cpupower-libs -p /sbin/ldconfig
601 %postun cpupower-libs -p /sbin/ldconfig
602
603 %post cpupower
604 %systemd_post cpupower.service
605
606 %preun cpupower
607 %systemd_preun cpupower.service
608
609 %postun cpupower
610 %systemd_reload
611
612 %post   -n usbip-libs -p /sbin/ldconfig
613 %postun -n usbip-libs -p /sbin/ldconfig
614
615 %files
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/bpf_asm
618 %attr(755,root,root) %{_bindir}/bpf_dbg
619 %attr(755,root,root) %{_bindir}/bpf_jit_disasm
620 %attr(755,root,root) %{_bindir}/gen_init_cpio
621 %attr(755,root,root) %{_bindir}/iio_event_monitor
622 %attr(755,root,root) %{_bindir}/iio_generic_buffer
623 %attr(755,root,root) %{_bindir}/lsgpio
624 %attr(755,root,root) %{_bindir}/lsiio
625 %attr(755,root,root) %{_bindir}/slabinfo
626 %attr(755,root,root) %{_bindir}/tmon
627 %attr(755,root,root) %{_sbindir}/bpftool
628 %attr(755,root,root) %{_sbindir}/dslm
629 %attr(755,root,root) %{_sbindir}/freefall
630 %attr(755,root,root) %{_sbindir}/page-types
631 %{_mandir}/man8/bpftool*.8*
632 %{_mandir}/man8/tmon.8*
633 %ifarch %{ix86} %{x8664} x32
634 %attr(755,root,root) %{_bindir}/centrino-decode
635 %attr(755,root,root) %{_bindir}/powernow-k8-decode
636 %endif
637 %ifarch %{ix86} %{x8664} x32
638 %attr(755,root,root) %{_bindir}/turbostat
639 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
640 %{_mandir}/man8/turbostat.8*
641 %{_mandir}/man8/x86_energy_perf_policy.8*
642 %endif
643
644 %files cpupower -f cpupower.lang
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_bindir}/cpupower
647 %{_mandir}/man1/cpupower*.1*
648 %{systemdunitdir}/cpupower.service
649 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
650
651 %files cpupower-libs
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
654 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
655
656 %files cpupower-libs-devel
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libcpupower.so
659 %{_includedir}/cpufreq.h
660 %{_includedir}/cpuidle.h
661
662 %ifarch %{ix86} %{x8664} x32
663 %files hv
664 %defattr(644,root,root,755)
665 # TODO: PLDify these scripts and move to bindir
666 %doc linux-%{basever}/tools/hv/hv_{get_dhcp_info,get_dns_info,set_ifconfig}.sh
667 %attr(755,root,root) %{_bindir}/lsvmbus
668 %attr(755,root,root) %{_sbindir}/hv_fcopy_daemon
669 %attr(755,root,root) %{_sbindir}/hv_kvp_daemon
670 %attr(755,root,root) %{_sbindir}/hv_vss_daemon
671 %endif
672
673 %if %{with perf}
674 %files perf
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_bindir}/perf
677 %attr(755,root,root) %{_bindir}/trace
678 %{_mandir}/man1/perf*.1*
679 %{_docdir}/perf-tip
680 %dir %{_datadir}/perf-core
681 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
682 %attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
683 %{_datadir}/perf-core/strace
684
685 %dir %{_datadir}/perf-core/scripts
686
687 %dir %{_datadir}/perf-core/scripts/perl
688 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
689 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
690 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
691 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
692 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
693 %dir %{_datadir}/perf-core/scripts/perl/bin
694 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
695 %{_datadir}/perf-core/scripts/perl/*.pl
696
697 %dir %{_datadir}/perf-core/scripts/python
698 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
699 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
700 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
701 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
702 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
703 %dir %{_datadir}/perf-core/scripts/python/bin
704 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
705 %{_datadir}/perf-core/scripts/python/*.py*
706
707 %dir %{_libdir}/traceevent
708 %dir %{_libdir}/traceevent/plugins
709 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
710
711 %if %{with multilib}
712 %files perf-vdso32
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_bindir}/perf-read-vdso32
715
716 %files perf-vdsox32
717 %defattr(644,root,root,755)
718 %attr(755,root,root) %{_bindir}/perf-read-vdsox32
719 %endif
720
721 %if %{with gtk}
722 %files perf-gtk
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/libperf-gtk.so
725 %endif
726
727 %files -n bash-completion-perf
728 %defattr(644,root,root,755)
729 /etc/bash_completion.d/perf
730 %endif
731
732 %files -n bash-completion-kernel-tools
733 %defattr(644,root,root,755)
734 %{bash_compdir}/bpftool
735
736 %if %{with usbip}
737 %files -n usbip
738 %defattr(644,root,root,755)
739 %doc linux-%{basever}/tools/usb/usbip/{AUTHORS,README}
740 %attr(755,root,root) %{_sbindir}/usbip
741 %attr(755,root,root) %{_sbindir}/usbipd
742 %{_mandir}/man8/usbip.8*
743 %{_mandir}/man8/usbipd.8*
744
745 %files -n usbip-libs
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/libusbip.so.*.*.*
748 %attr(755,root,root) %ghost %{_libdir}/libusbip.so.0
749
750 %files -n usbip-devel
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libusbip.so
753 %{_includedir}/usbip
754
755 %files -n usbip-static
756 %defattr(644,root,root,755)
757 %{_libdir}/libusbip.a
758 %endif
This page took 0.486859 seconds and 4 git commands to generate.