]> git.pld-linux.org Git - packages/kernel-tools.git/blob - kernel-tools.spec
BR: linux-libc-headers >= 7:4.8
[packages/kernel-tools.git] / kernel-tools.spec
1 # TODO:
2 # - redefine: PACKAGE_BUGREPORT=cpufreq@vger.kernel.org
3 # - add -n python-perf?
4 # - add bcond to disable building docs (perf docs)
5 # - install of perf links perf binary again
6
7 # Conditional build:
8 %bcond_without  verbose         # verbose build (V=1)
9 %bcond_without  cpupower        # cpupower tools
10 %bcond_without  perf            # perf tools
11 %bcond_without  gtk             # GTK+ 2.x perf support
12 %bcond_without  libunwind       # libunwind perf support
13 %bcond_without  multilib        # multilib perf support
14 %bcond_without  usbip           # usbip utils
15
16 %ifarch x32
17 %undefine       with_libunwind
18 %endif
19 %ifnarch %{x8664}
20 %undefine       with_multilib
21 %endif
22
23 %define         basever         4.8
24 %define         postver         .1
25 Summary:        Assortment of tools for the Linux kernel
26 Summary(pl.UTF-8):      Zestaw narzędzi dla jądra Linuksa
27 Name:           kernel-tools
28 Version:        %{basever}%{postver}
29 Release:        3
30 License:        GPL v2
31 Group:          Applications/System
32 Source0:        https://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
33 # Source0-md5:  c1af0afbd3df35c1ccdc7a5118cd2d07
34 Source1:        cpupower.service
35 Source2:        cpupower.config
36 %if "%{postver}" != ".0"
37 Patch0:         https://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
38 # Patch0-md5:   349734be5387f1605074515ad7207627
39 %endif
40 Patch1:         x32.patch
41 Patch2:         %{name}-format.patch
42 URL:            http://www.kernel.org/
43 BuildRequires:  bison
44 BuildRequires:  flex
45 BuildRequires:  gettext-tools
46 BuildRequires:  ncurses-devel
47 BuildRequires:  pciutils-devel
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpmbuild(macros) >= 1.647
50 BuildRequires:  tar >= 1:1.22
51 BuildRequires:  xz
52 %if %{with perf}
53 BuildRequires:  asciidoc
54 BuildRequires:  audit-libs-devel
55 BuildRequires:  binutils-devel
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  docbook-style-xsl
58 BuildRequires:  elfutils-devel
59 BuildRequires:  linux-libc-headers >= 7:4.8
60 %if %{with multilib}
61 BuildRequires:  gcc-multilib-32
62 BuildRequires:  gcc-multilib-x32
63 %endif
64 %{?with_libunwind:BuildRequires:        libunwind-devel >= 0.99}
65 BuildRequires:  numactl-devel
66 BuildRequires:  perl-devel >= 5.1
67 BuildRequires:  python-devel
68 BuildRequires:  rpm-pythonprov
69 BuildRequires:  slang-devel
70 BuildRequires:  xmlto
71 %if %{with gtk}
72 BuildRequires:  gtk+2-devel >= 2.0
73 %endif
74 %endif
75 %if %{with usbip}
76 BuildRequires:  autoconf >= 2.59
77 BuildRequires:  automake >= 1:1.9
78 BuildRequires:  gcc >= 6:4.0
79 BuildRequires:  libtool >= 2:2
80 BuildRequires:  libwrap-devel
81 BuildRequires:  udev-devel
82 %endif
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # otherwise /usr/lib/rpm/bin/debugedit: canonicalization unexpectedly shrank by one character
86 %define         _enable_debug_packages  0
87
88 %define         makeopts        CC="%{__cc}" %{?with_verbose:V=1}
89
90 %description
91 This package contains the software from tools/ subdirectory from Linux
92 kernel source and the supporting documentation.
93
94 %description -l pl.UTF-8
95 Ten pakiet zawiera oprogramowanie z podkatalogu tools/ ze źródeł jądra
96 Linuksa oraz związaną z nim dokumentację.
97
98 %package cpupower
99 Summary:        cpupower - Shows and sets processor power related values
100 Summary(pl.UTF-8):      cpupower - wyświetlanie i ustawianie wartości związanych z zużyciem energii przez procesor
101 Group:          Applications/System
102 Requires(post,preun,postun):    systemd-units >= 38
103 Requires:       %{name}-cpupower-libs = %{version}-%{release}
104 Requires:       systemd-units >= 0.38
105 Provides:       cpupowerutils = 1:009-0.6.p1
106 Obsoletes:      cpupowerutils < 1:009-0.6.p1
107 Obsoletes:      cpuspeed < 1:1.5-16
108
109 %description cpupower
110 cpupower is a collection of tools to examine and tune power saving
111 related features of your processor.
112
113 %description cpupower -l pl.UTF-8
114 cpupower to zbiór narzędzi do sprawdzania i ustawiania opcji procesora
115 związanych z oszczędzaniem energii.
116
117 %package cpupower-libs
118 Summary:        cpupower library
119 Summary(pl.UTF-8):      Biblioteka cpupower
120 Group:          Libraries
121
122 %description cpupower-libs
123 cpupower library.
124
125 %description cpupower-libs -l pl.UTF-8
126 Biblioteka cpupower.
127
128 %package cpupower-libs-devel
129 Summary:        Development files for the cpupower library
130 Summary(pl.UTF-8):      Pliki programistyczne biblioteki cpupower
131 Group:          Development/Libraries
132 Requires:       %{name}-cpupower-libs = %{version}-%{release}
133 Provides:       cpupowerutils-devel = 1:009-0.6.p1
134 Obsoletes:      cpupowerutils-devel < 1:009-0.6.p1
135 Conflicts:      cpufrequtils-devel
136
137 %description cpupower-libs-devel
138 Development files for the cpupower library.
139
140 %description cpupower-libs-devel -l pl.UTF-8
141 Pliki programistyczne biblioteki cpupower.
142
143 %package hv
144 Summary:        Hyper-V virtualization tools
145 Summary(pl.UTF-8):      Narzędzia do wirtualizacji Hyper-V
146 Group:          Applications/System
147
148 %description hv
149 Hyper-V virtualization tools.
150
151 %description hv -l pl.UTF-8
152 Narzędzia do wirtualizacji Hyper-V.
153
154 %package perf
155 Summary:        perf profiler tool
156 Summary(pl.UTF-8):      Narzędzie profilujące perf
157 Group:          Applications/System
158 Suggests:       binutils
159 Obsoletes:      perf-core
160 Obsoletes:      perf-slang
161
162 %description perf
163 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
164 away CPU hardware differences in Linux performance measurements and
165 presents a simple commandline interface. Perf is based on the
166 perf_events interface exported by recent versions of the Linux kernel.
167
168 This package contains core files, scripts and text interface (TUI).
169
170 %description perf -l pl.UTF-8
171 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
172 odseparowujące od różnic sprzętowych między pomiarami wydajności w
173 zależności od procesora oraz udostępniające prosty interfejs linii
174 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
175 przez nowe wersje jądra Linuksa.
176
177 Ten pakiet zawiera podstawowe pliki, skrypty oraz interfejs tekstowy
178 (TUI).
179
180 %package perf-vdso32
181 Summary:        perf profiler tool - VDSO 32-bit ABI reader
182 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI 32-bitowego
183 Group:          Applications/System
184 Requires:       %{name}-perf = %{version}-%{release}
185
186 %description perf-vdso32
187 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
188 away CPU hardware differences in Linux performance measurements and
189 presents a simple commandline interface. Perf is based on the
190 perf_events interface exported by recent versions of the Linux kernel.
191
192 This package contains perf-read-vdso32 tool for reading the 32-bit
193 compatibility VDSO in 64-bit mode.
194
195 %description perf-vdso32 -l pl.UTF-8
196 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
197 odseparowujące od różnic sprzętowych między pomiarami wydajności w
198 zależności od procesora oraz udostępniające prosty interfejs linii
199 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
200 przez nowe wersje jądra Linuksa.
201
202 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
203 binariów 32-bitowych w trybie 64-bitowym.
204
205 %package perf-vdsox32
206 Summary:        perf profiler tool - VDSO x32 ABI reader
207 Summary(pl.UTF-8):      Narzędzie profilujące perf - odczyt VDSO dla ABI x32
208 Group:          Applications/System
209 Requires:       %{name}-perf = %{version}-%{release}
210
211 %description perf-vdsox32
212 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
213 away CPU hardware differences in Linux performance measurements and
214 presents a simple commandline interface. Perf is based on the
215 perf_events interface exported by recent versions of the Linux kernel.
216
217 This package contains perf-read-vdso32 tool for reading the x32 mode
218 32-bit compatibility VDSO in 64-bit mode.
219
220 %description perf-vdsox32 -l pl.UTF-8
221 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
222 odseparowujące od różnic sprzętowych między pomiarami wydajności w
223 zależności od procesora oraz udostępniające prosty interfejs linii
224 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
225 przez nowe wersje jądra Linuksa.
226
227 Ten pakiet zawiera narzędzie perf-read-vdso32 do odczytu VDSO dla
228 binariów ABI x32 w trybie 64-bitowym.
229
230 %package perf-gtk
231 Summary:        perf profiler tool (GTK+ 2 GUI)
232 Summary(pl.UTF-8):      Narzędzie profilujące perf (interfejs graficzny GTK+ 2)
233 Group:          X11/Applications
234 Requires:       %{name}-perf = %{version}-%{release}
235
236 %description perf-gtk
237 Perf is a profiler tool for Linux 2.6+ based systems that abstracts
238 away CPU hardware differences in Linux performance measurements and
239 presents a simple commandline interface. Perf is based on the
240 perf_events interface exported by recent versions of the Linux kernel.
241
242 This package contains GTK+ 2 based GUI.
243
244 %description perf-gtk -l pl.UTF-8
245 Perf to narzędzie profilujące dla systemów opartych na Linuksie 2.6+,
246 odseparowujące od różnic sprzętowych między pomiarami wydajności w
247 zależności od procesora oraz udostępniające prosty interfejs linii
248 poleceń. Perf jest oparty na interfejsie perf_events eksportowanym
249 przez nowe wersje jądra Linuksa.
250
251 Ten pakiet zawiera graficzny interfejs oparty na GTK+ 2.
252
253 %package -n bash-completion-perf
254 Summary:        Bash completion for perf command
255 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla polecenia perf
256 Group:          Applications/Shells
257 Requires:       %{name}-perf
258 Requires:       bash-completion
259 %if "%{_rpmversion}" >= "5"
260 BuildArch:      noarch
261 %endif
262
263 %description -n bash-completion-perf
264 Bash completion for perf command.
265
266 %description -n bash-completion-perf -l pl.UTF-8
267 Bashowe uzupełnianie parametrów dla polecenia perf.
268
269 %package -n usbip
270 Summary:        USB device sharing system over IP network
271 Summary(pl.UTF-8):      System współdzielenia urządzeń USB po sieci IP
272 Group:          Networking/Utilities
273 Requires:       usbip-libs = %{version}-%{release}
274 # /lib/hwdata/usb.ids (note: only uncompressed file supported)
275 Requires:       hwdata >= 0.243-2
276
277 %description -n usbip
278 The USB/IP Project aims to develop a general USB device sharing system
279 over IP network. To share USB devices between computers with their
280 full functionality, USB/IP encapsulates "USB requests" into IP packets
281 and transmits them between computers. Original USB device drivers and
282 applications can be also used for remote USB devices without any
283 modification of them. A computer can use remote USB devices as if they
284 were directly attached; for example, we can:
285  - USB storage devices: fdisk, mkfs, mount/umount, file operations,
286    play a DVD movie and record a DVD-R media.
287  - USB keyboards and USB mice: use with Linux console and X Window
288    System.
289  - USB webcams and USB speakers: view webcam, capture image data and
290    play some music.
291  - USB printers, USB scanners, USB serial converters and USB Ethernet
292    interfaces: ok, use fine.
293
294 %description -n usbip -l pl.UTF-8
295 Projekt USB/IP ma na celu stworzenie ogólnego systemu współdzielenia
296 urządzeń USB po sieci IP. W celu współdzielenia urządzeń USB między
297 komputerami z zachowaniem pełnej funkcjonalności, USB/IP obudowuje
298 żądania SUB w pakiety IP i przesyła je między komputerami. Oryginalne
299 sterowniki urządzeń USB oraz aplikacje mogą być używane bez żadnych
300 modyfikacji. Komputer może wykorzystywać zdaln urządzenia USB tak,
301 jakby były podłączone bezpośrednio. Przykładowe możliwości:
302  - urządzenia USB do przechowywania danych: można używać programów
303    fdisk, mkfs, mount/umount, operacji na plikach, odtwarzać filmy
304    DVD oraz nagrywać nośniki DVD-R
305  - klawiatury i myszy USB: można ich używać na linuksowej konsoli oraz
306    w systemie X Window
307  - kamery i głośniki USB: można oglądać obraz z kamery, robić zdjęcia
308    i odtwarzać muzykę
309  - drukarki, skanery, konwertery portów szeregowych oraz interfejsy
310    sieciowe USB: można ich normalnie używać
311
312 %package -n usbip-libs
313 Summary:        USB/IP library
314 Summary(pl.UTF-8):      Biblioteka USB/IP
315 Group:          Libraries
316
317 %description -n usbip-libs
318 USB over IP library.
319
320 %description -n usbip-libs -l pl.UTF-8
321 Biblioteka USB po IP.
322
323 %package -n usbip-devel
324 Summary:        Header files for usbip library
325 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki usbip
326 Group:          Development/Libraries
327 Requires:       usbip-libs = %{version}-%{release}
328
329 %description -n usbip-devel
330 This package contains the header files needed to develop programs
331 which make use of USB/IP.
332
333 %description -n usbip-devel -l pl.UTF-8
334 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
335 wykorzystujących USB/IP.
336
337 %package -n usbip-static
338 Summary:        Static usbip library
339 Summary(pl.UTF-8):      Statyczna biblioteka usbip
340 Group:          Development/Libraries
341 Requires:       usbip-devel = %{version}-%{release}
342
343 %description -n usbip-static
344 Static usbip library.
345
346 %description -n usbip-static -l pl.UTF-8
347 Statyczna biblioteka usbip.
348
349 %prep
350 %setup -qc
351 cd linux-%{basever}
352
353 %if "%{postver}" != ".0"
354 %patch0 -p1
355 %endif
356
357 %patch1 -p1
358 %patch2 -p1
359
360 %{__sed} -i -e '/^CFLAGS = /s/ -g / $(OPTFLAGS) /' tools/hv/Makefile
361 %{__sed} -i -e '/^CFLAGS+=/s/ -O1 / $(OPTFLAGS) /' tools/thermal/tmon/Makefile
362 %{__sed} -i -e 's#libexec/perf-core#%{_datadir}/perf-core#g' tools/perf/Makefile.config
363
364 %build
365 cd linux-%{basever}
366
367 # Simple Disk Sleep Monitor
368 %{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags} Documentation/laptops/dslm.c -o dslm
369
370 # tools common (used eg. by tools/vm)
371 %{__make} -C tools/lib/api \
372         %{makeopts} \
373         EXTRA_CFLAGS="%{rpmcflags}"
374
375 # lsgpio
376 CFLAGS="%{rpmcflags}" \
377 %{__make} -C tools/gpio -j1 \
378         %{makeopts}
379
380 # HyperV is Windows based, x86 specific
381 %ifarch %{ix86} %{x8664} x32
382 %{__make} -C tools/hv \
383         CC="%{__cc}" \
384         OPTFLAGS="%{rpmcflags}"
385 %endif
386
387 CFLAGS="%{rpmcflags}" \
388 %{__make} -C tools/iio \
389         CC="%{__cc}"
390
391 %{__make} -C tools/laptop/freefall \
392         CC="%{__cc}" \
393         CFLAGS="%{rpmcflags}"
394
395 %ifarch %{ix86}
396 # drivers/lguest is x86-32 only
397 %{__make} -C tools/lguest \
398         CC="%{__cc}" \
399         CFLAGS="%{rpmcflags} -Wall -U_FORTIFY_SOURCE -Iinclude"
400 %endif
401
402 CFLAGS="%{rpmcflags}" \
403 %{__make} -C tools/net \
404         CC="%{__cc}"
405
406 # perf
407 %if %{with perf}
408 %{__make} -C tools/perf all man \
409 %ifarch %{x8664}
410         IS_X86_64=1 \
411         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
412 %endif
413         %{!?with_gtk:NO_GTK2=1} \
414         %{!?with_libunwind:NO_LIBUNWIND=1} \
415         %{makeopts} \
416         CFLAGS_OPTIMIZE="%{rpmcflags}" \
417         WERROR=0 \
418         prefix=%{_prefix} \
419         perfexecdir=%{_datadir}/perf-core \
420         lib=%{_lib} \
421         template_dir=%{_datadir}/perf-core/templates
422 %endif
423
424 # cpupower
425 %if %{with cpupower}
426 %{__make} -C tools/power/cpupower \
427         %{makeopts} \
428         CPUFREQ_BENCH=false \
429         OPTIMIZATION="%{rpmcflags}" \
430         STRIPCMD=true
431
432 %ifarch %{ix86} x32
433 %{__make} -C tools/power/cpupower/debug/i386 centrino-decode powernow-k8-decode \
434         CC="%{__cc}" \
435         CFLAGS="%{rpmcflags}"
436 %endif
437
438 %ifarch %{x8664} x32
439 %{__make} -C tools/power/cpupower/debug/x86_64 centrino-decode powernow-k8-decode \
440         CC="%{__cc}" \
441         CFLAGS="%{rpmcflags}"
442 %endif
443 %endif
444
445 %ifarch %{ix86} %{x8664} x32
446 %{__make} -C tools/power/x86/x86_energy_perf_policy \
447         CC="%{__cc}" \
448         CFLAGS="%{rpmcflags}"
449 CFLAGS="%{rpmcflags}" \
450 %{__make} -C tools/power/x86/turbostat \
451         CC="%{__cc}"
452 %endif
453
454 %{__make} -C tools/thermal/tmon \
455         CC="%{__cc}" \
456         OPTFLAGS="%{rpmcflags}"
457
458 # usbip-utils
459 %if %{with usbip}
460 cd tools/usb/usbip
461 %{__libtoolize}
462 %{__aclocal}
463 %{__autoconf}
464 %{__autoheader}
465 %{__automake}
466 %configure \
467         --disable-silent-rules \
468         --with-usbids-dir=/lib/hwdata
469 %{__make}
470 cd ../../..
471 %endif
472
473 # page-types, slabinfo
474 %{__make} -C tools/vm page-types slabinfo \
475         CC="%{__cc}" \
476         CFLAGS="%{rpmcflags} -Wall -Wextra -I../lib"
477
478 # gen_init_cpio
479 %{__make} -C usr gen_init_cpio \
480         %{makeopts} \
481         CFLAGS="%{rpmcflags}"
482
483 %install
484 rm -rf $RPM_BUILD_ROOT
485
486 cd linux-%{basever}
487
488 %if %{with cpupower}
489 %{__make} -C tools/power/cpupower install \
490         DESTDIR=$RPM_BUILD_ROOT \
491         libdir=%{_libdir} \
492         mandir=%{_mandir} \
493         CPUFREQ_BENCH=false
494
495 %find_lang cpupower
496 mv cpupower.lang ..
497
498 install -d $RPM_BUILD_ROOT{/etc/sysconfig,%{systemdunitdir}}
499 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/cpupower.service
500 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/cpupower
501
502 %ifarch %{ix86} x32
503 install -p tools/power/cpupower/debug/i386/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
504 %endif
505 %ifarch %{x8664} x32
506 install -p tools/power/cpupower/debug/x86_64/{centrino,powernow-k8}-decode $RPM_BUILD_ROOT%{_bindir}
507 %endif
508 %endif
509
510 %if %{with perf}
511 %{__make} -C tools/perf -j1 install install-man \
512 %ifarch %{x8664}
513         IS_X86_64=1 \
514         %{!?with_multilib:NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1} \
515 %endif
516         %{!?with_gtk:NO_GTK2=1} \
517         %{!?with_libunwind:NO_LIBUNWIND=1} \
518         CC="%{__cc}" \
519         CFLAGS_OPTIMIZE="%{rpmcflags}" \
520         WERROR=0 \
521         %{?with_verbose:V=1} \
522         prefix=%{_prefix} \
523         perfexecdir=%{_datadir}/perf-core \
524         template_dir=%{_datadir}/perf-core/templates \
525         lib=%{_lib} \
526         DESTDIR=$RPM_BUILD_ROOT
527
528 %py_comp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
529 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/perf-core/scripts/python
530
531 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/perf-core/tests
532 %endif
533
534 %if %{with usbip}
535 %{__make} -C tools/usb/usbip install \
536         DESTDIR=$RPM_BUILD_ROOT
537
538 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libusbip.la
539 %endif
540
541 install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man8}
542
543 install -p dslm $RPM_BUILD_ROOT%{_sbindir}
544
545 install -p tools/gpio/lsgpio $RPM_BUILD_ROOT%{_bindir}
546
547 %ifarch %{ix86} %{x8664} x32
548 install -p tools/hv/hv_{fcopy,kvp,vss}_daemon $RPM_BUILD_ROOT%{_sbindir}
549 # TODO: PLD-specific hv_get_dhcp_info,hv_get_dns_info,hv_set_ifconfig
550 %{__sed} -e '1s,/usr/bin/env python,%{__python},' tools/hv/lsvmbus >$RPM_BUILD_ROOT%{_bindir}/lsvmbus
551 chmod 755 $RPM_BUILD_ROOT%{_bindir}/lsvmbus
552 %endif
553
554 install -p tools/iio/{iio_event_monitor,iio_generic_buffer,lsiio} $RPM_BUILD_ROOT%{_bindir}
555
556 install -p tools/laptop/freefall/freefall $RPM_BUILD_ROOT%{_sbindir}
557
558 %ifarch %{ix86}
559 install -p tools/lguest/lguest $RPM_BUILD_ROOT%{_bindir}
560 %endif
561
562 install -p tools/net/{bpf_asm,bpf_dbg,bpf_jit_disasm} $RPM_BUILD_ROOT%{_bindir}
563
564 install -p tools/thermal/tmon/tmon $RPM_BUILD_ROOT%{_bindir}
565 cp -p tools/thermal/tmon/tmon.8 $RPM_BUILD_ROOT%{_mandir}/man8
566
567 install -p tools/vm/slabinfo $RPM_BUILD_ROOT%{_bindir}
568 install -p tools/vm/page-types $RPM_BUILD_ROOT%{_sbindir}
569
570 %ifarch %{ix86} %{x8664} x32
571 install -d $RPM_BUILD_ROOT%{_mandir}/man8
572 %{__make} -C tools/power/x86/x86_energy_perf_policy install \
573         DESTDIR=$RPM_BUILD_ROOT
574
575 %{__make} -C tools/power/x86/turbostat install \
576         DESTDIR=$RPM_BUILD_ROOT
577 %endif
578
579 # gen_init_cpio
580 install -p usr/gen_init_cpio $RPM_BUILD_ROOT%{_bindir}/gen_init_cpio
581
582 %clean
583 rm -rf $RPM_BUILD_ROOT
584
585 %post   cpupower-libs -p /sbin/ldconfig
586 %postun cpupower-libs -p /sbin/ldconfig
587
588 %post cpupower
589 %systemd_post cpupower.service
590
591 %preun cpupower
592 %systemd_preun cpupower.service
593
594 %postun cpupower
595 %systemd_reload
596
597 %post   -n usbip-libs -p /sbin/ldconfig
598 %postun -n usbip-libs -p /sbin/ldconfig
599
600 %files
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_bindir}/bpf_asm
603 %attr(755,root,root) %{_bindir}/bpf_dbg
604 %attr(755,root,root) %{_bindir}/bpf_jit_disasm
605 %attr(755,root,root) %{_bindir}/gen_init_cpio
606 %attr(755,root,root) %{_bindir}/iio_event_monitor
607 %attr(755,root,root) %{_bindir}/iio_generic_buffer
608 %attr(755,root,root) %{_bindir}/lsgpio
609 %attr(755,root,root) %{_bindir}/lsiio
610 %attr(755,root,root) %{_bindir}/slabinfo
611 %attr(755,root,root) %{_bindir}/tmon
612 %attr(755,root,root) %{_sbindir}/dslm
613 %attr(755,root,root) %{_sbindir}/freefall
614 %attr(755,root,root) %{_sbindir}/page-types
615 %{_mandir}/man8/tmon.8*
616 %ifarch %{ix86}
617 %doc linux-%{basever}/tools/lguest/lguest.txt
618 %attr(755,root,root) %{_bindir}/lguest
619 %endif
620 %ifarch %{ix86} %{x8664} x32
621 %attr(755,root,root) %{_bindir}/centrino-decode
622 %attr(755,root,root) %{_bindir}/powernow-k8-decode
623 %endif
624 %ifarch %{ix86} %{x8664} x32
625 %attr(755,root,root) %{_bindir}/turbostat
626 %attr(755,root,root) %{_bindir}/x86_energy_perf_policy
627 %{_mandir}/man8/turbostat.8*
628 %{_mandir}/man8/x86_energy_perf_policy.8*
629 %endif
630
631 %files cpupower -f cpupower.lang
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_bindir}/cpupower
634 %{_mandir}/man1/cpupower*.1*
635 %{systemdunitdir}/cpupower.service
636 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cpupower
637
638 %files cpupower-libs
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/libcpupower.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libcpupower.so.0
642
643 %files cpupower-libs-devel
644 %defattr(644,root,root,755)
645 %attr(755,root,root) %{_libdir}/libcpupower.so
646 %{_includedir}/cpufreq.h
647 %{_includedir}/cpuidle.h
648
649 %ifarch %{ix86} %{x8664} x32
650 %files hv
651 %defattr(644,root,root,755)
652 # TODO: PLDify these scripts and move to bindir
653 %doc linux-%{basever}/tools/hv/hv_{get_dhcp_info,get_dns_info,set_ifconfig}.sh
654 %attr(755,root,root) %{_bindir}/lsvmbus
655 %attr(755,root,root) %{_sbindir}/hv_fcopy_daemon
656 %attr(755,root,root) %{_sbindir}/hv_kvp_daemon
657 %attr(755,root,root) %{_sbindir}/hv_vss_daemon
658 %endif
659
660 %if %{with perf}
661 %files perf
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_bindir}/perf
664 %attr(755,root,root) %{_bindir}/trace
665 %{_mandir}/man1/perf*.1*
666 %dir %{_datadir}/perf-core
667 %attr(755,root,root) %{_datadir}/perf-core/perf-archive
668 %attr(755,root,root) %{_datadir}/perf-core/perf-with-kcore
669
670 %dir %{_datadir}/perf-core/scripts
671
672 %dir %{_datadir}/perf-core/scripts/perl
673 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util
674 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib
675 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf
676 %dir %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace
677 %{_datadir}/perf-core/scripts/perl/Perf-Trace-Util/lib/Perf/Trace/*.pm
678 %dir %{_datadir}/perf-core/scripts/perl/bin
679 %attr(755,root,root) %{_datadir}/perf-core/scripts/perl/bin/*
680 %{_datadir}/perf-core/scripts/perl/*.pl
681
682 %dir %{_datadir}/perf-core/scripts/python
683 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util
684 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib
685 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf
686 %dir %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace
687 %{_datadir}/perf-core/scripts/python/Perf-Trace-Util/lib/Perf/Trace/*.py*
688 %dir %{_datadir}/perf-core/scripts/python/bin
689 %attr(755,root,root) %{_datadir}/perf-core/scripts/python/bin/*
690 %{_datadir}/perf-core/scripts/python/*.py*
691
692 %dir %{_libdir}/traceevent
693 %dir %{_libdir}/traceevent/plugins
694 %attr(755,root,root) %{_libdir}/traceevent/plugins/plugin_*.so
695
696 %if %{with multilib}
697 %files perf-vdso32
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/perf-read-vdso32
700
701 %files perf-vdsox32
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_bindir}/perf-read-vdsox32
704 %endif
705
706 %if %{with gtk}
707 %files perf-gtk
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/libperf-gtk.so
710 %endif
711
712 %files -n bash-completion-perf
713 %defattr(644,root,root,755)
714 /etc/bash_completion.d/perf
715 %endif
716
717 %if %{with usbip}
718 %files -n usbip
719 %defattr(644,root,root,755)
720 %doc linux-%{basever}/tools/usb/usbip/{AUTHORS,README}
721 %attr(755,root,root) %{_sbindir}/usbip
722 %attr(755,root,root) %{_sbindir}/usbipd
723 %{_mandir}/man8/usbip.8*
724 %{_mandir}/man8/usbipd.8*
725
726 %files -n usbip-libs
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/libusbip.so.*.*.*
729 %attr(755,root,root) %ghost %{_libdir}/libusbip.so.0
730
731 %files -n usbip-devel
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libusbip.so
734 %{_includedir}/usbip
735
736 %files -n usbip-static
737 %defattr(644,root,root,755)
738 %{_libdir}/libusbip.a
739 %endif
This page took 0.119741 seconds and 4 git commands to generate.