]> git.pld-linux.org Git - packages/kdenlive.git/blob - kdenlive.spec
67cc6bcc4769026e14d3652ae5e9751af6bd020f
[packages/kdenlive.git] / kdenlive.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      24.02.2
5 %define         qtver           5.15.2
6 %define         kaname          kdenlive
7 Summary:        KDE movie editor
8 Summary(pl.UTF-8):      Edytor filmów dla KDE
9 Name:           kdenlive
10 Version:        24.02.2
11 Release:        1
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  ae03ea95bc510c92735b818d10033364
16 URL:            http://kdenlive.org/
17 BuildRequires:  Qt6Concurrent-devel
18 BuildRequires:  Qt6Core-devel
19 BuildRequires:  Qt6DBus-devel
20 BuildRequires:  Qt6Gui-devel
21 BuildRequires:  Qt6Multimedia-devel
22 BuildRequires:  Qt6Network-devel
23 BuildRequires:  Qt6NetworkAuth-devel
24 BuildRequires:  Qt6Qml-devel
25 BuildRequires:  Qt6Quick-devel
26 BuildRequires:  Qt6Svg-devel
27 BuildRequires:  Qt6Widgets-devel
28 BuildRequires:  cmake >= 3.20
29 BuildRequires:  gettext-tools
30 BuildRequires:  kf6-attica-devel
31 BuildRequires:  kf6-karchive-devel
32 BuildRequires:  kf6-kbookmarks-devel
33 BuildRequires:  kf6-kconfig-devel
34 BuildRequires:  kf6-kconfigwidgets-devel
35 BuildRequires:  kf6-kcoreaddons-devel
36 BuildRequires:  kf6-kcrash-devel
37 BuildRequires:  kf6-kdbusaddons-devel
38 BuildRequires:  kf6-kdeclarative-devel
39 BuildRequires:  kf6-kdoctools-devel
40 BuildRequires:  kf6-kfilemetadata-devel
41 BuildRequires:  kf6-kguiaddons-devel
42 BuildRequires:  kf6-ki18n-devel
43 BuildRequires:  kf6-kiconthemes-devel
44 BuildRequires:  kf6-kio-devel
45 BuildRequires:  kf6-knewstuff-devel
46 BuildRequires:  kf6-knotifications-devel
47 BuildRequires:  kf6-knotifyconfig-devel
48 BuildRequires:  kf6-kplotting-devel
49 BuildRequires:  kf6-ktextwidgets-devel
50 BuildRequires:  kf6-kwidgetsaddons-devel
51 BuildRequires:  kf6-kxmlgui-devel
52 BuildRequires:  kf6-purpose-devel
53 BuildRequires:  kf6-sonnet-devel
54 BuildRequires:  libv4l-devel
55 BuildRequires:  mlt-devel >= 7.14.0
56 BuildRequires:  ninja
57 BuildRequires:  pkgconfig
58 BuildRequires:  qjson-devel >= 0.5
59 BuildRequires:  rpmbuild(macros) >= 1.129
60 BuildRequires:  rttr-devel
61 BuildRequires:  shared-desktop-ontologies-devel
62 BuildRequires:  soprano-devel
63 BuildConflicts: gstreamer0.10
64 Requires:       %{name}-data = %{version}-%{release}
65 Requires:       Qt6Quick
66 Suggests:       dvdauthor
67 Suggests:       dvgrab
68 Suggests:       ffmpeg-ffplay
69 Suggests:       frei0r-plugins
70 Suggests:       mlt >= 7.12.0
71 Suggests:       recordmydesktop
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 Kdenlive is a non-linear video editor for KDE. It provides all project
76 management and editing tools while relying on a separate rendering
77 program (currently PIAVE) to perform the editing operations. Support
78 is planned for transitions, effects, multiple file formats, and full
79 project and asset management support. The current beta is capable of
80 editing raw DV or AVI DV files, with tools such as move, razor, and
81 resize, selecting parts of clips using in/outpoints, and exporting the
82 result to another raw DV file. You may playback/preview the contents
83 of the timeline at any point during the edit. Full project save/load
84 is supported.
85
86 %description -l pl.UTF-8
87 Kdenlive to nieliniowy edytor filmów dla KDE. Dostarcza narzędzia do
88 zarządzania projektem i edycji polegające na oddzielnym programie
89 renderującym (aktualnie PIAVE) do wykonywania operacji edycji.
90 Planowana jest obsługa przejść, efektów, wielu formatów plików
91 oraz pełnego zarządzania projektem i kapitałem. Aktualna wersja
92 beta może modyfikować pliki w formacie surowego DV oraz AVI DV przy
93 użyciu narzędzi takich jak przemieszczanie, cięcia, zmiana
94 rozmiaru, wybieranie części klatek przy użyciu punktów
95 wejściowych/wyjściowych oraz eksportowanie wyniku do innego pliku w
96 formacie surowego DV. Można odtwarzać/podglądać zawartość w
97 dowolnej chwili edycji. Obsługiwany jest zapis/odczyt pełnego
98 projektu.
99
100 %package data
101 Summary:        Data files for %{kaname}
102 Summary(pl.UTF-8):      Dane dla %{kaname}
103 Group:          X11/Applications/Multimedia
104 BuildArch:      noarch
105
106 %description data
107 Data files for %{kaname}.
108
109 %description data -l pl.UTF-8
110 Dane dla %{kaname}.
111
112 %prep
113 %setup -q
114
115 %build
116 %cmake \
117         -B build \
118         -G Ninja \
119         %{!?with_tests:-DBUILD_TESTING=OFF} \
120         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
121         -DKDE_INSTALL_DOCBUNDLEDIR=%{_kdedocdir} \
122         -DPLUGIN_INSTALL_DIR=%{_libdir}/qt5/plugins
123
124 %ninja_build -C build
125
126 %if %{with tests}
127 ctest --test-dir build
128 %endif
129
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %ninja_install -C build
135
136 %find_lang %{kaname} --all-name --with-kde
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/%{name}*
144 %attr(755,root,root) %{_libdir}/qt6/plugins/kf6/thumbcreator/mltpreview.so
145
146 %files data  -f %{kaname}.lang
147 %defattr(644,root,root,755)
148 %{_datadir}/metainfo/org.kde.kdenlive.appdata.xml
149 %{_datadir}/config.kcfg/kdenlivesettings.kcfg
150 %{_datadir}/knotifications6/kdenlive.notifyrc
151 %{_datadir}/mime/packages/*.xml
152 %{_datadir}/%{name}
153 %{_desktopdir}/org.kde.kdenlive.desktop
154 %{_iconsdir}/*/*/*/*.png
155 %{_iconsdir}/*/*/*/*.svg
156 %{_iconsdir}/*/*/*/*.svgz
157 %{_mandir}/man1/kdenlive*
158 %{_datadir}/knsrcfiles/*.knsrc
159 %{_datadir}/qlogging-categories6/kdenlive.categories
This page took 0.177927 seconds and 4 git commands to generate.