]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blob - kde4-kdevelop.spec
- changed QTCore to QtCore
[packages/ka5-kdevelop.git] / kde4-kdevelop.spec
1 #
2 # Conditional build:
3 #
4 %define         _state          unstable
5 %define         _kdever         4.1.96
6 %define         _qtver          4.4
7 %define         orgname         kdevelop
8
9 Summary:        KDE Integrated Development Environment
10 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
11 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
12 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
13 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
14 Name:           kde4-kdevelop
15 Version:        3.9.91
16 Release:        1
17 License:        GPL
18 Group:          X11/Development/Tools
19 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/kdevelop/%{version}/src/%{orgname}-%{version}.tar.bz2
20 # Source0-md5:  8fe4f166d0a56604f37c311b3d9d530c
21 URL:            http://www.kdevelop.org/
22 Patch0:         %{name}-libkio.patch
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.129
27 BuildRequires:  kde4-kdelibs-devel >= %{_kdever}
28 BuildRequires:  kde4-kdevplatform-devel >= 0.9.91
29 BuildRequires:  QtCore-devel >= %{_qtver}
30 BuildRequires:  QtDBus-devel >= %{_qtver}
31 BuildRequires:  QtDesigner-devel >= %{_qtver}
32 BuildRequires:  QtGui-devel >= %{_qtver}
33 BuildRequires:  QtNetwork-devel >= %{_qtver}
34 BuildRequires:  QtScript-devel >= %{_qtver}
35 BuildRequires:  QtTest-devel >= %{_qtver}
36 BuildRequires:  QtSvg-devel >= %{_qtver}
37 BuildRequires:  Qt3Support-devel >= %{_qtver}
38 BuildRequires:  perl-base >= 5.8
39 BuildRequires:  zlib-devel >= 1.2.0
40 BuildRequires:  libstdc++-devel >= 3.3
41 BuildRequires:  gcc-c++ >= 3.3
42 BuildConflicts: star
43 Requires:       kde4-kdebase-core >= %{_kdever}
44 Requires:       kde4-kdelibs >= %{_kdever}
45 Requires:       kde4-kdelibs-libs >= %{_kdever}
46 Requires:       QtCore >= %{_qtver}
47 Requires:       QtDBus >= %{_qtver}
48 Requires:       QtDesigner >= %{_qtver}
49 Requires:       QtGui >= %{_qtver}
50 Requires:       QtNetwork >= %{_qtver}
51 Requires:       QtScript >= %{_qtver}
52 Requires:       glibc   
53 Requires:       libgcc
54 Requires:       kde4-kdevplatform >= 0.9.91
55 Requires:       libstdc++ >= 3.3
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 The KDevelop Integrated Development Environment provides many features
60 that developers need as well as providing a unified interface to
61 programs like gdb, the C/C++ compiler, and make.
62
63 KDevelop manages or provides: all development tools needed for C++
64 programming like Compiler, Linker, automake and autoconf; KAppWizard,
65 which generates complete, ready-to-go sample applications;
66 Classgenerator, for creating new classes and integrating them into the
67 current project; File management for sources, headers, documentation
68 etc. to be included in the project; The creation of User-Handbooks
69 written with SGML and the automatic generation of HTML-output with the
70 KDE look and feel; Automatic HTML-based API-documentation for your
71 project's classes with cross-references to the used libraries;
72 Internationalization support for your application, allowing
73 translators to easily add their target language to a project;
74
75 KDevelop also includes WYSIWYG (What you see is what you get)-creation
76 of user interfaces with a built-in dialog editor; Debugging your
77 application by integrating KDbg; Editing of project-specific pixmaps
78 with KIconEdit; The inclusion of any other program you need for
79 development by adding it to the "Tools"-menu according to your
80 individual needs.
81
82 %description -l de.UTF-8
83 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
84
85 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
86 bedienende grafische (integrierte Entwicklungsumgebung) für C++ und C
87 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
88 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
89 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
90
91 %description -l pl.UTF-8
92 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
93 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
94 do programów typu gdb, kompilator C/C++ oraz make.
95
96 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
97 potrzebne do programowania w C++ jak kompilator, linker, automake,
98 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
99 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
100 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
101 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
102 i automatyczne generowanie wyjścia HTML pasującego do KDE;
103 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
104 odniesieniami do używanych bibliotek; wsparcie dla
105 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
106 tłumaczeniami do projektu.
107
108 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
109 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
110 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
111 potrzebnych do programowania przez dodanie ich do menu Tools według
112 własnych potrzeb.
113
114 %prep
115 %setup -q -n %{orgname}-%{version}
116 %patch0 -p1
117
118 %build
119 install -d build
120 cd build
121 %cmake \
122         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
123         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
124         ../
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 install -d $RPM_BUILD_ROOT%{_desktopdir}
131 %{__make} -C build install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         kde_htmldir=%{_kdedocdir}
134
135 install src/kdevelop.desktop $RPM_BUILD_ROOT%{_desktopdir}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/kdev_includepathresolver
146 %attr(755,root,root) %{_bindir}/kdevelop
147 %attr(755,root,root) %{_bindir}/lcov_geninfo
148 %attr(755,root,root) %{_bindir}/qmake-parser
149 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_cppdebugger.so
150 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_makebuilder.so
151 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_qmakebuilder.so
152 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_valgrindsettings.so
153 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_veritassettings.so
154 %attr(755,root,root) %{_libdir}/kde4/kcm_kdevcmake_settings.so
155 %attr(755,root,root) %{_libdir}/kde4/kdevastyle.so
156 %attr(755,root,root) %{_libdir}/kde4/kdevcmakebuilder.so
157 %attr(755,root,root) %{_libdir}/kde4/kdevcmakemanager.so
158 %attr(755,root,root) %{_libdir}/kde4/kdevcoverage.so
159 %attr(755,root,root) %{_libdir}/kde4/kdevcppdebugger.so
160 %attr(755,root,root) %{_libdir}/kde4/kdevcpplanguagesupport.so
161 %attr(755,root,root) %{_libdir}/kde4/kdevcustommakemanager.so
162 %attr(755,root,root) %{_libdir}/kde4/kdevdocumentview.so
163 %attr(755,root,root) %{_libdir}/kde4/kdevgrepview.so
164 %attr(755,root,root) %{_libdir}/kde4/kdevindent.so
165 %attr(755,root,root) %{_libdir}/kde4/kdevmakebuilder.so
166 %attr(755,root,root) %{_libdir}/kde4/kdevqmakebuilder.so
167 %attr(755,root,root) %{_libdir}/kde4/kdevqmakemanager.so
168 %attr(755,root,root) %{_libdir}/kde4/kdevqtdesigner.so
169 %attr(755,root,root) %{_libdir}/kde4/kdevqtestview.so
170 %attr(755,root,root) %{_libdir}/kde4/kdevvalgrind.so
171 %attr(755,root,root) %{_libdir}/libkdev4cmakecommon.so
172 %attr(755,root,root) %{_libdir}/libkdev4cppduchain.so
173 %attr(755,root,root) %{_libdir}/libkdev4cppparser.so
174 %attr(755,root,root) %{_libdir}/libkdev4cpprpp.so
175 %attr(755,root,root) %{_libdir}/libkdev4qmakeparser.so
176 %attr(755,root,root) %{_libdir}/libkdev4qmakeduchain.so
177 %attr(755,root,root) %{_libdir}/libkdevqtest.so
178 %attr(755,root,root) %{_libdir}/libkdevveritascoverage.so
179 %attr(755,root,root) %{_libdir}/libveritascpp.so
180 %{_desktopdir}/kdevelop.desktop
181
182 %{_datadir}/apps/cmake/modules/FindKDevelop.cmake
183 %{_datadir}/apps/cmake/modules/KDevelopMacros.cmake
184 %{_datadir}/apps/kdevappwizard
185 %{_datadir}/apps/kdevcmakebuilder
186 %{_datadir}/apps/kdevcmakemanager
187 %{_datadir}/apps/kdevcppdebugger
188 %{_datadir}/apps/kdevcustommakemanager
189 %{_datadir}/apps/kdevdocumentview
190 %{_datadir}/apps/kdevelop
191 %{_datadir}/apps/kdevgrepview
192 %{_datadir}/apps/kdevqmakebuilder
193 %{_datadir}/apps/kdevqtdesigner
194 %{_datadir}/apps/kdevvalgrind
195 %{_datadir}/config/kdeveloprc
196 %dir %{_datadir}/apps/kdevcppsupport
197 %{_datadir}/apps/kdevcppsupport/kdevcppsupport.rc
198 %dir %{_datadir}/apps/kdevcoverage
199 %{_datadir}/apps/kdevcoverage/kdevcoverage.rc
200 %dir %{_datadir}/apps/kdevqtest
201 %{_datadir}/apps/kdevqtest/kdevqtest.rc
202
203 %{_iconsdir}/*/*x*/*/*.png
204 %{_datadir}/kde4/services/kcm_kdev_cppdebugger.desktop
205 %{_datadir}/kde4/services/kcm_kdev_makebuilder.desktop
206 %{_datadir}/kde4/services/kcm_kdev_qmakebuilder.desktop
207 %{_datadir}/kde4/services/kcm_kdev_valgrindsettings.desktop
208 %{_datadir}/kde4/services/kcm_kdev_veritassettings.desktop
209 %{_datadir}/kde4/services/kcm_kdevcmake_settings.desktop
210 %{_datadir}/kde4/services/kdevastyle.desktop
211 %{_datadir}/kde4/services/kdevcmakebuilder.desktop
212 %{_datadir}/kde4/services/kdevcmakemanager.desktop
213 %{_datadir}/kde4/services/kdevcoverage.desktop
214 %{_datadir}/kde4/services/kdevcppdebugger.desktop
215 %{_datadir}/kde4/services/kdevcppsupport.desktop
216 %{_datadir}/kde4/services/kdevcustommakemanager.desktop
217 %{_datadir}/kde4/services/kdevdocumentview.desktop
218 %{_datadir}/kde4/services/kdevgrepview.desktop
219 %{_datadir}/kde4/services/kdevindent.desktop
220 %{_datadir}/kde4/services/kdevmakebuilder.desktop
221 %{_datadir}/kde4/services/kdevqmakebuilder.desktop
222 %{_datadir}/kde4/services/kdevqmakemanager.desktop
223 %{_datadir}/kde4/services/kdevqtdesigner.desktop
224 %{_datadir}/kde4/services/kdevqtest.desktop
225 %{_datadir}/kde4/services/kdevvalgrind.desktop
226 %{_datadir}/applications/kde4/kdevelop.desktop
227
228 %{_includedir}/kdevelop
This page took 0.042658 seconds and 4 git commands to generate.