]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blob - kde4-kdevelop.spec
- 4.0.65
[packages/ka5-kdevelop.git] / kde4-kdevelop.spec
1 #
2 # Conditional build:
3 #
4 %define         _state          unstable
5 %define         _kdever         4.0.65
6 %define         orgname         kdevelop
7
8 Summary:        KDE Integrated Development Environment
9 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
10 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
11 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
12 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
13 Name:           kde4-kdevelop
14 Version:        4.0.65
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Development/Tools
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
19 # Source0-md5:  2583086869269c1f91a7ccd8b0e60013
20 URL:            http://www.kdevelop.org/
21 # disabled, breaks with this new antlr
22 # BuildRequires:        antlr >= 2.7.3
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  db-devel
26 BuildRequires:  doxygen
27 BuildRequires:  flex
28 %{?with_ada:BuildRequires:gcc-ada}
29 BuildRequires:  gettext-devel
30 BuildRequires:  kde4-kdelibs-devel
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  libpng-devel
33 BuildRequires:  libtool
34 BuildRequires:  openssl-devel >= 0.9.7d
35 BuildRequires:  pcre-devel
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.129
38 BuildRequires:  subversion-devel >= 1.2.0-4
39 BuildRequires:  zlib-devel
40 BuildConflicts: star
41 Requires:       kde4-kdebase-core >= %{_minbaseevr}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 The KDevelop Integrated Development Environment provides many features
46 that developers need as well as providing a unified interface to
47 programs like gdb, the C/C++ compiler, and make.
48
49 KDevelop manages or provides: all development tools needed for C++
50 programming like Compiler, Linker, automake and autoconf; KAppWizard,
51 which generates complete, ready-to-go sample applications;
52 Classgenerator, for creating new classes and integrating them into the
53 current project; File management for sources, headers, documentation
54 etc. to be included in the project; The creation of User-Handbooks
55 written with SGML and the automatic generation of HTML-output with the
56 KDE look and feel; Automatic HTML-based API-documentation for your
57 project's classes with cross-references to the used libraries;
58 Internationalization support for your application, allowing
59 translators to easily add their target language to a project;
60
61 KDevelop also includes WYSIWYG (What you see is what you get)-creation
62 of user interfaces with a built-in dialog editor; Debugging your
63 application by integrating KDbg; Editing of project-specific pixmaps
64 with KIconEdit; The inclusion of any other program you need for
65 development by adding it to the "Tools"-menu according to your
66 individual needs.
67
68 %description -l de.UTF-8
69 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
70
71 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
72 bedienende grafische (integrierte Entwicklungsumgebung) für C++ und C
73 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
74 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
75 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
76
77 %description -l pl.UTF-8
78 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
79 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
80 do programów typu gdb, kompilator C/C++ oraz make.
81
82 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
83 potrzebne do programowania w C++ jak kompilator, linker, automake,
84 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
85 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
86 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
87 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
88 i automatyczne generowanie wyjścia HTML pasującego do KDE;
89 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
90 odniesieniami do używanych bibliotek; wsparcie dla
91 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
92 tłumaczeniami do projektu.
93
94 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
95 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
96 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
97 potrzebnych do programowania przez dodanie ich do menu Tools według
98 własnych potrzeb.
99
100 %prep
101 %setup -q -n %{orgname}-%{version}
102
103 %build
104 mkdir build
105 cd build
106 %cmake \
107         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
108         -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
109         ../
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 install -d $RPM_BUILD_ROOT%{_desktopdir}
116 %{__make} -C build install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         kde_htmldir=%{_kdedocdir}
119
120 install src/kdevelop.desktop $RPM_BUILD_ROOT%{_desktopdir}
121 #%find_lang %{name} --with-kde --all-name
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files
130 %defattr(644,root,root,755)
131 #-f %{name}.lang
132 %attr(755,root,root) %{_bindir}/kdev_includepathresolver
133 %attr(755,root,root) %{_bindir}/kdevelop
134 %attr(755,root,root) %{_bindir}/qmake-parser
135 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_cppdebugger.so
136 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_makebuilder.so
137 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_qmakebuilder.so
138 %attr(755,root,root) %{_libdir}/kde4/kcm_kdev_valgrindsettings.so
139 %attr(755,root,root) %{_libdir}/kde4/kcm_kdevcmake_settings.so
140 %attr(755,root,root) %{_libdir}/kde4/kdevappwizard.so
141 %attr(755,root,root) %{_libdir}/kde4/kdevcmakebuilder.so
142 %attr(755,root,root) %{_libdir}/kde4/kdevcmakemanager.so
143 %attr(755,root,root) %{_libdir}/kde4/kdevcppdebugger.so
144 %attr(755,root,root) %{_libdir}/kde4/kdevcpplanguagesupport.so
145 %attr(755,root,root) %{_libdir}/kde4/kdevcustommakemanager.so
146 %attr(755,root,root) %{_libdir}/kde4/kdevdocumentview.so
147 %attr(755,root,root) %{_libdir}/kde4/kdevgrepview.so
148 %attr(755,root,root) %{_libdir}/kde4/kdevmakebuilder.so
149 %attr(755,root,root) %{_libdir}/kde4/kdevqmakebuilder.so
150 %attr(755,root,root) %{_libdir}/kde4/kdevqmakemanager.so
151 %attr(755,root,root) %{_libdir}/kde4/kdevqtdesigner.so
152 %attr(755,root,root) %{_libdir}/kde4/kdevvalgrind.so
153 %attr(755,root,root) %{_libdir}/libkdev4cmakecommon.so
154 %attr(755,root,root) %{_libdir}/libkdev4cppduchain.so
155 %attr(755,root,root) %{_libdir}/libkdev4cppparser.so
156 %attr(755,root,root) %{_libdir}/libkdev4cpprpp.so
157 %attr(755,root,root) %{_libdir}/libkdev4qmakeparser.so
158 %{_desktopdir}/kdevelop.desktop
159
160 %{_datadir}/apps/cmake/modules/FindKDevelop.cmake
161 %{_datadir}/apps/cmake/modules/KDevelopMacros.cmake
162 %{_datadir}/apps/kdevappwizard
163 %{_datadir}/apps/kdevcmakebuilder
164 %{_datadir}/apps/kdevcmakemanager
165 %{_datadir}/apps/kdevcppdebugger
166 %{_datadir}/apps/kdevcustommakemanager
167 %{_datadir}/apps/kdevdocumentview
168 %{_datadir}/apps/kdevelop
169 %{_datadir}/apps/kdevgrepview
170 %{_datadir}/apps/kdevplatform
171 %{_datadir}/apps/kdevqmakebuilder
172 %{_datadir}/apps/kdevqtdesigner
173 %{_datadir}/apps/kdevvalgrind
174 %{_datadir}/config/kdeveloprc
175 %{_datadir}/apps/kdevcppsupport/kdevcppsupport.rc
176
177 %{_iconsdir}/*/*x*/*/*.png
178 %{_datadir}/kde4/services/kcm_kdev_cppdebugger.desktop
179 %{_datadir}/kde4/services/kcm_kdev_makebuilder.desktop
180 %{_datadir}/kde4/services/kcm_kdev_qmakebuilder.desktop
181 %{_datadir}/kde4/services/kcm_kdev_valgrindsettings.desktop
182 %{_datadir}/kde4/services/kcm_kdevcmake_settings.desktop
183 %{_datadir}/kde4/services/kdevappwizard.desktop
184 %{_datadir}/kde4/services/kdevcmakebuilder.desktop
185 %{_datadir}/kde4/services/kdevcmakemanager.desktop
186 %{_datadir}/kde4/services/kdevcppdebugger.desktop
187 %{_datadir}/kde4/services/kdevcppsupport.desktop
188 %{_datadir}/kde4/services/kdevcustommakemanager.desktop
189 %{_datadir}/kde4/services/kdevdocumentview.desktop
190 %{_datadir}/kde4/services/kdevgrepview.desktop
191 %{_datadir}/kde4/services/kdevmakebuilder.desktop
192 %{_datadir}/kde4/services/kdevqmakebuilder.desktop
193 %{_datadir}/kde4/services/kdevqmakemanager.desktop
194 %{_datadir}/kde4/services/kdevqtdesigner.desktop
195 %{_datadir}/kde4/services/kdevvalgrind.desktop
196
197 %{_includedir}/kdevelop
This page took 0.07932 seconds and 4 git commands to generate.