]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- BR: pkgconfig, python, python-modules, qimageblitz-devel
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1
2 %bcond_without  marble  # don't build marble plasma support
3
4 %define         orgname kdeplasma-addons
5 %define         _state  stable
6 %define         _qtver  4.5.3
7
8 Summary:        KDE4 Plasmoids
9 Summary(pl.UTF-8):      Plazmoidy dla KDE4
10 Name:           kde4-kdeplasma-addons
11 Version:        4.3.4
12 Release:        1
13 License:        GPL v2
14 Group:          X11/Applications
15 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
16 # Source0-md5:  c03ab7099a8064ca85bb804408052a2b
17 #Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
18 Patch100:       %{name}-branch.diff
19 Patch0:         %{name}-pastebinpld.patch
20 URL:            http://www.kde.org/
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  OpenGL-devel
23 BuildRequires:  QtCore-devel >= %{_qtver}
24 BuildRequires:  QtNetwork-devel >= %{_qtver}
25 BuildRequires:  QtOpenGL-devel >= %{_qtver}
26 BuildRequires:  QtScript-devel >= %{_qtver}
27 BuildRequires:  QtSvg-devel >= %{_qtver}
28 BuildRequires:  QtWebKit-devel >= %{_qtver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  cmake >= 2.6.3
31 BuildRequires:  eigen-devel >= 2.0.51
32 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
33 %{?with_marble:BuildRequires:   kde4-kdeedu-devel >= %{version}}
34 BuildRequires:  kde4-kdegraphics-devel >= %{version}
35 BuildRequires:  kde4-kdelibs-devel >= %{version}
36 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
37 BuildRequires:  phonon-devel >= 4.3.1
38 BuildRequires:  pkgconfig
39 BuildRequires:  python
40 BuildRequires:  python-modules
41 BuildRequires:  qimageblitz-devel
42 BuildRequires:  qt4-build >= %{_qtver}
43 BuildRequires:  qt4-qmake >= %{_qtver}
44 BuildRequires:  rpmbuild(macros) >= 1.293
45 BuildRequires:  strigi-devel >= 0.6.5
46 BuildRequires:  xorg-lib-libXcomposite
47 BuildRequires:  xorg-lib-libXdamage
48 BuildRequires:  xorg-lib-libXrender
49 BuildRequires:  xorg-lib-libXtst-devel
50 Obsoletes:      kde4-kdeplasmoids
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 KDE4 plasmoids.
55
56 %description -l pl.UTF-8
57 Plazmoidy dla KDE4.
58
59 %package lancelot
60 Summary:        Lancelot Desktop Theme
61 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
62 Group:          X11/Applications
63 Requires:       kde4-kdebase-workspace >= %{version}
64
65 %description lancelot
66 Lancelot Desktop Theme.
67
68 %description lancelot -l pl.UTF-8
69 Motyw pulpitu Lancelot.
70
71 %package devel
72 Summary:        Development files for KDE4 Plasmoids
73 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek plazmoidów dla KDE4
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       kde4-kdebase-workspace-devel >= %{version}
77 Requires:       kde4-kdegraphics-devel >= %{version}
78 Requires:       kde4-kdelibs-devel >= %{version}
79 Requires:       kde4-kdepimlibs-devel >= %{version}
80
81 %description devel
82 This package contains header files needed if you wish to build
83 applications based on KDE4 Plasmoids.
84
85 %description devel -l pl.UTF-8
86 Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
87 opartych na plazmoidach dla KDE4.
88
89 %prep
90 %setup -q -n %{orgname}-%{version}
91 #%patch100 -p0
92 %patch0 -p1
93
94 %build
95 install -d build
96 cd build
97 %cmake \
98         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
99         -DLIB_INSTALL_DIR=%{_libdir} \
100         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
101 %if "%{_lib}" != "lib"
102         -DLIB_SUFFIX=64 \
103 %endif
104         ../
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} -C build install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %post   lancelot        -p /sbin/ldconfig
121 %postun lancelot        -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
126 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
127 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
128 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
129 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
130 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
131 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
132 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
133 %attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
134 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
135 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
136 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
137 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
138 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
139 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
140 %if %{with marble}
141 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
142 %endif
143 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
144 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
145 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
146 %attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
147 %attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
148 %attr(755,root,root) %{_libdir}/liblancelot.so
149 %attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
150 %attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
151 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
152 %attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
153 %attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
155 %attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/librtm.so.?
157 %attr(755,root,root) %{_libdir}/librtm.so.*.*.*
158 %{_datadir}/apps/desktoptheme/Aya
159 %{_datadir}/apps/desktoptheme/Elegance
160 %{_datadir}/apps/desktoptheme/Silicon
161 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
162 %{_datadir}/apps/desktoptheme/default/stylesheets/*
163 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
164 %{_datadir}/apps/desktoptheme/default/weatherstation/*
165 %dir %{_datadir}/apps/desktoptheme/default/weather/
166 %{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
167 %{_datadir}/apps/desktoptheme/default/widgets/*
168 %{_datadir}/apps/desktoptheme/heron
169 %{_datadir}/apps/desktoptheme/slim-glow
170 %{_datadir}/kde4/services/*.desktop
171 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
172 %{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
173 %{_datadir}/config/comic.knsrc
174 %{_datadir}/config/virus_wallpaper.knsrc
175 %dir %{_datadir}/apps/desktoptheme/default/rssnow
176 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
177 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
178 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
179 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
180 %dir %{_datadir}/apps/desktoptheme/default/bubblemon
181 %{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
182 %dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
183 %{_datadir}/apps/desktoptheme/default/fifteenPuzzle/greensquare.svgz
184 %{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
185
186 %dir %{_datadir}/apps/rssnow
187 %{_datadir}/apps/rssnow/feeds
188 %{_iconsdir}/*/*x*/apps/previewer.png
189 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
190 %dir %{_datadir}/apps/bball
191 %{_datadir}/apps/bball/bball.svgz
192 %{_datadir}/apps/bball/bounce.ogg
193 %{_datadir}/apps/bball/football.svgz
194 #%{_datadir}/apps/plasma-bluemarble
195 %{_datadir}/apps/plasma
196 %{_datadir}/apps/plasma-applet-opendesktop
197 %{_datadir}/apps/plasma_pastebin
198 %{_datadir}/apps/plasma_wallpaper_pattern
199
200 %files lancelot
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_bindir}/lancelot
203 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
204 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
205 %{_datadir}/apps/desktoptheme/default/lancelot
206 #%{_datadir}/apps/desktoptheme/air/
207
208 %{_datadir}/dbus-1/services/org.kde.lancelot.service
209 %{_datadir}/mime/packages/lancelotpart-mime.xml
210 %{_datadir}/apps/lancelot
211 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
212 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
213
214 %files devel
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/*.so
217 %{_includedir}/conversion
218 %{_includedir}/lancelot
219 %{_datadir}/apps/cmake/modules/*.cmake
This page took 0.589144 seconds and 4 git commands to generate.