]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- 4.4.5
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1 # TODO:
2 # Lancelot: installed - cmake unimplemented because not found
3 #   * XRender - Lancelot compositing support
4 #   * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
5
6 %bcond_without  marble  # don't build marble plasma support
7
8 %define         orgname     kdeplasma-addons
9 %define         _state      stable
10 %define         qtver       4.6.3
11
12 Summary:        KDE4 Plasmoids
13 Summary(pl.UTF-8):      Plazmoidy dla KDE4
14 Name:           kde4-kdeplasma-addons
15 Version:        4.4.5
16 Release:        1
17 License:        GPL v2
18 Group:          X11/Applications
19 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
20 # Source0-md5:  cdc027b3dfdcc588f253006baa970638
21 Patch100:       %{name}-branch.diff
22 Patch0:         %{name}-pastebinpld.patch
23 URL:            http://www.kde.org/
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  QtCore-devel >= %{qtver}
27 BuildRequires:  QtNetwork-devel >= %{qtver}
28 BuildRequires:  QtOpenGL-devel >= %{qtver}
29 BuildRequires:  QtScript-devel >= %{qtver}
30 BuildRequires:  QtSvg-devel >= %{qtver}
31 BuildRequires:  QtWebKit-devel >= %{qtver}
32 BuildRequires:  automoc4 >= 0.9.88
33 BuildRequires:  cmake >= 2.8.0
34 BuildRequires:  eigen >= 1:2.0.12-3
35 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
36 %{?with_marble:BuildRequires:   kde4-kdeedu-devel >= %{version}}
37 BuildRequires:  kde4-kdegraphics-devel >= %{version}
38 BuildRequires:  kde4-kdelibs-devel >= %{version}
39 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
40 BuildRequires:  phonon-devel >= 4.3.80
41 BuildRequires:  pkgconfig
42 BuildRequires:  python
43 BuildRequires:  qimageblitz-devel
44 BuildRequires:  qt4-build >= %{qtver}
45 BuildRequires:  qt4-qmake >= %{qtver}
46 BuildRequires:  rpmbuild(macros) >= 1.293
47 BuildRequires:  shared-desktop-ontologies-devel >= 0.2
48 BuildRequires:  soprano-devel
49 BuildRequires:  strigi-devel >= 0.7.0
50 BuildRequires:  xorg-lib-libXcomposite-devel
51 BuildRequires:  xorg-lib-libXdamage-devel
52 BuildRequires:  xorg-lib-libXrender-devel
53 BuildRequires:  xorg-lib-libXtst-devel
54 Obsoletes:      kde4-kdeplasmoids
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 KDE4 plasmoids.
59
60 %description -l pl.UTF-8
61 Plazmoidy dla KDE4.
62
63 %package lancelot
64 Summary:        Lancelot Desktop Theme
65 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
66 Group:          X11/Applications
67 Requires:       kde4-kdebase-workspace >= %{version}
68
69 %description lancelot
70 Lancelot Desktop Theme.
71
72 %description lancelot -l pl.UTF-8
73 Motyw pulpitu Lancelot.
74
75 %package devel
76 Summary:        Development files for KDE4 Plasmoids
77 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek plazmoidów dla KDE4
78 Group:          X11/Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       kde4-kdebase-workspace-devel >= %{version}
81 Requires:       kde4-kdegraphics-devel >= %{version}
82 Requires:       kde4-kdelibs-devel >= %{version}
83 Requires:       kde4-kdepimlibs-devel >= %{version}
84
85 %description devel
86 This package contains header files needed if you wish to build
87 applications based on KDE4 Plasmoids.
88
89 %description devel -l pl.UTF-8
90 Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
91 opartych na plazmoidach dla KDE4.
92
93 %prep
94 %setup -q -n %{orgname}-%{version}
95 #%patch100 -p0
96 %patch0 -p1
97
98 %build
99 install -d build
100 cd build
101 %cmake \
102         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
103         -DLIB_INSTALL_DIR=%{_libdir} \
104         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
105 %if "%{_lib}" != "lib"
106         -DLIB_SUFFIX=64 \
107 %endif
108         ../
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} -C build install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %post   lancelot        -p /sbin/ldconfig
125 %postun lancelot        -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
130 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
131 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
132 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
133 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
134 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
135 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
136 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
137 %attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
138 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
139 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
140 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
141 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
142 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
143 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
144 %if %{with marble}
145 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
146 %endif
147 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
148 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
149 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
150 #%attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
151 #%attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
152 %attr(755,root,root) %{_libdir}/liblancelot.so
153 #%attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
154 #%attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
155 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
156 %attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
157 %attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
159 %attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/librtm.so.?
161 %attr(755,root,root) %{_libdir}/librtm.so.*.*.*
162 %{_datadir}/apps/desktoptheme/Aya
163 %{_datadir}/apps/desktoptheme/Elegance
164 %{_datadir}/apps/desktoptheme/Silicon
165 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
166 %{_datadir}/apps/desktoptheme/default/stylesheets/*
167 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
168 %{_datadir}/apps/desktoptheme/default/weatherstation/*
169 %dir %{_datadir}/apps/desktoptheme/default/weather/
170 %{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
171 %{_datadir}/apps/desktoptheme/default/widgets/*
172 %{_datadir}/apps/desktoptheme/heron
173 %{_datadir}/apps/desktoptheme/slim-glow
174 %{_datadir}/kde4/services/*.desktop
175 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
176 %{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
177 %{_datadir}/config/comic.knsrc
178 %{_datadir}/config/plasmaweather.knsrc
179 %{_datadir}/config/virus_wallpaper.knsrc
180 %dir %{_datadir}/apps/desktoptheme/default/rssnow
181 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
182 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
183 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
184 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
185 %dir %{_datadir}/apps/desktoptheme/default/bubblemon
186 %{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
187 %dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
188 %{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
189 %{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
190 %{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
191 %{_iconsdir}/hicolor/scalable/apps/bball.svgz
192 %{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
193
194 %dir %{_datadir}/apps/rssnow
195 %{_datadir}/apps/rssnow/feeds
196 %{_iconsdir}/*/*x*/apps/previewer.png
197 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
198 %dir %{_datadir}/apps/bball
199 %{_datadir}/apps/bball/bball.svgz
200 %{_iconsdir}/*/*x*/apps/bball.png
201 %{_datadir}/apps/bball/bounce.ogg
202 %{_datadir}/apps/bball/football.svgz
203 #%{_datadir}/apps/plasma-bluemarble
204 %{_datadir}/apps/plasma
205 %{_datadir}/apps/plasma-applet-opendesktop
206 %{_datadir}/apps/plasma-applet-opendesktop-activities
207 %{_datadir}/apps/plasma-applet-frame
208 %{_datadir}/apps/plasma_pastebin
209 %{_datadir}/apps/plasma_wallpaper_pattern
210
211 %files lancelot
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_bindir}/lancelot
214 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
215 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
216 %{_datadir}/apps/desktoptheme/default/lancelot
217 %{_datadir}/apps/desktoptheme/oxygen/lancelot
218 #%{_datadir}/apps/desktoptheme/air/
219
220 %{_datadir}/dbus-1/services/org.kde.lancelot.service
221 %{_datadir}/mime/packages/lancelotpart-mime.xml
222 %{_datadir}/apps/lancelot
223 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
224 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
225
226 %files devel
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/*.so
229 #%{_includedir}/conversion
230 %{_includedir}/lancelot
231 #%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.442207 seconds and 4 git commands to generate.