]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- 4.2.3
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1 %define         orgname kdeplasma-addons
2 %define         _state  stable
3 %define         _qtver  4.5.0
4
5 Summary:        KDE4 Plasmoids
6 Summary(pl.UTF-8):      Plazmoidy dla KDE4
7 Name:           kde4-kdeplasma-addons
8 Version:        4.2.3
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications
12 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
13 # Source0-md5:  7f29b7dbb46b5b468fd7867e4907e858
14 Patch100:       %{name}-branch.diff
15 Patch0:         %{name}-pastebinpld.patch
16 URL:            http://www.kde.org/
17 BuildRequires:  OpenGL-GLU-devel
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  QtCore-devel >= %{_qtver}
20 BuildRequires:  QtNetwork-devel >= %{_qtver}
21 BuildRequires:  QtOpenGL-devel >= %{_qtver}
22 BuildRequires:  QtScript-devel >= %{_qtver}
23 BuildRequires:  QtSvg-devel >= %{_qtver}
24 BuildRequires:  QtWebKit-devel >= %{_qtver}
25 BuildRequires:  automoc4 >= 0.9.88
26 BuildRequires:  cmake >= 2.6.2
27 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
28 BuildRequires:  kde4-kdelibs-devel >= %{version}
29 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
30 BuildRequires:  phonon-devel >= 4.3.1
31 BuildRequires:  qt4-build >= %{_qtver}
32 BuildRequires:  qt4-qmake >= %{_qtver}
33 BuildRequires:  rpmbuild(macros) >= 1.293
34 BuildRequires:  strigi-devel >= 0.6.3
35 BuildRequires:  xorg-lib-libXtst-devel
36 Obsoletes:      kde4-kdeplasmoids
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 KDE4 plasmoids.
41
42 %description -l pl.UTF-8
43 Plazmoidy dla KDE4.
44
45 %package lancelot
46 Summary:        Lancelot Desktop Theme
47 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
48 Group:          X11/Applications
49 Requires:       kde4-kdebase-workspace >= %{version}
50
51 %description lancelot
52 Lancelot Desktop Theme.
53
54 %description lancelot -l pl.UTF-8
55 Motyw pulpitu Lancelot.
56
57 %prep
58 %setup -q -n %{orgname}-%{version}
59 #%patch100 -p0
60 %patch0 -p1
61
62 %build
63 install -d build
64 cd build
65 %cmake \
66         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
67         -DCMAKE_BUILD_TYPE=%{!?debug:release}%{?debug:debug} \
68 %if "%{_lib}" != "lib"
69         -DLIB_SUFFIX=64 \
70 %endif
71         ../
72
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} -C build install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %post   lancelot        -p /sbin/ldconfig
88 %postun lancelot        -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
93 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
94 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
95 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
96 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
97 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
98 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
99 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
100 %attr(755,root,root) %ghost %{_libdir}/libplasmaconverter.so.?
101 %attr(755,root,root) %{_libdir}/libplasmaconverter.so.*.*.*
102 %{_datadir}/apps/desktoptheme/Aya
103 %{_datadir}/apps/desktoptheme/Elegance
104 %{_datadir}/apps/desktoptheme/Silicon
105 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
106 %{_datadir}/apps/desktoptheme/default/stylesheets/*
107 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
108 %{_datadir}/apps/desktoptheme/default/weatherstation/*
109 %{_datadir}/apps/desktoptheme/default/widgets/*
110 %{_datadir}/apps/desktoptheme/heron
111 %{_datadir}/apps/desktoptheme/slim-glow
112 %{_datadir}/kde4/services/*.desktop
113 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
114 #%{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
115 %{_datadir}/config/comic.knsrc
116 %dir %{_datadir}/apps/desktoptheme/default/rssnow
117 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
118 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
119 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
120 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
121 %dir %{_datadir}/apps/rssnow
122 %{_datadir}/apps/rssnow/feeds
123 %{_iconsdir}/*/*x*/apps/previewer.png
124 #%{_iconsdir}/oxygen/scalable/apps/bball.svgz
125 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
126 %dir %{_datadir}/apps/bball
127 %{_datadir}/apps/bball/bball.svgz
128 %{_datadir}/apps/bball/bounce.ogg
129 %{_datadir}/apps/bball/football.svgz
130 %{_datadir}/apps/plasma-bluemarble
131 %{_datadir}/apps/plasma/services/tweet.operations
132
133 %files lancelot
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/lancelot
136 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
137 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
138 %{_datadir}/apps/desktoptheme/default/lancelot
139 %{_datadir}/dbus-1/services/org.kde.lancelot.service
140 %{_datadir}/mime/packages/lancelotpart-mime.xml
141 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
142 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
This page took 0.079055 seconds and 4 git commands to generate.