]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blob - kde4-kdeplasma-addons.spec
- merged from DEVEL
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
1 # TODO:
2 # Lancelot: installed - cmake unimplemented because not found
3 #   * XRender - Lancelot compositing support
4 #   * Eigen2 - Eigen2 enables the Mandelbrot wallpaper plugin.
5
6 %bcond_without  marble  # don't build marble plasma support
7
8 %define         orgname     kdeplasma-addons
9 %define         _state      stable
10 %define         qtver       4.6.1
11
12 Summary:        KDE4 Plasmoids
13 Summary(pl.UTF-8):      Plazmoidy dla KDE4
14 Name:           kde4-kdeplasma-addons
15 Version:        4.4.0
16 Release:        1
17 License:        GPL v2
18 Group:          X11/Applications
19 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
20 # Source0-md5:  0a990a833a8a7c5434d158b0b18c5ad2
21 Patch100:       %{name}-branch.diff
22 Patch0:         %{name}-pastebinpld.patch
23 URL:            http://www.kde.org/
24 BuildRequires:  OpenGL-GLU-devel
25 BuildRequires:  OpenGL-devel
26 BuildRequires:  QtCore-devel >= %{qtver}
27 BuildRequires:  QtNetwork-devel >= %{qtver}
28 BuildRequires:  QtOpenGL-devel >= %{qtver}
29 BuildRequires:  QtScript-devel >= %{qtver}
30 BuildRequires:  QtSvg-devel >= %{qtver}
31 BuildRequires:  QtWebKit-devel >= %{qtver}
32 BuildRequires:  automoc4 >= 0.9.88
33 BuildRequires:  cmake >= 2.8.0
34 BuildRequires:  eigen-devel >= 2.0.51
35 BuildRequires:  kde4-kdebase-workspace-devel >= %{version}
36 %{?with_marble:BuildRequires:   kde4-kdeedu-devel >= %{version}}
37 BuildRequires:  kde4-kdegraphics-devel >= %{version}
38 BuildRequires:  kde4-kdelibs-devel >= %{version}
39 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
40 BuildRequires:  phonon-devel >= 4.3.80
41 BuildRequires:  qt4-build >= %{qtver}
42 BuildRequires:  qt4-qmake >= %{qtver}
43 BuildRequires:  rpmbuild(macros) >= 1.293
44 BuildRequires:  shared-desktop-ontologies-devel >= 0.2
45 BuildRequires:  strigi-devel >= 0.7.0
46 BuildRequires:  xorg-lib-libXcomposite-devel
47 BuildRequires:  xorg-lib-libXdamage-devel
48 BuildRequires:  xorg-lib-libXrender-devel
49 BuildRequires:  xorg-lib-libXtst-devel
50 Obsoletes:      kde4-kdeplasmoids
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %description
54 KDE4 plasmoids.
55
56 %description -l pl.UTF-8
57 Plazmoidy dla KDE4.
58
59 %package lancelot
60 Summary:        Lancelot Desktop Theme
61 Summary(pl.UTF-8):      Motyw pulpitu Lancelot
62 Group:          X11/Applications
63 Requires:       kde4-kdebase-workspace >= %{version}
64
65 %description lancelot
66 Lancelot Desktop Theme.
67
68 %description lancelot -l pl.UTF-8
69 Motyw pulpitu Lancelot.
70
71 %package devel
72 Summary:        Development files for KDE4 Plasmoids
73 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek plazmoidów dla KDE4
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       kde4-kdebase-workspace-devel >= %{version}
77 Requires:       kde4-kdegraphics-devel >= %{version}
78 Requires:       kde4-kdelibs-devel >= %{version}
79 Requires:       kde4-kdepimlibs-devel >= %{version}
80
81 %description devel
82 This package contains header files needed if you wish to build
83 applications based on KDE4 Plasmoids.
84
85 %description devel -l pl.UTF-8
86 Pakiet ten zawiera pliki nagłówkowe potrzebne do budowy aplikacji
87 opartych na plazmoidach dla KDE4.
88
89 %prep
90 %setup -q -n %{orgname}-%{version}
91 #%patch100 -p0
92 %patch0 -p1
93
94 %build
95 install -d build
96 cd build
97 %cmake \
98         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
99         -DLIB_INSTALL_DIR=%{_libdir} \
100         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
101 %if "%{_lib}" != "lib"
102         -DLIB_SUFFIX=64 \
103 %endif
104         ../
105
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} -C build install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %post   lancelot        -p /sbin/ldconfig
121 %postun lancelot        -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
126 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
127 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_*.so
128 %attr(755,root,root) %{_libdir}/kde4/plasma_comic_*.so
129 %attr(755,root,root) %{_libdir}/kde4/plasma_engine_*.so
130 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_comic.so
131 %attr(755,root,root) %ghost %{_libdir}/libplasmacomicprovidercore.so.?
132 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so.*.*.*
133 %attr(755,root,root) %{_libdir}/kde4/plasma-applet_systemloadviewer.so
134 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_apodprovider.so
135 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_epodprovider.so
136 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_flickrprovider.so
137 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_oseiprovider.so
138 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
139 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
140 %if %{with marble}
141 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
142 %endif
143 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
144 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
145 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
146 #%attr(755,root,root) %ghost %{_libdir}/libconversion.so.?
147 #%attr(755,root,root) %{_libdir}/libconversion.so.*.*.*
148 %attr(755,root,root) %{_libdir}/liblancelot.so
149 #%attr(755,root,root) %ghost %{_libdir}/libocsclient.so.?
150 #%attr(755,root,root) %{_libdir}/libocsclient.so.*.*.*
151 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
152 %attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
153 %attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libplasmaweather.so.?
155 %attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/librtm.so.?
157 %attr(755,root,root) %{_libdir}/librtm.so.*.*.*
158 %{_datadir}/apps/desktoptheme/Aya
159 %{_datadir}/apps/desktoptheme/Elegance
160 %{_datadir}/apps/desktoptheme/Silicon
161 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
162 %{_datadir}/apps/desktoptheme/default/stylesheets/*
163 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
164 %{_datadir}/apps/desktoptheme/default/weatherstation/*
165 %dir %{_datadir}/apps/desktoptheme/default/weather/
166 %{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
167 %{_datadir}/apps/desktoptheme/default/widgets/*
168 %{_datadir}/apps/desktoptheme/heron
169 %{_datadir}/apps/desktoptheme/slim-glow
170 %{_datadir}/kde4/services/*.desktop
171 %{_datadir}/kde4/servicetypes/plasma_comicprovider.desktop
172 %{_datadir}/kde4/servicetypes/plasma_potdprovider.desktop
173 %{_datadir}/config/comic.knsrc
174 %{_datadir}/config/plasmaweather.knsrc
175 %{_datadir}/config/virus_wallpaper.knsrc
176 %dir %{_datadir}/apps/desktoptheme/default/rssnow
177 %{_datadir}/apps/desktoptheme/default/rssnow/background.svgz
178 %{_datadir}/apps/desktoptheme/default/rssnow/left.svgz
179 %{_datadir}/apps/desktoptheme/default/rssnow/right.svgz
180 %{_datadir}/apps/desktoptheme/default/rssnow/rssnow.svgz
181 %dir %{_datadir}/apps/desktoptheme/default/bubblemon
182 %{_datadir}/apps/desktoptheme/default/bubblemon/bubble.svg
183 %dir %{_datadir}/apps/desktoptheme/default/fifteenPuzzle
184 %{_datadir}/apps/desktoptheme/default/fifteenPuzzle/blanksquare.svg
185 %{_iconsdir}/hicolor/scalable/apps/fifteenpuzzle.svgz
186 %{_iconsdir}/hicolor/scalable/apps/accessories-dictionary.svgz
187 %{_iconsdir}/hicolor/scalable/apps/bball.svgz
188 %{_iconsdir}/oxygen/*x*/apps/qalculate-applet.png
189
190 %dir %{_datadir}/apps/rssnow
191 %{_datadir}/apps/rssnow/feeds
192 %{_iconsdir}/*/*x*/apps/previewer.png
193 %{_datadir}/kde4/services/ServiceMenus/preview.desktop
194 %dir %{_datadir}/apps/bball
195 %{_datadir}/apps/bball/bball.svgz
196 %{_iconsdir}/*/*x*/apps/bball.png
197 %{_datadir}/apps/bball/bounce.ogg
198 %{_datadir}/apps/bball/football.svgz
199 #%{_datadir}/apps/plasma-bluemarble
200 %{_datadir}/apps/plasma
201 %{_datadir}/apps/plasma-applet-opendesktop
202 %{_datadir}/apps/plasma-applet-opendesktop-activities
203 %{_datadir}/apps/plasma-applet-frame
204 %{_datadir}/apps/plasma_pastebin
205 %{_datadir}/apps/plasma_wallpaper_pattern
206
207 %files lancelot
208 %defattr(644,root,root,755)
209 %attr(755,root,root) %{_bindir}/lancelot
210 %attr(755,root,root) %ghost %{_libdir}/liblancelot.so.?
211 %attr(755,root,root) %{_libdir}/liblancelot.so.*.*.*
212 %{_datadir}/apps/desktoptheme/default/lancelot
213 %{_datadir}/apps/desktoptheme/oxygen/lancelot
214 #%{_datadir}/apps/desktoptheme/air/
215
216 %{_datadir}/dbus-1/services/org.kde.lancelot.service
217 %{_datadir}/mime/packages/lancelotpart-mime.xml
218 %{_datadir}/apps/lancelot
219 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
220 %{_iconsdir}/hicolor/*x*/apps/lancelot-part.png
221
222 %files devel
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/*.so
225 #%{_includedir}/conversion
226 %{_includedir}/lancelot
227 #%{_datadir}/apps/cmake/modules/*.cmake
This page took 0.112412 seconds and 3 git commands to generate.