]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
- more %files but it's still not as it should be
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 # Conditional build:
2 %bcond_without  apidocs         # do not prepare API documentation
3 %bcond_without  hidden_visibility       # pass '--fvisibility=hidden'
4                                         # & '--fvisibility-inlines-hidden'
5                                         # to g++
6
7 %define         _state          stable
8 %define         _minlibsevr     9:%{version}
9 %define         _minbaseevr     9:%{version}
10
11 Summary:        KDE4 runtime
12 %define orgname kdebase-runtime
13 Name:           kdebase4-runtime
14 Version:        4.0.0
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/latest/src/%{orgname}-%{version}.tar.bz2
19 # Source0-md5:  da93f59497ff90ad01bd4ab9b458f6cb
20 %{?with_apidocs:BuildRequires:  doxygen}
21 %{?with_hidden_visibility:BuildRequires:        gcc-c++ >= 5:4.1.0-0.20051206r108118.1}
22 %{?with_apidocs:BuildRequires:  graphviz}
23 BuildRequires:  kdelibs4-devel >= %{_minlibsevr}
24 %{?with_apidocs:BuildRequires:  qt4-doc}
25 BuildRequires:  rpmbuild(macros) >= 1.129
26 BuildRequires:  xine-lib-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreq      libtool(.*)
30
31 %description
32
33 %package devel
34 Summary:        Development files for KDE4 runtime
35 Summary(pl.UTF-8):      Pliki nagłówkowe do KDE pim
36 Summary(ru.UTF-8):      Файлы разработки для kdepim
37 Summary(uk.UTF-8):      Файли розробки для kdepim
38 Group:          X11/Development/Libraries
39 Requires:       %{name} = %{epoch}:%{version}-%{release}
40 Requires:       kdelibs4-devel >= %{_minlibsevr}
41
42 %description devel
43
44 %prep
45 %setup -q -n %{orgname}-%{version}
46
47 %build
48 export QTDIR=%{_prefix}
49 mkdir build
50 cd build
51 %cmake \
52         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
53         ../
54
55 %{__make}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} -C build/ install \
61         DESTDIR=$RPM_BUILD_ROOT \
62         kde_htmldir=%{_kdedocdir}
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %post           -p /sbin/ldconfig
68 %postun         -p /sbin/ldconfig
69
70 %files
71 %defattr(644,root,root,755)
72 %attr(755,root,root) %{_bindir}/*
73 %attr(755,root,root) %{_libdir}/kde4/*.so
74 %attr(755,root,root) %{_libdir}/*.so
75 %attr(755,root,root) %{_libdir}/kde4/libexec/*
76 %attr(755,root,root) %{_libdir}/kde4/plugins/styles/*.so
77 %{_iconsdir}/oxygen
78 %{_datadir}/applications/kde4/*
79 # this should be probably a separate package
80 %{_datadir}/apps/khelpcenter
81 #
82 %{_datadir}/emoticons/kde4
83 %{_datadir}/kde4/services
84
85
86 %files devel
87 %defattr(644,root,root,755)
This page took 0.099124 seconds and 4 git commands to generate.