]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
updated to 4.9.1.
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 # TODO
2 # - l10n != %lang glibc locales (et = etiopia not estonia!)
3 #
4 # Conditional build:
5 #
6 %define         _state          stable
7 %define         orgname         kde-runtime
8 %define         qtver           4.8.1
9 %define         atticaver       0.2.0
10
11 Summary:        KDE 4 base runtime components
12 Summary(pl.UTF-8):      Komponenty uruchomieniowe podstawowej części KDE 4
13 Name:           kde4-kdebase-runtime
14 Version:        4.9.1
15 Release:        1
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  346a06a4f2dea27e258a9e3c2064c443
20 Source1:        kdebase-searchproviders.tar.bz2
21 # Source1-md5:  126c3524b5367f5096a628acbf9dc86f
22 Source2:        l10n-iso639-1
23 Patch100:       %{name}-branch.diff
24 Patch0:         %{name}-rpc.patch
25 URL:            http://www.kde.org/
26 BuildRequires:  OpenEXR-devel
27 BuildRequires:  alsa-lib-devel
28 BuildRequires:  attica-devel >= %{atticaver}
29 BuildRequires:  automoc4 >= 0.9.88
30 BuildRequires:  bzip2-devel
31 BuildRequires:  clucene-core-devel >= 0.9.21
32 BuildRequires:  cmake >= 2.8.0
33 BuildRequires:  docbook-dtd42-xml
34 BuildRequires:  docbook-style-xsl
35 BuildRequires:  exiv2-devel >= 0.18.2
36 BuildRequires:  kde4-nepomuk-core >= %{version}
37 BuildRequires:  kde4-kdelibs-devel >= %{version}
38 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
39 BuildRequires:  libcanberra-devel
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libqzeitgeist-devel >= 0.8
42 BuildRequires:  libsmbclient-devel
43 BuildRequires:  libssh-devel >= 1:0.4.0
44 BuildRequires:  libtirpc-devel
45 BuildRequires:  kde4-nepomuk-core-devel
46 BuildRequires:  ntrack-devel
47 BuildRequires:  openslp-devel
48 BuildRequires:  phonon-devel >= 4.4.3
49 BuildRequires:  pkgconfig
50 BuildRequires:  pulseaudio-devel
51 BuildRequires:  qt4-build >= %{qtver}
52 BuildRequires:  qt4-qmake >= %{qtver}
53 BuildRequires:  rpmbuild(macros) >= 1.600
54 BuildRequires:  shared-desktop-ontologies-devel >= 0.7.1
55 BuildRequires:  shared-mime-info
56 BuildRequires:  soprano-devel >= 2.6.51
57 BuildRequires:  strigi-devel >= 0.7.0
58 BuildRequires:  xine-lib-devel
59 BuildRequires:  xz-devel
60 Requires:       attica >= %{atticaver}
61 Provides:       dbus(org.freedesktop.Notifications)
62 Obsoletes:      kdebase4-runtime
63 Conflicts:      kdebase4-runtime
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 KDE 4 runtime components.
68
69 %description -l pl.UTF-8
70 Komponenty uruchomieniowe podstawowej części KDE 4.
71
72 %package devel
73 Summary:        Development files for KDE 4 runtime components
74 Summary(pl.UTF-8):      Pliki programistyczne komponentów uruchomieniowych KDE 4
75 Group:          X11/Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       kde4-kdelibs-devel >= %{version}
78
79 %description devel
80 Development files for KDE 4 runtime components.
81
82 %description devel -l pl.UTF-8
83 Pliki programistyczne komponentów uruchomieniowych KDE 4.
84
85 %package -n kde4-phonon
86 Summary:        KDE 4 Phonon plugins
87 Summary(pl.UTF-8):      Wtyczki KDE 4 dla Phonona
88 Group:          X11/Applications
89
90 %description -n kde4-phonon
91 KDE 4 Phonon plugins.
92
93 %description -n kde4-phonon -l pl.UTF-8
94 Wtyczki KDE 4 dla Phonona.
95
96 %prep
97 %setup -q -n %{orgname}-%{version} -a1
98 #%patch100 -p1
99 %patch0 -p1
100
101 %build
102 install -d build
103 cd build
104 %cmake \
105         -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
106         ../
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} -C build install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         kde_htmldir=%{_kdedocdir}
116
117 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
118 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
119
120 collect_l10n_files() {
121         while read country language comment; do
122                 [ "$country" != "#" ] || continue
123                 if [ "$language" = "-" ]; then
124                         # no mapping. just add for now
125                         echo >&2 "No mapping for $country $comment, adding without %%lang tag"
126                         echo "%{_datadir}/locale/l10n/$country"
127                 else
128                         echo "%lang($language) %{_datadir}/locale/l10n/$country"
129                 fi
130         done
131 } < %{SOURCE2}
132 collect_l10n_files > %{name}.files
133
134 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/default.kde4
135 # provided (conflicts) by hicolor-icon-theme
136 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files -f %{name}.files
145 %defattr(644,root,root,755)
146 %{_sysconfdir}/xdg/menus/kde-information.menu
147 %attr(755,root,root) %{_bindir}/kcmshell4
148 %attr(755,root,root) %{_bindir}/kde-cp
149 %attr(755,root,root) %{_bindir}/kde-mv
150 %attr(755,root,root) %{_bindir}/kde-open
151 %attr(755,root,root) %{_bindir}/kde4-menu
152 %attr(755,root,root) %{_bindir}/kdebugdialog
153 %attr(755,root,root) %{_bindir}/kfile4
154 %attr(755,root,root) %{_bindir}/kiconfinder
155 %attr(755,root,root) %{_bindir}/khelpcenter
156 %attr(755,root,root) %{_bindir}/khotnewstuff4
157 %attr(755,root,root) %{_bindir}/khotnewstuff-upload
158 %attr(755,root,root) %{_bindir}/kioclient
159 %attr(755,root,root) %{_bindir}/kmimetypefinder
160 %attr(755,root,root) %{_bindir}/knotify4
161 %attr(755,root,root) %{_bindir}/kquitapp
162 %attr(755,root,root) %{_bindir}/kreadconfig
163 %attr(755,root,root) %{_bindir}/kstart
164 %attr(755,root,root) %{_bindir}/kde4
165 %attr(755,root,root) %{_bindir}/kwalletd
166 %attr(755,root,root) %{_bindir}/ksvgtopng
167 %attr(755,root,root) %{_bindir}/keditfiletype
168 %attr(755,root,root) %{_bindir}/kglobalaccel
169 %attr(755,root,root) %{_bindir}/ktraderclient
170 %attr(755,root,root) %{_bindir}/ktrash
171 %attr(755,root,root) %{_bindir}/kuiserver
172 %attr(755,root,root) %{_bindir}/kwriteconfig
173 %attr(755,root,root) %{_bindir}/solid-hardware
174 %attr(755,root,root) %{_bindir}/nepomukcontroller
175 %attr(755,root,root) %{_bindir}/plasma-remote-helper
176 %attr(755,root,root) %{_bindir}/plasmapkg
177 %attr(755,root,root) %{_libdir}/attica_kde.so
178 %attr(755,root,root) %{_libdir}/libkdeinit4_kcmshell4.so
179 %attr(755,root,root) %{_libdir}/libkdeinit4_khelpcenter.so
180 %attr(755,root,root) %{_libdir}/libkdeinit4_kuiserver.so
181 %attr(755,root,root) %{_libdir}/libkdeinit4_kwalletd.so
182 %attr(755,root,root) %{_libdir}/libkdeinit4_kglobalaccel.so
183 %attr(755,root,root) %{_libdir}/libknotifyplugin.so
184 # Is it ok to add those files to main package?
185 %attr(755,root,root) %ghost %{_libdir}/libkwalletbackend.so.?
186 %attr(755,root,root) %{_libdir}/libkwalletbackend.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libmolletnetwork.so.?
188 %attr(755,root,root) %{_libdir}/libmolletnetwork.so.4.*.*
189 %attr(755,root,root) %{_libdir}/kde4/comicbookthumbnail.so
190 %attr(755,root,root) %{_libdir}/kde4/cursorthumbnail.so
191 %attr(755,root,root) %{_libdir}/kde4/djvuthumbnail.so
192 %attr(755,root,root) %{_libdir}/kde4/exrthumbnail.so
193 %attr(755,root,root) %{_libdir}/kde4/htmlthumbnail.so
194 %attr(755,root,root) %{_libdir}/kde4/imagethumbnail.so
195 #%attr(755,root,root) %{_libdir}/kde4/jpegrotatedthumbnail.so
196 %attr(755,root,root) %{_libdir}/kde4/jpegthumbnail.so
197 %attr(755,root,root) %{_libdir}/kde4/kcm_cgi.so
198 %attr(755,root,root) %{_libdir}/kde4/kcm_componentchooser.so
199 %attr(755,root,root) %{_libdir}/kde4/kcm_device_automounter.so
200 %attr(755,root,root) %{_libdir}/kde4/kcm_emoticons.so
201 %attr(755,root,root) %{_libdir}/kde4/kcm_filetypes.so
202 %attr(755,root,root) %{_libdir}/kde4/kcm_icons.so
203 %attr(755,root,root) %{_libdir}/kde4/kcm_kded.so
204 %attr(755,root,root) %{_libdir}/kde4/kcm_kdnssd.so
205 %attr(755,root,root) %{_libdir}/kde4/kcm_knotify.so
206 %attr(755,root,root) %{_libdir}/kde4/kcm_locale.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_nepomuk.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_trash.so
209 #%attr(755,root,root) %{_libdir}/kde4/kded_activitymanager.so
210 %attr(755,root,root) %{_libdir}/kde4/kded_device_automounter.so
211 %attr(755,root,root) %{_libdir}/kde4/kded_kpasswdserver.so
212 %attr(755,root,root) %{_libdir}/kde4/kded_ktimezoned.so
213 %attr(755,root,root) %{_libdir}/kde4/kded_remotedirnotify.so
214 %attr(755,root,root) %{_libdir}/kde4/kded_soliduiserver.so
215 %attr(755,root,root) %{_libdir}/kde4/kded_desktopnotifier.so
216 %attr(755,root,root) %{_libdir}/kde4/kded_nepomuksearchmodule.so
217 %attr(755,root,root) %{_libdir}/kde4/kded_networkstatus.so
218 %attr(755,root,root) %{_libdir}/kde4/kded_networkwatcher.so
219 %attr(755,root,root) %{_libdir}/kde4/kded_recentdocumentsnotifier.so
220 %attr(755,root,root) %{_libdir}/kde4/kded_solidautoeject.so
221 %attr(755,root,root) %{_libdir}/kde4/kio_applications.so
222 %attr(755,root,root) %{_libdir}/kde4/kio_bookmarks.so
223 %attr(755,root,root) %{_libdir}/kde4/kio_desktop.so
224 %attr(755,root,root) %{_libdir}/kde4/kio_about.so
225 %attr(755,root,root) %{_libdir}/kde4/kio_archive.so
226 %attr(755,root,root) %{_libdir}/kde4/kio_cgi.so
227 %attr(755,root,root) %{_libdir}/kde4/kio_filter.so
228 %attr(755,root,root) %{_libdir}/kde4/kio_finger.so
229 %attr(755,root,root) %{_libdir}/kde4/kio_fish.so
230 %attr(755,root,root) %{_libdir}/kde4/kio_floppy.so
231 %attr(755,root,root) %{_libdir}/kde4/kio_info.so
232 %attr(755,root,root) %{_libdir}/kde4/kio_man.so
233 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuksearch.so
234 %attr(755,root,root) %{_libdir}/kde4/kio_network.so
235 %attr(755,root,root) %{_libdir}/kde4/kio_nfs.so
236 %attr(755,root,root) %{_libdir}/kde4/kio_recentdocuments.so
237 %attr(755,root,root) %{_libdir}/kde4/kio_remote.so
238 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
239 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
240 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
241 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
242 %attr(755,root,root) %{_libdir}/kde4/kio_timeline.so
243 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
244 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuk.so
245 %attr(755,root,root) %{_libdir}/kde4/libkmanpart.so
246 %attr(755,root,root) %{_libdir}/kde4/fixhosturifilter.so
247 %attr(755,root,root) %{_libdir}/kde4/kcm_attica.so
248 %attr(755,root,root) %{_libdir}/kde4/kcm_phonon.so
249 %attr(755,root,root) %{_libdir}/kde4/kcmspellchecking.so
250 %attr(755,root,root) %{_libdir}/kde4/kshorturifilter.so
251 %attr(755,root,root) %{_libdir}/kde4/kuriikwsfilter.so
252 %attr(755,root,root) %{_libdir}/kde4/kurisearchfilter.so
253 %attr(755,root,root) %{_libdir}/kde4/localdomainurifilter.so
254 %attr(755,root,root) %{_libdir}/kde4/librenaudioplugin.so
255 %attr(755,root,root) %{_libdir}/kde4/librenimageplugin.so
256 %attr(755,root,root) %{_libdir}/kde4/plasma-kpart.so
257 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_declarative.so
258 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_simple_javascript.so
259 %attr(755,root,root) %{_libdir}/kde4/plasma_containment_newspaper.so
260 %attr(755,root,root) %{_libdir}/kde4/plasma_dataenginescript_javascript.so
261 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_javascriptaddon.so
262 %attr(755,root,root) %{_libdir}/kde4/plasma_runnerscript_javascript.so
263 %attr(755,root,root) %{_libdir}/kde4/svgthumbnail.so
264 %attr(755,root,root) %{_libdir}/kde4/textthumbnail.so
265 %attr(755,root,root) %{_libdir}/kde4/windowsexethumbnail.so
266 %attr(755,root,root) %{_libdir}/kde4/windowsimagethumbnail.so
267
268 %attr(755,root,root) %{_libdir}/kde4/imports
269
270 %attr(755,root,root) %{_libdir}/kde4/libexec/drkonqi
271 #%attr(755,root,root) %{_libdir}/kde4/libexec/installdbgsymbols.sh
272 %attr(755,root,root) %{_libdir}/kde4/libexec/kdeeject
273 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesu
274 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesud
275 %attr(755,root,root) %{_libdir}/kde4/libexec/kdontchangethehostname
276 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_docbookdig.pl
277 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htdig.pl
278 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htsearch.pl
279 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_indexbuilder
280 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_mansearch.pl
281 %attr(755,root,root) %{_libdir}/kde4/libexec/kioexec
282 #%attr(755,root,root) %{_libdir}/kde4/libexec/klocaldomainurifilterhelper
283 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
284 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
285 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
286 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
287 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
288 %{_desktopdir}/kde4/nepomukcontroller.desktop
289 %{_datadir}/apps/drkonqi
290 %dir %{_datadir}/apps/kcm_componentchooser
291 %{_datadir}/apps/hardwarenotifications
292 %{_datadir}/apps/kcm_componentchooser/kcm_browser.desktop
293 %{_datadir}/apps/kcm_componentchooser/kcm_filemanager.desktop
294 %{_datadir}/apps/kcm_componentchooser/kcm_kemail.desktop
295 %{_datadir}/apps/kcm_componentchooser/kcm_terminal.desktop
296 %{_datadir}/apps/kcm_componentchooser/kcm_wm.desktop
297 %{_datadir}/apps/kcmlocale
298 %{_datadir}/apps/kconf_update/kuriikwsfilter.upd
299 %{_datadir}/apps/kde/kde.notifyrc
300 %dir %{_datadir}/apps/kglobalaccel
301 %{_datadir}/apps/kglobalaccel/kglobalaccel.notifyrc
302 %{_datadir}/apps/khelpcenter
303 %{_datadir}/apps/kio_bookmarks
304 %{_datadir}/apps/kio_finger
305 %{_datadir}/apps/kio_info
306 #%{_datadir}/apps/kio_thumbnail
307 %dir %{_datadir}/apps/konqueror/dirtree
308 %dir %{_datadir}/apps/konqueror/dirtree/remote
309 %{_datadir}/apps/konqueror/dirtree/remote/smb-network.desktop
310 %dir %{_datadir}/apps/remoteview
311 %{_datadir}/apps/remoteview/smb-network.desktop
312 %{_datadir}/config.kcfg/khelpcenter.kcfg
313 %{_datadir}/config.kcfg/jpegcreatorsettings.kcfg
314 %{_datadir}/config/khotnewstuff.knsrc
315 %{_datadir}/config/icons.knsrc
316 %{_datadir}/config/emoticons.knsrc
317 %{_datadir}/config/kshorturifilterrc
318 %{_datadir}/config/khotnewstuff_upload.knsrc
319 %{_datadir}/dbus-1/services/org.kde.knotify.service
320 %{_datadir}/dbus-1/services/org.kde.kuiserver.service
321 %{_datadir}/dbus-1/interfaces/*.xml
322 %{_datadir}/emoticons/kde4
323 %{_datadir}/kde4/services/about.protocol
324 %{_datadir}/kde4/services/applications.protocol
325 %{_datadir}/kde4/services/ar.protocol
326 %{_datadir}/kde4/services/kcm_attica.desktop
327 %{_datadir}/kde4/services/bookmarks.protocol
328 %{_datadir}/kde4/services/bzip.protocol
329 %{_datadir}/kde4/services/bzip2.protocol
330 %{_datadir}/kde4/services/cgi.protocol
331 %{_datadir}/kde4/services/comicbookthumbnail.desktop
332 %{_datadir}/kde4/services/componentchooser.desktop
333 %{_datadir}/kde4/services/cursorthumbnail.desktop
334 %{_datadir}/kde4/services/device_automounter_kcm.desktop
335 %{_datadir}/kde4/services/djvuthumbnail.desktop
336 %{_datadir}/kde4/services/emoticons.desktop
337 %{_datadir}/kde4/services/exrthumbnail.desktop
338 %{_datadir}/kde4/services/finger.protocol
339 %{_datadir}/kde4/services/fish.protocol
340 %{_datadir}/kde4/services/fixhosturifilter.desktop
341 %{_datadir}/kde4/services/floppy.protocol
342 %{_datadir}/kde4/services/gzip.protocol
343 %{_datadir}/kde4/services/htmlthumbnail.desktop
344 %{_datadir}/kde4/services/icons.desktop
345 #%{_datadir}/kde4/services/jpegrotatedthumbnail.desktop
346 %{_datadir}/kde4/services/imagethumbnail.desktop
347 %{_datadir}/kde4/services/info.protocol
348 %{_datadir}/kde4/services/jpegthumbnail.desktop
349 %{_datadir}/kde4/services/kcm_kdnssd.desktop
350 %{_datadir}/kde4/services/kcmcgi.desktop
351 %{_datadir}/kde4/services/kcmkded.desktop
352 %{_datadir}/kde4/services/kcmnotify.desktop
353 %{_datadir}/kde4/services/kcmtrash.desktop
354 %{_datadir}/kde4/services/kded/device_automounter.desktop
355 %{_datadir}/kde4/services/kded/kpasswdserver.desktop
356 %{_datadir}/kde4/services/kded/ktimezoned.desktop
357 %{_datadir}/kde4/services/kded/nepomuksearchmodule.desktop
358 %{_datadir}/kde4/services/kded/networkstatus.desktop
359 %{_datadir}/kde4/services/kded/remotedirnotify.desktop
360 %{_datadir}/kde4/services/kded/soliduiserver.desktop
361 %{_datadir}/kde4/services/khelpcenter.desktop
362 %{_datadir}/kde4/services/kmanpart.desktop
363 %{_datadir}/kde4/services/knotify4.desktop
364 %{_datadir}/kde4/services/kshorturifilter.desktop
365 %{_datadir}/kde4/services/kuiserver.desktop
366 %{_datadir}/kde4/services/kuriikwsfilter.desktop
367 %{_datadir}/kde4/services/kurisearchfilter.desktop
368 %{_datadir}/kde4/services/kwalletd.desktop
369 %{_datadir}/kde4/services/language.desktop
370 %{_datadir}/kde4/services/localdomainurifilter.desktop
371 %{_datadir}/kde4/services/lzma.protocol
372 %{_datadir}/kde4/services/man.protocol
373 %{_datadir}/kde4/services/nepomuk.protocol
374 %{_datadir}/kde4/services/nfs.protocol
375 %{_datadir}/kde4/services/programs.protocol
376 %{_datadir}/kde4/services/remote.protocol
377 %{_datadir}/kde4/services/renaudiodlg.desktop
378 %{_datadir}/kde4/services/renimagedlg.desktop
379 %{_datadir}/kde4/services/searchproviders
380 %{_datadir}/kde4/services/settings.protocol
381 %{_datadir}/kde4/services/sftp.protocol
382 %{_datadir}/kde4/services/smb.protocol
383 %{_datadir}/kde4/services/svgthumbnail.desktop
384 %{_datadir}/kde4/services/tar.protocol
385 %{_datadir}/kde4/services/textthumbnail.desktop
386 %{_datadir}/kde4/services/thumbnail.protocol
387 %{_datadir}/kde4/services/timeline.protocol
388 %{_datadir}/kde4/services/trash.protocol
389 %{_datadir}/kde4/services/zip.protocol
390 %{_datadir}/kde4/services/xz.protocol
391 %{_datadir}/kde4/services/desktop.protocol
392 %{_datadir}/kde4/services/kded/desktopnotifier.desktop
393 %{_datadir}/kde4/services/desktopthumbnail.desktop
394 %{_datadir}/kde4/services/directorythumbnail.desktop
395 %{_datadir}/kde4/services/filetypes.desktop
396 %{_datadir}/kde4/services/kded/networkwatcher.desktop
397 %{_datadir}/kde4/services/kded/solidautoeject.desktop
398 %{_datadir}/kde4/services/kded/recentdocumentsnotifier.desktop
399 %{_datadir}/kde4/services/kglobalaccel.desktop
400 %{_datadir}/kde4/services/network.protocol
401 %{_datadir}/kde4/services/kcm_nepomuk.desktop
402 %{_datadir}/kde4/services/nepomuksearch.protocol
403 %{_datadir}/kde4/services/plasma-containment-newspaper.desktop
404 %{_datadir}/kde4/services/plasma-kpart.desktop
405 %{_datadir}/kde4/services/plasma-packagestructure-javascript-addon.desktop
406 %{_datadir}/kde4/services/plasma-scriptengine-applet-declarative.desktop
407 %{_datadir}/kde4/services/plasma-scriptengine-applet-simple-javascript.desktop
408 %{_datadir}/kde4/services/plasma-scriptengine-dataengine-javascript.desktop
409 %{_datadir}/kde4/services/plasma-scriptengine-runner-javascript.desktop
410 %{_datadir}/kde4/services/recentdocuments.protocol
411 %{_datadir}/kde4/services/windowsexethumbnail.desktop
412 %{_datadir}/kde4/services/windowsimagethumbnail.desktop
413 %{_datadir}/kde4/servicetypes/knotifynotifymethod.desktop
414 %{_datadir}/kde4/servicetypes/plasma-javascriptaddon.desktop
415 %{_datadir}/kde4/servicetypes/searchprovider.desktop
416 %{_datadir}/kde4/servicetypes/thumbcreator.desktop
417 %{_datadir}/desktop-directories
418 %{_datadir}/mime/packages/network.xml
419 %{_datadir}/autostart/nepomukcontroller.desktop
420
421 #%{_datadir}/locale/en_US/*
422 %dir %{_datadir}/locale/l10n
423 %{_datadir}/locale/l10n/C
424 %{_datadir}/locale/l10n/caribbean.desktop
425 %{_datadir}/locale/l10n/centralafrica.desktop
426 %{_datadir}/locale/l10n/centralamerica.desktop
427 %{_datadir}/locale/l10n/centralasia.desktop
428 %{_datadir}/locale/l10n/centraleurope.desktop
429 %{_datadir}/locale/l10n/eastafrica.desktop
430 %{_datadir}/locale/l10n/eastasia.desktop
431 %{_datadir}/locale/l10n/easteurope.desktop
432 %{_datadir}/locale/l10n/middleeast.desktop
433 %{_datadir}/locale/l10n/northafrica.desktop
434 %{_datadir}/locale/l10n/northamerica.desktop
435 %{_datadir}/locale/l10n/northeurope.desktop
436 %{_datadir}/locale/l10n/oceania.desktop
437 %{_datadir}/locale/l10n/southafrica.desktop
438 %{_datadir}/locale/l10n/southamerica.desktop
439 %{_datadir}/locale/l10n/southasia.desktop
440 %{_datadir}/locale/l10n/southeastasia.desktop
441 %{_datadir}/locale/l10n/southeurope.desktop
442 %{_datadir}/locale/l10n/westafrica.desktop
443 %{_datadir}/locale/l10n/westeurope.desktop
444 # really?
445 %{_datadir}/locale/currency
446
447 %{_desktopdir}/kde4/Help.desktop
448 %{_desktopdir}/kde4/knetattach.desktop
449 %lang(en) %{_kdedocdir}/en/kcontrol/*
450 %lang(en) %{_kdedocdir}/en/kdebugdialog
451 %lang(en) %{_kdedocdir}/en/kdesu
452 %lang(en) %{_kdedocdir}/en/khelpcenter
453 %lang(en) %{_kdedocdir}/en/kioslave/bzip2
454 %lang(en) %{_kdedocdir}/en/kioslave/bookmarks
455 %lang(en) %{_kdedocdir}/en/kioslave/cgi
456 %lang(en) %{_kdedocdir}/en/kioslave/finger
457 %lang(en) %{_kdedocdir}/en/kioslave/fish
458 %lang(en) %{_kdedocdir}/en/kioslave/floppy
459 %lang(en) %{_kdedocdir}/en/kioslave/gzip
460 %lang(en) %{_kdedocdir}/en/kioslave/info
461 %lang(en) %{_kdedocdir}/en/kioslave/man
462 %lang(en) %{_kdedocdir}/en/kioslave/nfs
463 %lang(en) %{_kdedocdir}/en/kioslave/sftp
464 %lang(en) %{_kdedocdir}/en/kioslave/smb
465 %lang(en) %{_kdedocdir}/en/kioslave/tar
466 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
467 %lang(en) %{_kdedocdir}/en/knetattach
468 %lang(en) %{_kdedocdir}/en/network
469 %lang(en) %{_mandir}/man1/kdesu.1*
470 %lang(en) %{_mandir}/man8/nepomuk*.8*
471
472 %{_datadir}/sounds/*
473 %{_iconsdir}/hicolor/*/*/*.png
474 %dir %{_datadir}/apps/ksmserver
475 %dir %{_datadir}/apps/ksmserver/windowmanagers
476 %{_datadir}/apps/ksmserver/windowmanagers/compiz-custom.desktop
477 %{_datadir}/apps/ksmserver/windowmanagers/compiz.desktop
478 %{_datadir}/apps/ksmserver/windowmanagers/metacity.desktop
479 %{_datadir}/apps/ksmserver/windowmanagers/openbox.desktop
480 %{_datadir}/apps/kio_docfilter
481 %dir %{_datadir}/apps/konqsidebartng
482 %dir %{_datadir}/apps/konqsidebartng/virtual_folders
483 %dir %{_datadir}/apps/konqsidebartng/virtual_folders/remote
484 %{_datadir}/apps/konqsidebartng/virtual_folders/remote/virtualfolder_network.desktop
485 %{_datadir}/apps/kwalletd
486 %{_datadir}/apps/remoteview/network.desktop
487
488 # dir owned by kdelibs
489 %{_datadir}/apps/desktoptheme/default/*
490 %{_datadir}/apps/desktoptheme/oxygen
491 %{_datadir}/apps/desktoptheme/appdashboard
492
493 %files devel
494 %defattr(644,root,root,755)
495 %{_includedir}/knotify*.h
496 %attr(755,root,root) %{_libdir}/libkwalletbackend.so
497 %attr(755,root,root) %{_libdir}/libmolletnetwork.so
498 %{_datadir}/apps/cmake/modules/FindCLucene.cmake
499 %{_datadir}/apps/cmake/modules/FindSLP.cmake
500
501 %files -n kde4-phonon
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
504 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
505 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
506 %attr(755,root,root) %{_libdir}/kde4/kcm_phononxine.so
507 %{_datadir}/kde4/services/kcm_phonon.desktop
508 %{_datadir}/kde4/services/spellchecking.desktop
509 %{_datadir}/kde4/servicetypes/phononbackend.desktop
510 %{_datadir}/kde4/services/kcm_phononxine.desktop
511
512 %dir %{_libdir}/kde4/plugins/phonon_platform
513 %{_libdir}/kde4/plugins/phonon_platform/kde.so
514 %dir %{_datadir}/apps/kcm_phonon
515 %{_datadir}/apps/kcm_phonon/listview-background.png
516 %{_datadir}/apps/kconf_update/devicepreference.upd
517 %dir %{_datadir}/apps/libphonon
518 %{_datadir}/apps/libphonon/hardwaredatabase
519 %dir %{_datadir}/apps/phonon
520 %{_datadir}/apps/phonon/phonon.notifyrc
521 %dir %{_datadir}/apps/kio_desktop
522 %dir %{_datadir}/apps/kio_desktop/DesktopLinks
523 %{_datadir}/apps/kio_desktop/DesktopLinks/Home.desktop
524 %{_datadir}/apps/kio_desktop/directory.desktop
525 %{_datadir}/apps/kio_desktop/directory.trash
526 %{_datadir}/kde4/services/kded/phononserver.desktop
This page took 0.059172 seconds and 4 git commands to generate.