]> git.pld-linux.org Git - packages/kde4-kdebase-runtime.git/blob - kde4-kdebase-runtime.spec
- added -qzeitgeist.patch (now builds with libqzeitgeist >= 0.8)
[packages/kde4-kdebase-runtime.git] / kde4-kdebase-runtime.spec
1 # TODO
2 # - l10n != %lang glibc locales (et = etiopia not estonia!)
3 #
4 # Conditional build:
5 #
6 %define         _state          stable
7 %define         orgname         kde-runtime
8 %define         qtver           4.7.4
9 %define         atticaver       0.2.0
10
11 Summary:        KDE 4 base runtime components
12 Summary(pl.UTF-8):      Komponenty uruchomieniowe podstawowej części KDE 4
13 Name:           kde4-kdebase-runtime
14 Version:        4.7.4
15 Release:        2
16 License:        GPL
17 Group:          X11/Applications
18 Source0:        ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
19 # Source0-md5:  8e6af5f464ae06e3b7cbfd73aa9f7971
20 Source1:        kdebase-searchproviders.tar.bz2
21 # Source1-md5:  126c3524b5367f5096a628acbf9dc86f
22 Source2:        l10n-iso639-1
23 Patch100:       %{name}-branch.diff
24 Patch0:         %{name}-rpc.patch
25 Patch1:         %{name}-qzeitgeist.patch
26 URL:            http://www.kde.org/
27 BuildRequires:  OpenEXR-devel
28 BuildRequires:  alsa-lib-devel
29 BuildRequires:  attica-devel >= %{atticaver}
30 BuildRequires:  automoc4 >= 0.9.88
31 BuildRequires:  bzip2-devel
32 BuildRequires:  clucene-core-devel >= 0.9.21
33 BuildRequires:  cmake >= 2.8.0
34 BuildRequires:  docbook-dtd42-xml
35 BuildRequires:  docbook-style-xsl
36 BuildRequires:  exiv2-devel >= 0.18.2
37 BuildRequires:  kde4-kdelibs-devel >= %{version}
38 BuildRequires:  kde4-kdepimlibs-devel >= %{version}
39 BuildRequires:  libcanberra-devel
40 BuildRequires:  libjpeg-devel
41 BuildRequires:  libqzeitgeist-devel >= 0.8
42 BuildRequires:  libsmbclient-devel
43 BuildRequires:  libssh-devel >= 1:0.4.0
44 BuildRequires:  libtirpc-devel
45 BuildRequires:  ntrack-devel
46 BuildRequires:  openslp-devel
47 BuildRequires:  phonon-devel >= 4.4.3
48 BuildRequires:  pkgconfig
49 BuildRequires:  pulseaudio-devel
50 BuildRequires:  qt4-build >= %{qtver}
51 BuildRequires:  qt4-qmake >= %{qtver}
52 BuildRequires:  rpmbuild(macros) >= 1.600
53 BuildRequires:  shared-desktop-ontologies-devel >= 0.7.1
54 BuildRequires:  shared-mime-info
55 BuildRequires:  soprano-devel >= 2.6.51
56 BuildRequires:  strigi-devel >= 0.7.0
57 BuildRequires:  xine-lib-devel
58 BuildRequires:  xz-devel
59 Requires:       attica >= %{atticaver}
60 Provides:       dbus(org.freedesktop.Notifications)
61 Obsoletes:      kdebase4-runtime
62 Conflicts:      kdebase4-runtime
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 KDE 4 runtime components.
67
68 %description -l pl.UTF-8
69 Komponenty uruchomieniowe podstawowej części KDE 4.
70
71 %package devel
72 Summary:        Development files for KDE 4 runtime components
73 Summary(pl.UTF-8):      Pliki programistyczne komponentów uruchomieniowych KDE 4
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       kde4-kdelibs-devel >= %{version}
77
78 %description devel
79 Development files for KDE 4 runtime components.
80
81 %description devel -l pl.UTF-8
82 Pliki programistyczne komponentów uruchomieniowych KDE 4.
83
84 %package -n kde4-phonon
85 Summary:        KDE 4 Phonon plugins
86 Summary(pl.UTF-8):      Wtyczki KDE 4 dla Phonona
87 Group:          X11/Applications
88
89 %description -n kde4-phonon
90 KDE 4 Phonon plugins.
91
92 %description -n kde4-phonon -l pl.UTF-8
93 Wtyczki KDE 4 dla Phonona.
94
95 %prep
96 %setup -q -n %{orgname}-%{version} -a1
97 #%patch100 -p1
98 %patch0 -p1
99 %patch1 -p1
100
101 %build
102 install -d build
103 cd build
104 %cmake \
105         -DLIBEXEC_INSTALL_DIR=%{_libdir}/kde4/libexec \
106         ../
107
108 %{__make}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} -C build install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         kde_htmldir=%{_kdedocdir}
116
117 install -d $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
118 cp -a kdebase-searchproviders/*.desktop $RPM_BUILD_ROOT%{_datadir}/kde4/services/searchproviders/pld
119
120 collect_l10n_files() {
121         while read country language comment; do
122                 [ "$country" != "#" ] || continue
123                 if [ "$language" = "-" ]; then
124                         # no mapping. just add for now
125                         echo >&2 "No mapping for $country $comment, adding without %%lang tag"
126                         echo "%{_datadir}/locale/l10n/$country"
127                 else
128                         echo "%lang($language) %{_datadir}/locale/l10n/$country"
129                 fi
130         done
131 } < %{SOURCE2}
132 collect_l10n_files > %{name}.files
133
134 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/default.kde4
135 # provided (conflicts) by hicolor-icon-theme
136 rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/index.theme
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files -f %{name}.files
145 %defattr(644,root,root,755)
146 %{_sysconfdir}/xdg/menus/kde-information.menu
147 %attr(755,root,root) %{_bindir}/kactivitymanagerd
148 %attr(755,root,root) %{_bindir}/kcmshell4
149 %attr(755,root,root) %{_bindir}/kde-cp
150 %attr(755,root,root) %{_bindir}/kde-mv
151 %attr(755,root,root) %{_bindir}/kde-open
152 %attr(755,root,root) %{_bindir}/kde4-menu
153 %attr(755,root,root) %{_bindir}/kdebugdialog
154 %attr(755,root,root) %{_bindir}/kfile4
155 %attr(755,root,root) %{_bindir}/kiconfinder
156 %attr(755,root,root) %{_bindir}/khelpcenter
157 %attr(755,root,root) %{_bindir}/khotnewstuff4
158 %attr(755,root,root) %{_bindir}/khotnewstuff-upload
159 %attr(755,root,root) %{_bindir}/kioclient
160 %attr(755,root,root) %{_bindir}/kmimetypefinder
161 %attr(755,root,root) %{_bindir}/knotify4
162 %attr(755,root,root) %{_bindir}/kquitapp
163 %attr(755,root,root) %{_bindir}/kreadconfig
164 %attr(755,root,root) %{_bindir}/kstart
165 %attr(755,root,root) %{_bindir}/kde4
166 %attr(755,root,root) %{_bindir}/kwalletd
167 %attr(755,root,root) %{_bindir}/ksvgtopng
168 %attr(755,root,root) %{_bindir}/keditfiletype
169 %attr(755,root,root) %{_bindir}/kglobalaccel
170 %attr(755,root,root) %{_bindir}/ktraderclient
171 %attr(755,root,root) %{_bindir}/ktrash
172 %attr(755,root,root) %{_bindir}/kuiserver
173 %attr(755,root,root) %{_bindir}/kwriteconfig
174 %attr(755,root,root) %{_bindir}/solid-hardware
175 %attr(755,root,root) %{_bindir}/nepomukbackup
176 %attr(755,root,root) %{_bindir}/nepomukcontroller
177 %attr(755,root,root) %{_bindir}/nepomukindexer
178 %attr(755,root,root) %{_bindir}/nepomukserver
179 %attr(755,root,root) %{_bindir}/nepomukservicestub
180 %attr(755,root,root) %{_bindir}/plasma-remote-helper
181 %attr(755,root,root) %{_bindir}/plasmapkg
182 %attr(755,root,root) %{_libdir}/attica_kde.so
183 %attr(755,root,root) %{_libdir}/libkdeinit4_kcmshell4.so
184 %attr(755,root,root) %{_libdir}/libkdeinit4_khelpcenter.so
185 %attr(755,root,root) %{_libdir}/libkdeinit4_kuiserver.so
186 %attr(755,root,root) %{_libdir}/libkdeinit4_kwalletd.so
187 %attr(755,root,root) %{_libdir}/libkdeinit4_kglobalaccel.so
188 %attr(755,root,root) %{_libdir}/libkdeinit4_nepomukserver.so
189 %attr(755,root,root) %{_libdir}/libknotifyplugin.so
190 %attr(755,root,root) %{_libdir}/libnepomukcommon.so
191 %attr(755,root,root) %{_libdir}/libnepomukdatamanagement.so
192 %attr(755,root,root) %{_libdir}/libnepomuksync.so.?
193 %attr(755,root,root) %{_libdir}/libnepomuksync.so.*.*.*
194 # Is it ok to add those files to main package?
195 %attr(755,root,root) %ghost %{_libdir}/libkwalletbackend.so.?
196 %attr(755,root,root) %{_libdir}/libkwalletbackend.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libmolletnetwork.so.?
198 %attr(755,root,root) %{_libdir}/libmolletnetwork.so.4.*.*
199 %attr(755,root,root) %{_libdir}/kde4/comicbookthumbnail.so
200 %attr(755,root,root) %{_libdir}/kde4/cursorthumbnail.so
201 %attr(755,root,root) %{_libdir}/kde4/djvuthumbnail.so
202 %attr(755,root,root) %{_libdir}/kde4/exrthumbnail.so
203 %attr(755,root,root) %{_libdir}/kde4/htmlthumbnail.so
204 %attr(755,root,root) %{_libdir}/kde4/imagethumbnail.so
205 #%attr(755,root,root) %{_libdir}/kde4/jpegrotatedthumbnail.so
206 %attr(755,root,root) %{_libdir}/kde4/jpegthumbnail.so
207 %attr(755,root,root) %{_libdir}/kde4/kcm_cgi.so
208 %attr(755,root,root) %{_libdir}/kde4/kcm_componentchooser.so
209 %attr(755,root,root) %{_libdir}/kde4/kcm_device_automounter.so
210 %attr(755,root,root) %{_libdir}/kde4/kcm_emoticons.so
211 %attr(755,root,root) %{_libdir}/kde4/kcm_filetypes.so
212 %attr(755,root,root) %{_libdir}/kde4/kcm_icons.so
213 %attr(755,root,root) %{_libdir}/kde4/kcm_kded.so
214 %attr(755,root,root) %{_libdir}/kde4/kcm_kdnssd.so
215 %attr(755,root,root) %{_libdir}/kde4/kcm_knotify.so
216 %attr(755,root,root) %{_libdir}/kde4/kcm_locale.so
217 %attr(755,root,root) %{_libdir}/kde4/kcm_nepomuk.so
218 %attr(755,root,root) %{_libdir}/kde4/kcm_trash.so
219 #%attr(755,root,root) %{_libdir}/kde4/kded_activitymanager.so
220 %attr(755,root,root) %{_libdir}/kde4/kded_device_automounter.so
221 %attr(755,root,root) %{_libdir}/kde4/kded_kpasswdserver.so
222 %attr(755,root,root) %{_libdir}/kde4/kded_ktimezoned.so
223 %attr(755,root,root) %{_libdir}/kde4/kded_remotedirnotify.so
224 %attr(755,root,root) %{_libdir}/kde4/kded_soliduiserver.so
225 %attr(755,root,root) %{_libdir}/kde4/kded_desktopnotifier.so
226 %attr(755,root,root) %{_libdir}/kde4/kded_nepomuksearchmodule.so
227 %attr(755,root,root) %{_libdir}/kde4/kded_networkstatus.so
228 %attr(755,root,root) %{_libdir}/kde4/kded_networkwatcher.so
229 %attr(755,root,root) %{_libdir}/kde4/kded_solidautoeject.so
230 %attr(755,root,root) %{_libdir}/kde4/kio_applications.so
231 %attr(755,root,root) %{_libdir}/kde4/kio_bookmarks.so
232 %attr(755,root,root) %{_libdir}/kde4/kio_desktop.so
233 %attr(755,root,root) %{_libdir}/kde4/kio_about.so
234 %attr(755,root,root) %{_libdir}/kde4/kio_archive.so
235 %attr(755,root,root) %{_libdir}/kde4/kio_cgi.so
236 %attr(755,root,root) %{_libdir}/kde4/kio_filter.so
237 %attr(755,root,root) %{_libdir}/kde4/kio_finger.so
238 %attr(755,root,root) %{_libdir}/kde4/kio_fish.so
239 %attr(755,root,root) %{_libdir}/kde4/kio_floppy.so
240 %attr(755,root,root) %{_libdir}/kde4/kio_info.so
241 %attr(755,root,root) %{_libdir}/kde4/kio_man.so
242 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuksearch.so
243 %attr(755,root,root) %{_libdir}/kde4/kio_network.so
244 %attr(755,root,root) %{_libdir}/kde4/kio_nfs.so
245 %attr(755,root,root) %{_libdir}/kde4/kio_remote.so
246 %attr(755,root,root) %{_libdir}/kde4/kio_settings.so
247 %attr(755,root,root) %{_libdir}/kde4/kio_sftp.so
248 %attr(755,root,root) %{_libdir}/kde4/kio_smb.so
249 %attr(755,root,root) %{_libdir}/kde4/kio_thumbnail.so
250 %attr(755,root,root) %{_libdir}/kde4/kio_timeline.so
251 %attr(755,root,root) %{_libdir}/kde4/kio_trash.so
252 %attr(755,root,root) %{_libdir}/kde4/kio_nepomuk.so
253 %attr(755,root,root) %{_libdir}/kde4/libkmanpart.so
254 %attr(755,root,root) %{_libdir}/kde4/fixhosturifilter.so
255 %attr(755,root,root) %{_libdir}/kde4/kcm_attica.so
256 %attr(755,root,root) %{_libdir}/kde4/kcm_phonon.so
257 %attr(755,root,root) %{_libdir}/kde4/kcmspellchecking.so
258 %attr(755,root,root) %{_libdir}/kde4/kshorturifilter.so
259 %attr(755,root,root) %{_libdir}/kde4/kuriikwsfilter.so
260 %attr(755,root,root) %{_libdir}/kde4/kurisearchfilter.so
261 %attr(755,root,root) %{_libdir}/kde4/localdomainurifilter.so
262 %attr(755,root,root) %{_libdir}/kde4/librenaudioplugin.so
263 %attr(755,root,root) %{_libdir}/kde4/librenimageplugin.so
264 #%attr(755,root,root) %{_libdir}/kde4/nepomukactivitiesservice.so
265 %attr(755,root,root) %{_libdir}/kde4/nepomukbackupsync.so
266 %attr(755,root,root) %{_libdir}/kde4/nepomukfilewatch.so
267 #%attr(755,root,root) %{_libdir}/kde4/nepomukmigration1.so
268 #%attr(755,root,root) %{_libdir}/kde4/nepomukontologyloader.so
269 %attr(755,root,root) %{_libdir}/kde4/nepomukqueryservice.so
270 #%attr(755,root,root) %{_libdir}/kde4/nepomukremovablestorageservice.so
271 %attr(755,root,root) %{_libdir}/kde4/nepomukstorage.so
272 %attr(755,root,root) %{_libdir}/kde4/nepomukstrigiservice.so
273 %attr(755,root,root) %{_libdir}/kde4/plasma-kpart.so
274 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_declarative.so
275 %attr(755,root,root) %{_libdir}/kde4/plasma_appletscript_simple_javascript.so
276 %attr(755,root,root) %{_libdir}/kde4/plasma_containment_newspaper.so
277 %attr(755,root,root) %{_libdir}/kde4/plasma_dataenginescript_javascript.so
278 %attr(755,root,root) %{_libdir}/kde4/plasma_packagestructure_javascriptaddon.so
279 %attr(755,root,root) %{_libdir}/kde4/plasma_runnerscript_javascript.so
280 %attr(755,root,root) %{_libdir}/kde4/svgthumbnail.so
281 %attr(755,root,root) %{_libdir}/kde4/textthumbnail.so
282 %attr(755,root,root) %{_libdir}/kde4/windowsexethumbnail.so
283 %attr(755,root,root) %{_libdir}/kde4/windowsimagethumbnail.so
284
285 %attr(755,root,root) %{_libdir}/kde4/imports
286
287 %attr(755,root,root) %{_libdir}/kde4/libexec/drkonqi
288 #%attr(755,root,root) %{_libdir}/kde4/libexec/installdbgsymbols.sh
289 %attr(755,root,root) %{_libdir}/kde4/libexec/kdeeject
290 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesu
291 %attr(755,root,root) %{_libdir}/kde4/libexec/kdesud
292 %attr(755,root,root) %{_libdir}/kde4/libexec/kdontchangethehostname
293 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_docbookdig.pl
294 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htdig.pl
295 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_htsearch.pl
296 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_indexbuilder
297 %attr(755,root,root) %{_libdir}/kde4/libexec/khc_mansearch.pl
298 %attr(755,root,root) %{_libdir}/kde4/libexec/kioexec
299 #%attr(755,root,root) %{_libdir}/kde4/libexec/klocaldomainurifilterhelper
300 %attr(755,root,root) %{_libdir}/kde4/libexec/knetattach
301 #%attr(755,root,root) %{_libdir}/strigi/strigiindex_nepomukbackend.so
302 %attr(755,root,root) %{_libdir}/kde4/libexec/kcmremotewidgetshelper
303 %{_sysconfdir}/dbus-1/system.d/org.kde.kcontrol.kcmremotewidgets.conf
304 %{_desktopdir}/kde4/nepomukbackup.desktop
305 %{_desktopdir}/kde4/nepomukcontroller.desktop
306 %{_datadir}/dbus-1/system-services/org.kde.kcontrol.kcmremotewidgets.service
307 %{_datadir}/polkit-1/actions/org.kde.kcontrol.kcmremotewidgets.policy
308 %{_datadir}/apps/drkonqi
309 %dir %{_datadir}/apps/kcm_componentchooser
310 %{_datadir}/apps/hardwarenotifications
311 %{_datadir}/apps/kcm_componentchooser/kcm_browser.desktop
312 %{_datadir}/apps/kcm_componentchooser/kcm_filemanager.desktop
313 %{_datadir}/apps/kcm_componentchooser/kcm_kemail.desktop
314 %{_datadir}/apps/kcm_componentchooser/kcm_terminal.desktop
315 %{_datadir}/apps/kcm_componentchooser/kcm_wm.desktop
316 %{_datadir}/apps/kcmlocale
317 %{_datadir}/apps/kconf_update/kuriikwsfilter.upd
318 %{_datadir}/apps/kde/kde.notifyrc
319 %dir %{_datadir}/apps/kglobalaccel
320 %{_datadir}/apps/kglobalaccel/kglobalaccel.notifyrc
321 %{_datadir}/apps/khelpcenter
322 %{_datadir}/apps/kio_bookmarks
323 %{_datadir}/apps/kio_finger
324 %{_datadir}/apps/kio_info
325 #%{_datadir}/apps/kio_thumbnail
326 %dir %{_datadir}/apps/konqueror/dirtree
327 %dir %{_datadir}/apps/konqueror/dirtree/remote
328 %{_datadir}/apps/konqueror/dirtree/remote/smb-network.desktop
329 %dir %{_datadir}/apps/remoteview
330 %{_datadir}/apps/remoteview/smb-network.desktop
331 #%dir %{_datadir}/apps/nepomuk
332 #%dir %{_datadir}/apps/nepomuk/ontologies
333 #%{_datadir}/apps/nepomuk/ontologies/*
334 %{_datadir}/apps/nepomukfilewatch
335 %dir %{_datadir}/apps/nepomukstorage
336 %{_datadir}/apps/nepomukstorage/nepomukstorage.notifyrc
337 %dir %{_datadir}/apps/nepomukstrigiservice
338 %{_datadir}/apps/nepomukstrigiservice/nepomukstrigiservice.notifyrc
339 %{_datadir}/config.kcfg/khelpcenter.kcfg
340 %{_datadir}/config.kcfg/jpegcreatorsettings.kcfg
341 %{_datadir}/config/khotnewstuff.knsrc
342 %{_datadir}/config/icons.knsrc
343 %{_datadir}/config/emoticons.knsrc
344 %{_datadir}/config/kshorturifilterrc
345 %{_datadir}/config/khotnewstuff_upload.knsrc
346 %{_datadir}/dbus-1/services/org.kde.knotify.service
347 %{_datadir}/dbus-1/services/org.kde.kuiserver.service
348 %{_datadir}/dbus-1/interfaces/*.xml
349 %{_datadir}/emoticons/kde4
350 %{_datadir}/kde4/services/about.protocol
351 %{_datadir}/kde4/services/applications.protocol
352 %{_datadir}/kde4/services/ar.protocol
353 %{_datadir}/kde4/services/kcm_attica.desktop
354 %{_datadir}/kde4/services/bookmarks.protocol
355 %{_datadir}/kde4/services/bzip.protocol
356 %{_datadir}/kde4/services/bzip2.protocol
357 %{_datadir}/kde4/services/cgi.protocol
358 %{_datadir}/kde4/services/comicbookthumbnail.desktop
359 %{_datadir}/kde4/services/componentchooser.desktop
360 %{_datadir}/kde4/services/cursorthumbnail.desktop
361 %{_datadir}/kde4/services/device_automounter_kcm.desktop
362 %{_datadir}/kde4/services/djvuthumbnail.desktop
363 %{_datadir}/kde4/services/emoticons.desktop
364 %{_datadir}/kde4/services/exrthumbnail.desktop
365 %{_datadir}/kde4/services/finger.protocol
366 %{_datadir}/kde4/services/fish.protocol
367 %{_datadir}/kde4/services/fixhosturifilter.desktop
368 %{_datadir}/kde4/services/floppy.protocol
369 %{_datadir}/kde4/services/gzip.protocol
370 %{_datadir}/kde4/services/htmlthumbnail.desktop
371 %{_datadir}/kde4/services/icons.desktop
372 #%{_datadir}/kde4/services/jpegrotatedthumbnail.desktop
373 %{_datadir}/kde4/services/imagethumbnail.desktop
374 %{_datadir}/kde4/services/info.protocol
375 %{_datadir}/kde4/services/jpegthumbnail.desktop
376 %{_datadir}/kde4/services/kactivitymanagerd.desktop
377 %{_datadir}/kde4/services/kcm_kdnssd.desktop
378 %{_datadir}/kde4/services/kcmcgi.desktop
379 %{_datadir}/kde4/services/kcmkded.desktop
380 %{_datadir}/kde4/services/kcmnotify.desktop
381 %{_datadir}/kde4/services/kcmtrash.desktop
382 %{_datadir}/kde4/services/kded/activitymanager.desktop
383 %{_datadir}/kde4/services/kded/device_automounter.desktop
384 %{_datadir}/kde4/services/kded/kpasswdserver.desktop
385 %{_datadir}/kde4/services/kded/ktimezoned.desktop
386 %{_datadir}/kde4/services/kded/nepomuksearchmodule.desktop
387 %{_datadir}/kde4/services/kded/networkstatus.desktop
388 %{_datadir}/kde4/services/kded/remotedirnotify.desktop
389 %{_datadir}/kde4/services/kded/soliduiserver.desktop
390 %{_datadir}/kde4/services/khelpcenter.desktop
391 %{_datadir}/kde4/services/kmanpart.desktop
392 %{_datadir}/kde4/services/knotify4.desktop
393 %{_datadir}/kde4/services/kshorturifilter.desktop
394 %{_datadir}/kde4/services/kuiserver.desktop
395 %{_datadir}/kde4/services/kuriikwsfilter.desktop
396 %{_datadir}/kde4/services/kurisearchfilter.desktop
397 %{_datadir}/kde4/services/kwalletd.desktop
398 %{_datadir}/kde4/services/language.desktop
399 %{_datadir}/kde4/services/localdomainurifilter.desktop
400 %{_datadir}/kde4/services/lzma.protocol
401 %{_datadir}/kde4/services/man.protocol
402 %{_datadir}/kde4/services/nepomuk.protocol
403 %{_datadir}/kde4/services/nepomukactivitiesservice.desktop
404 %{_datadir}/kde4/services/nepomukbackupsync.desktop
405 %{_datadir}/kde4/services/nepomukremovablestorageservice.desktop
406 %{_datadir}/kde4/services/nfs.protocol
407 %{_datadir}/kde4/services/programs.protocol
408 %{_datadir}/kde4/services/remote.protocol
409 %{_datadir}/kde4/services/renaudiodlg.desktop
410 %{_datadir}/kde4/services/renimagedlg.desktop
411 %{_datadir}/kde4/services/searchproviders
412 %{_datadir}/kde4/services/settings.protocol
413 %{_datadir}/kde4/services/sftp.protocol
414 %{_datadir}/kde4/services/smb.protocol
415 %{_datadir}/kde4/services/svgthumbnail.desktop
416 %{_datadir}/kde4/services/tar.protocol
417 %{_datadir}/kde4/services/textthumbnail.desktop
418 %{_datadir}/kde4/services/thumbnail.protocol
419 %{_datadir}/kde4/services/timeline.protocol
420 %{_datadir}/kde4/services/trash.protocol
421 %{_datadir}/kde4/services/zip.protocol
422 %{_datadir}/kde4/services/xz.protocol
423 %{_datadir}/kde4/services/desktop.protocol
424 %{_datadir}/kde4/services/kded/desktopnotifier.desktop
425 %{_datadir}/kde4/services/desktopthumbnail.desktop
426 %{_datadir}/kde4/services/directorythumbnail.desktop
427 %{_datadir}/kde4/services/filetypes.desktop
428 %{_datadir}/kde4/services/kded/networkwatcher.desktop
429 %{_datadir}/kde4/services/kded/solidautoeject.desktop
430 %{_datadir}/kde4/services/kglobalaccel.desktop
431 %{_datadir}/kde4/services/network.protocol
432 %{_datadir}/kde4/services/kcm_nepomuk.desktop
433 %{_datadir}/kde4/services/nepomukfilewatch.desktop
434 #%{_daetadir}/kde4/services/nepomukmigration1.desktop
435 %{_datadir}/kde4/services/nepomukontologyloader.desktop
436 %{_datadir}/kde4/services/nepomukqueryservice.desktop
437 %{_datadir}/kde4/services/nepomuksearch.protocol
438 %{_datadir}/kde4/services/nepomukstorage.desktop
439 %{_datadir}/kde4/services/nepomukstrigiservice.desktop
440 %{_datadir}/kde4/services/plasma-containment-newspaper.desktop
441 %{_datadir}/kde4/services/plasma-kpart.desktop
442 %{_datadir}/kde4/services/plasma-packagestructure-javascript-addon.desktop
443 %{_datadir}/kde4/services/plasma-scriptengine-applet-declarative.desktop
444 %{_datadir}/kde4/services/plasma-scriptengine-applet-simple-javascript.desktop
445 %{_datadir}/kde4/services/plasma-scriptengine-dataengine-javascript.desktop
446 %{_datadir}/kde4/services/plasma-scriptengine-runner-javascript.desktop
447 %{_datadir}/kde4/services/windowsexethumbnail.desktop
448 %{_datadir}/kde4/services/windowsimagethumbnail.desktop
449 %{_datadir}/kde4/servicetypes/knotifynotifymethod.desktop
450 %{_datadir}/kde4/servicetypes/nepomukservice.desktop
451 %{_datadir}/kde4/servicetypes/plasma-javascriptaddon.desktop
452 %{_datadir}/kde4/servicetypes/searchprovider.desktop
453 %{_datadir}/kde4/servicetypes/thumbcreator.desktop
454 %{_datadir}/desktop-directories
455 %{_datadir}/mime/packages/network.xml
456 %{_datadir}/autostart/nepomukcontroller.desktop
457 %{_datadir}/autostart/nepomukserver.desktop
458
459 %dir %{_datadir}/ontology/kde
460 %{_datadir}/ontology/kde/*.ontology
461 %{_datadir}/ontology/kde/*.trig
462
463 #%{_datadir}/locale/en_US/*
464 %dir %{_datadir}/locale/l10n
465 %{_datadir}/locale/l10n/C
466 %{_datadir}/locale/l10n/caribbean.desktop
467 %{_datadir}/locale/l10n/centralafrica.desktop
468 %{_datadir}/locale/l10n/centralamerica.desktop
469 %{_datadir}/locale/l10n/centralasia.desktop
470 %{_datadir}/locale/l10n/centraleurope.desktop
471 %{_datadir}/locale/l10n/eastafrica.desktop
472 %{_datadir}/locale/l10n/eastasia.desktop
473 %{_datadir}/locale/l10n/easteurope.desktop
474 %{_datadir}/locale/l10n/middleeast.desktop
475 %{_datadir}/locale/l10n/northafrica.desktop
476 %{_datadir}/locale/l10n/northamerica.desktop
477 %{_datadir}/locale/l10n/northeurope.desktop
478 %{_datadir}/locale/l10n/oceania.desktop
479 %{_datadir}/locale/l10n/southafrica.desktop
480 %{_datadir}/locale/l10n/southamerica.desktop
481 %{_datadir}/locale/l10n/southasia.desktop
482 %{_datadir}/locale/l10n/southeastasia.desktop
483 %{_datadir}/locale/l10n/southeurope.desktop
484 %{_datadir}/locale/l10n/westafrica.desktop
485 %{_datadir}/locale/l10n/westeurope.desktop
486 # really?
487 %{_datadir}/locale/currency
488
489 %{_desktopdir}/kde4/Help.desktop
490 %{_desktopdir}/kde4/knetattach.desktop
491 %lang(en) %{_kdedocdir}/en/kcontrol/*
492 %lang(en) %{_kdedocdir}/en/kdebugdialog
493 %lang(en) %{_kdedocdir}/en/kdesu
494 %lang(en) %{_kdedocdir}/en/khelpcenter
495 %lang(en) %{_kdedocdir}/en/kioslave/bzip2
496 %lang(en) %{_kdedocdir}/en/kioslave/bookmarks
497 %lang(en) %{_kdedocdir}/en/kioslave/cgi
498 %lang(en) %{_kdedocdir}/en/kioslave/finger
499 %lang(en) %{_kdedocdir}/en/kioslave/fish
500 %lang(en) %{_kdedocdir}/en/kioslave/floppy
501 %lang(en) %{_kdedocdir}/en/kioslave/gzip
502 %lang(en) %{_kdedocdir}/en/kioslave/info
503 %lang(en) %{_kdedocdir}/en/kioslave/man
504 %lang(en) %{_kdedocdir}/en/kioslave/nfs
505 %lang(en) %{_kdedocdir}/en/kioslave/sftp
506 %lang(en) %{_kdedocdir}/en/kioslave/smb
507 %lang(en) %{_kdedocdir}/en/kioslave/tar
508 %lang(en) %{_kdedocdir}/en/kioslave/thumbnail
509 %lang(en) %{_kdedocdir}/en/knetattach
510 %lang(en) %{_kdedocdir}/en/network
511 %lang(en) %{_mandir}/man1/kdesu.1*
512 %lang(en) %{_mandir}/man8/nepomuk*.8*
513
514 %{_datadir}/sounds/*
515 %{_iconsdir}/hicolor/*/*/*.png
516 %dir %{_datadir}/apps/ksmserver
517 %dir %{_datadir}/apps/ksmserver/windowmanagers
518 %{_datadir}/apps/ksmserver/windowmanagers/compiz-custom.desktop
519 %{_datadir}/apps/ksmserver/windowmanagers/compiz.desktop
520 %{_datadir}/apps/ksmserver/windowmanagers/metacity.desktop
521 %{_datadir}/apps/ksmserver/windowmanagers/openbox.desktop
522 %{_datadir}/apps/kio_docfilter
523 %dir %{_datadir}/apps/konqsidebartng
524 %dir %{_datadir}/apps/konqsidebartng/virtual_folders
525 %dir %{_datadir}/apps/konqsidebartng/virtual_folders/remote
526 %{_datadir}/apps/konqsidebartng/virtual_folders/remote/virtualfolder_network.desktop
527 %{_datadir}/apps/kwalletd
528 %{_datadir}/apps/remoteview/network.desktop
529
530 # dir owned by kdelibs
531 %{_datadir}/apps/desktoptheme/default/*
532 %{_datadir}/apps/desktoptheme/oxygen
533 %{_datadir}/apps/desktoptheme/appdashboard
534
535 %files devel
536 %defattr(644,root,root,755)
537 %{_includedir}/knotify*.h
538 %{_includedir}/nepomuk
539 %{_libdir}/libkwalletbackend.so
540 %{_libdir}/libmolletnetwork.so
541 %{_libdir}/libnepomuksync.so
542 %{_datadir}/apps/cmake/modules/FindCLucene.cmake
543 %{_datadir}/apps/cmake/modules/FindSLP.cmake
544
545 %files -n kde4-phonon
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_devicepreference_update
548 %attr(755,root,root) %{_libdir}/kconf_update_bin/phonon_deviceuids_update
549 %attr(755,root,root) %{_libdir}/kde4/kded_phononserver.so
550 %attr(755,root,root) %{_libdir}/kde4/kcm_phononxine.so
551 %{_datadir}/kde4/services/kcm_phonon.desktop
552 %{_datadir}/kde4/services/spellchecking.desktop
553 %{_datadir}/kde4/servicetypes/phononbackend.desktop
554 %{_datadir}/kde4/services/kcm_phononxine.desktop
555
556 %dir %{_libdir}/kde4/plugins/phonon_platform
557 %{_libdir}/kde4/plugins/phonon_platform/kde.so
558 %dir %{_datadir}/apps/kcm_phonon
559 %{_datadir}/apps/kcm_phonon/listview-background.png
560 %{_datadir}/apps/kconf_update/devicepreference.upd
561 %dir %{_datadir}/apps/libphonon
562 %{_datadir}/apps/libphonon/hardwaredatabase
563 %dir %{_datadir}/apps/phonon
564 %{_datadir}/apps/phonon/phonon.notifyrc
565 %dir %{_datadir}/apps/kio_desktop
566 %dir %{_datadir}/apps/kio_desktop/DesktopLinks
567 %{_datadir}/apps/kio_desktop/DesktopLinks/Home.desktop
568 %{_datadir}/apps/kio_desktop/directory.desktop
569 %{_datadir}/apps/kio_desktop/directory.trash
570 %{_datadir}/kde4/services/kded/phononserver.desktop
This page took 0.098372 seconds and 4 git commands to generate.