]> git.pld-linux.org Git - packages/kaffeine.git/blob - kaffeine.spec
81c8bbfb0355382be44ddd0a3c3e8f98c31e100b
[packages/kaffeine.git] / kaffeine.spec
1 # TODO
2 # - kaffeine-mozilla-0.2.tar.bz2 (Starter-Plugin for Mozilla)
3 # - check: http://kaffeine.sourceforge.net/index.php?page=faq#question4
4
5 %define         qt_ver  4.4
6 Summary:        Full featured Multimedia-Player for KDE
7 Summary(pl.UTF-8):      Frontend do xine pod KDE
8 Name:           kaffeine
9 Version:        1.0
10 Release:        1.1
11 License:        GPL v2+
12 Group:          X11/Applications/Multimedia
13 Source0:        http://downloads.sourceforge.net/project/kaffeine/kaffeine/%{name}-%{version}/kaffeine-%{version}.tar.gz
14 # Source0-md5:  81bac76f931245a75f20ed26a37c55e3
15 URL:            http://kaffeine.kde.org/
16 BuildRequires:  QtNetwork-devel
17 BuildRequires:  QtSvg-devel
18 BuildRequires:  automoc4
19 BuildRequires:  cmake
20 BuildRequires:  gettext-devel
21 BuildRequires:  kde4-kdelibs-devel >= 4.2
22 BuildRequires:  phonon-devel >= 4.3
23 BuildRequires:  qt4-build >= %{qt_ver}
24 BuildRequires:  qt4-qmake >= %{qt_ver}
25 BuildRequires:  rpmbuild(macros) >= 1.122
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Kaffeine is a full featured Multimedia-Player for KDE. By default it
30 uses xine as backend.
31
32 %description -l pl.UTF-8
33 W pełni zintegrowany z KDE frontend do xine.
34
35 %prep
36 %setup -q
37
38 %build
39 install -d build
40 cd build
41 %cmake .. \
42         -DCMAKE_INSTALL_PREFIX=%{_prefix} \
43         -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
44 %if "%{_lib}" == "lib64"
45         -DLIB_SUFFIX=64
46 %endif
47
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} -C build install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/x-test
57
58 %find_lang %{name}
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %post   -p /sbin/ldconfig
64 %postun -p /sbin/ldconfig
65
66 %files -f %{name}.lang
67 %defattr(644,root,root,755)
68 %attr(755,root,root) %{_bindir}/kaffeine
69 %attr(755,root,root) %{_bindir}/kaffeine-xbu
70 %{_datadir}/apps/profiles/kaffeine.profile.xml
71 %{_datadir}/apps/kaffeine
72 %{_datadir}/apps/solid/actions/*.desktop
73 %{_desktopdir}/kde4/kaffeine.desktop
74 %{_iconsdir}/oxygen/*/actions/audio-radio-encrypted.png
75 %{_iconsdir}/oxygen/*/actions/video-television-encrypted.png
This page took 0.02372 seconds and 2 git commands to generate.