]> git.pld-linux.org Git - packages/ka5-spectacle.git/blob - ka5-spectacle.spec
- updated to 22.12.0
[packages/ka5-spectacle.git] / ka5-spectacle.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.12.0
5 %define         qtver           5.15.2
6 %define         kaname          spectacle
7
8 Summary:        Spectacle
9 Summary(pl.UTF-8):      Spectacle
10 Name:           ka5-%{kaname}
11 Version:        22.12.0
12 Release:        1
13 License:        GPL
14 Group:          X11/Applications/Editors
15 Source0:        https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
16 # Source0-md5:  d286bd549641c16f7c28fb93aaa1935b
17 URL:            http://www.kde.org/
18 BuildRequires:  Qt5Concurrent-devel
19 BuildRequires:  Qt5Core-devel
20 BuildRequires:  Qt5DBus-devel
21 BuildRequires:  Qt5Gui-devel >= 5.11.1
22 BuildRequires:  Qt5Network-devel >= 5.11.1
23 BuildRequires:  Qt5PrintSupport-devel
24 BuildRequires:  Qt5Qml-devel >= 5.11.1
25 BuildRequires:  Qt5Quick-devel
26 BuildRequires:  Qt5Widgets-devel
27 BuildRequires:  Qt5X11Extras-devel >= 5.6.0
28 BuildRequires:  gettext-devel
29 BuildRequires:  kColorPicker-devel
30 BuildRequires:  kf5-extra-cmake-modules >= 5.53.0
31 BuildRequires:  kf5-kconfig-devel >= 5.29.0
32 BuildRequires:  kf5-kcoreaddons-devel >= 5.29.0
33 BuildRequires:  kf5-kdbusaddons-devel >= 5.29.0
34 BuildRequires:  kf5-kdeclarative-devel >= 5.29.0
35 BuildRequires:  kf5-kdoctools-devel >= 5.29.0
36 BuildRequires:  kf5-ki18n-devel >= 5.29.0
37 BuildRequires:  kf5-kio-devel >= 5.29.0
38 BuildRequires:  kf5-knewstuff-devel >= 5.29.0
39 BuildRequires:  kf5-knotifications-devel >= 5.29.0
40 BuildRequires:  kf5-kwayland-devel
41 BuildRequires:  kf5-kwidgetsaddons-devel >= 5.29.0
42 BuildRequires:  kf5-kwindowsystem-devel >= 5.29.0
43 BuildRequires:  kf5-kxmlgui-devel >= 5.29.0
44 BuildRequires:  ninja
45 BuildRequires:  qt5-build >= 5.6.0
46 BuildRequires:  shared-mime-info
47 BuildRequires:  xcb-util-cursor-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Spectacle is a simple application for taking screenshots. It is
52 capable of capturing images of either the whole desktop or just a
53 single window. The images can then be saved in a variety of formats.
54
55 %description -l pl.UTF-8
56 Spectacle to prosta aplikacja do robienia zrzutów ekranu. Potrafi
57 przechwytywać obraz całego pulpitu lub tylko pojedynczego okna.
58 Obrazy mogą być następnie zapisane w wielu formatach.
59
60 %prep
61 %setup -q -n %{kaname}-%{version}
62
63 %build
64 install -d build
65 cd build
66 %cmake -G Ninja \
67         %{!?with_tests:-DBUILD_TESTING=OFF} \
68         -DHTML_INSTALL_DIR=%{_kdedocdir} \
69         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
70         ..
71 %ninja_build
72
73 %if %{with tests}
74 ctest
75 %endif
76
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %ninja_install -C build
81
82 %find_lang %{kaname} --all-name --with-kde
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files -f %{kaname}.lang
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_bindir}/spectacle
90 %{_desktopdir}/org.kde.spectacle.desktop
91 %{_datadir}/dbus-1/interfaces/org.kde.Spectacle.xml
92 %{_datadir}/dbus-1/services/org.kde.Spectacle.service
93 %{_datadir}/knotifications5/spectacle.notifyrc
94 %{_datadir}/metainfo/org.kde.spectacle.appdata.xml
95 %attr(755,root,root) %{_libdir}/kconf_update_bin/spectacle-migrate-shortcuts
96 %attr(755,root,root) %{_libdir}/kconf_update_bin/spectacle-migrate-rememberregion
97 %{_datadir}/kconf_update/spectacle_rememberregion.upd
98 %attr(755,root,root) %{_datadir}/kconf_update/50-clipboard_settings_change.py
99 %{_datadir}/kconf_update/spectacle_clipboard.upd
100 %{_datadir}/kconf_update/spectacle_shortcuts.upd
101 %dir %{_datadir}/kglobalaccel
102 %{_datadir}/kglobalaccel/org.kde.spectacle.desktop
103 %{_datadir}/qlogging-categories5/spectacle.categories
104 %{_datadir}/kconf_update/spectacle_newConfig.upd
105 %{systemduserunitdir}/app-org.kde.spectacle.service
106 %{_mandir}/ca/man1/spectacle.1*
107 %{_mandir}/de/man1/spectacle.1*
108 %{_mandir}/es/man1/spectacle.1*
109 %{_mandir}/it/man1/spectacle.1*
110 %{_mandir}/man1/spectacle.1*
111 %{_mandir}/nl/man1/spectacle.1*
112 %{_mandir}/sv/man1/spectacle.1*
113 %{_mandir}/uk/man1/spectacle.1*
114 %{_iconsdir}/hicolor/scalable/apps/spectacle.svg
This page took 0.108276 seconds and 3 git commands to generate.