]> git.pld-linux.org Git - packages/ka5-kdevelop.git/blob - ka5-kdevelop.spec
- updated to 5.3.2
[packages/ka5-kdevelop.git] / ka5-kdevelop.spec
1 #
2 # Conditional build:
3 #
4 %define         _state          stable
5 %define         qtver           5.5.1
6 %define         orgname         kdevelop
7
8 Summary:        KDE Integrated Development Environment
9 Summary(de.UTF-8):      KDevelop ist eine grafische Entwicklungsumgebung für KDE
10 Summary(pl.UTF-8):      Zintegrowane środowisko programisty dla KDE
11 Summary(pt_BR.UTF-8):   Ambiente Integrado de Desenvolvimento para o KDE
12 Summary(zh_CN.UTF-8):   KDE C/C++集成开发环境
13 Name:           ka5-kdevelop
14 Version:        5.3.2
15 Release:        0.1
16 License:        GPL
17 Group:          X11/Development/Tools
18 Source0:        http://download.kde.org/%{_state}/kdevelop/%{version}/src/%{orgname}-%{version}.tar.xz
19 # Source0-md5:  6e30713e19c20e987e1a943d47cd1d65
20 URL:            http://www.kdevelop.org/
21 BuildRequires:  cmake >= 2.8.9
22 BuildRequires:  docbook-style-xsl
23 BuildRequires:  gettext-tools
24 BuildRequires:  ka5-okteta-devel
25
26 BuildRequires:  kf5-kcrash-devel
27 BuildRequires:  kf5-kdoctools-devel
28 BuildRequires:  kf5-plasma-framework-devel
29 BuildRequires:  kf5-krunner-devel
30 BuildRequires:  kp5-libksysguard-devel
31 BuildRequires:  clang-devel
32 BuildRequires:  Qt5Help-devel
33 BuildRequires:  Qt5WebEngine-devel
34 BuildRequires:  qt5-assistant
35 BuildRequires:  docbook-dtd45-xml
36
37 BuildRequires:  libstdc++-devel >= 3.3
38 BuildRequires:  pkgconfig
39 BuildRequires:  rpmbuild(macros) >= 1.600
40 BuildRequires:  zlib-devel >= 1.2.0
41 BuildConflicts: star
42 Requires:       libstdc++-gdb
43 Requires(post,postun):  desktop-file-utils
44 Requires(post,postun):  shared-mime-info
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 The KDevelop Integrated Development Environment provides many features
49 that developers need as well as providing a unified interface to
50 programs like gdb, the C/C++ compiler, and make.
51
52 KDevelop manages or provides: all development tools needed for C++
53 programming like Compiler, Linker, automake and autoconf; KAppWizard,
54 which generates complete, ready-to-go sample applications;
55 Classgenerator, for creating new classes and integrating them into the
56 current project; File management for sources, headers, documentation
57 etc. to be included in the project; The creation of User-Handbooks
58 written with SGML and the automatic generation of HTML-output with the
59 KDE look and feel; Automatic HTML-based API-documentation for your
60 project's classes with cross-references to the used libraries;
61 Internationalization support for your application, allowing
62 translators to easily add their target language to a project;
63
64 KDevelop also includes WYSIWYG (What you see is what you get)-creation
65 of user interfaces with a built-in dialog editor; Debugging your
66 application by integrating KDbg; Editing of project-specific pixmaps
67 with KIconEdit; The inclusion of any other program you need for
68 development by adding it to the "Tools"-menu according to your
69 individual needs.
70
71 %description -l de.UTF-8
72 KDevelop ist eine grafische Entwicklungsumgebung für KDE.
73
74 Das KDevelop-Projekt wurde 1998 begonnen, um eine einfach zu
75 bedienende grafische (integrierte) Entwicklungsumgebung für C++ und C
76 auf Unix-basierten Betriebssystemen bereitzustellen. Seit damals ist
77 die KDevelop-IDE öffentlich unter der GPL erhältlich und unterstützt
78 u. a. Qt-, KDE-, GNOME-, C++- und C-Projekte.
79
80 %description -l pl.UTF-8
81 KDevelop to zintegrowane środowisko programistyczne dla KDE, dające
82 wiele możliwości przydatnych programistom oraz zunifikowany interfejs
83 do programów typu gdb, kompilator C/C++ oraz make.
84
85 KDevelop obsługuje lub zawiera: wszystkie narzędzia programistyczne
86 potrzebne do programowania w C++ jak kompilator, linker, automake,
87 autoconf; KAppWizard, generujący kompletne, gotowe do uruchomienia,
88 proste aplikacje; Classgenerator do tworzenia nowych klas i włączania
89 ich do projektu; zarządzanie plikami źródłowymi, nagłówkowymi,
90 dokumentacją itp.; tworzenie podręczników użytkownika pisanych w SGML
91 i automatyczne generowanie wyjścia HTML pasującego do KDE;
92 automatyczne tworzenie dokumentacji API w HTML do klas projektu z
93 odniesieniami do używanych bibliotek; wsparcie dla
94 internacjonalizacji, pozwalające tłumaczom łatwo dodawać pliki z
95 tłumaczeniami do projektu.
96
97 KDevelop ma także tworzenie interfejsów użytkownika przy użyciu
98 edytora dialogów WYSIWYG; odpluskwianie aplikacji poprzez integrację z
99 KDbg; edycję ikon przy pomocy KIconEdit; dołączanie innych programów
100 potrzebnych do programowania przez dodanie ich do menu Tools według
101 własnych potrzeb.
102
103 %package devel
104 Summary:        kdevelop - header files and development documentation
105 Summary(pl.UTF-8):      kdevelop - pliki nagłówkowe i dokumentacja
106 Group:          X11/Development/Libraries
107 Requires:       %{name} = %{version}-%{release}
108
109 %description devel
110 This package contains header files and development documentation for
111 kdevelop.
112
113 %description devel -l pl.UTF-8
114 Pakiet ten zawiera pliki nagłówkowe i dokumentację potrzebną przy
115 pisaniu własnych programów wykorzystujących kdevelop.
116
117 %prep
118 %setup -q -n %{orgname}-%{version}
119
120 %build
121 install -d build
122 cd build
123 %cmake \
124         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
125         ../
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 install -d $RPM_BUILD_ROOT%{_desktopdir}
132 %{__make} -C build install \
133         DESTDIR=$RPM_BUILD_ROOT \
134         kde_htmldir=%{_kdedocdir}
135
136 %find_lang %{orgname} --all-name --with-kde
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 /sbin/ldconfig
143 %update_mime_database
144 %update_desktop_database
145
146 %postun
147 /sbin/ldconfig
148 %update_mime_database
149 %update_desktop_database_postun
150
151 %files -f %{orgname}.lang
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/kdevelop
154 %attr(755,root,root) %{_bindir}/kdevelop!
155 %attr(755,root,root) %{_bindir}/kdev_includepathsconverter
156 %attr(755,root,root) %{_libdir}/qt5/plugins/kdevplatform/*/kdev*.so
157 %attr(755,root,root) %{_libdir}/qt5/plugins/krunner_kdevelopsessions.so
158 %dir %{_libdir}/qt5/plugins/plasma/dataengine
159 %attr(755,root,root) %{_libdir}/qt5/plugins/plasma/dataengine/plasma_engine_kdevelopsessions.so
160 %attr(755,root,root) %{_libdir}/libKDevClangPrivate.so.*
161 %attr(755,root,root) %{_libdir}/libkdevcmakecommon.so
162 %{_datadir}/doc/HTML/en/kdevelop
163 %{_datadir}/kdevappwizard
164 %{_datadir}/kdevclangsupport
165 %{_datadir}/kdevelop
166 %{_datadir}/kdevfiletemplates
167 %{_datadir}/kdevgdb
168 %{_datadir}/kdevlldb
169 %{_datadir}/kdevmanpage
170 %{_datadir}/kdevqmljssupport
171 %{_datadir}/knotifications5/*
172 %{_datadir}/metainfo/*
173 %{_datadir}/mime/packages/*
174 %{_datadir}/kservices5/*
175 %{_datadir}/plasma/plasmoids/kdevelopsessions
176 %{_datadir}/plasma/services/org.kde.plasma.dataengine.kdevelopsessions.operations
177 %{_desktopdir}/org.kde.kdevelop.desktop
178 %{_desktopdir}/org.kde.kdevelop_*.desktop
179 %{_iconsdir}/*/*x*/*/*.png
180 %{_sysconfdir}/xdg/*.categories
181
182 #kdevplatform
183 %attr(755,root,root) %{_bindir}/kdev_dbus_socket_transformer
184 %attr(755,root,root) %{_bindir}/kdev_format_source
185 %attr(755,root,root) %{_bindir}/kdevplatform_shell_environment.sh
186 %attr(755,root,root) %{_libdir}/libKDevPlatformDebugger.so.*.*.*
187 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformDebugger.so.??
188 %attr(755,root,root) %{_libdir}/libKDevPlatformDocumentation.so.*.*.*
189 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformDocumentation.so.??
190 %attr(755,root,root) %{_libdir}/libKDevPlatformInterfaces.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformInterfaces.so.??
192 %attr(755,root,root) %{_libdir}/libKDevPlatformLanguage.so.*.*.*
193 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformLanguage.so.??
194 %attr(755,root,root) %{_libdir}/libKDevPlatformOutputView.so.*.*.*
195 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformOutputView.so.??
196 %attr(755,root,root) %{_libdir}/libKDevPlatformProject.so.*.*.*
197 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformProject.so.??
198 %attr(755,root,root) %{_libdir}/libKDevPlatformSerialization.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformSerialization.so.??
200 %attr(755,root,root) %{_libdir}/libKDevPlatformShell.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformShell.so.??
202 %attr(755,root,root) %{_libdir}/libKDevPlatformSublime.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformSublime.so.??
204 %attr(755,root,root) %{_libdir}/libKDevPlatformTests.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformTests.so.??
206 %attr(755,root,root) %{_libdir}/libKDevPlatformUtil.so.*.*.*
207 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformUtil.so.??
208 %attr(755,root,root) %{_libdir}/libKDevPlatformVcs.so.*.*.*
209 %attr(755,root,root) %ghost %{_libdir}/libKDevPlatformVcs.so.??
210 %dir %{_libdir}/qt5/plugins/grantlee
211 %dir %{_libdir}/qt5/plugins/grantlee/*
212 %attr(755,root,root) %{_libdir}/qt5/plugins/grantlee/*/kdev_filters.so
213 %dir %{_libdir}/qt5/plugins/kdevplatform
214 %dir %{_libdir}/qt5/plugins/kdevplatform/*
215 %dir %{_libdir}/qt5/qml/org/kde/kdevplatform
216 %{_libdir}/qt5/qml/org/kde/kdevplatform/qmldir
217 %attr(755,root,root) %{_libdir}/qt5/qml/org/kde/kdevplatform/libkdevelopdashboarddeclarativeplugin.so
218 %{_datadir}/kdevcodegen
219 %{_datadir}/kdevcodeutils
220 %{_datadir}/kservicetypes5/kdevelopplugin.desktop
221 %{_iconsdir}/hicolor/*/actions/*.svg
222 %{_iconsdir}/hicolor/*/apps/*.svg
223
224
225 %files devel
226 %defattr(644,root,root,755)
227 %{_libdir}/cmake/KDevelop
228 %{_includedir}/kdevelop
229
230 #kdevplatform
231 %{_includedir}/kdevplatform
232 %{_libdir}/libKDevPlatformDebugger.so
233 %{_libdir}/libKDevPlatformDocumentation.so
234 %{_libdir}/libKDevPlatformInterfaces.so
235 %{_libdir}/libKDevPlatformLanguage.so
236 %{_libdir}/libKDevPlatformOutputView.so
237 %{_libdir}/libKDevPlatformProject.so
238 %{_libdir}/libKDevPlatformSerialization.so
239 %{_libdir}/libKDevPlatformShell.so
240 %{_libdir}/libKDevPlatformSublime.so
241 %{_libdir}/libKDevPlatformTests.so
242 %{_libdir}/libKDevPlatformUtil.so
243 %{_libdir}/libKDevPlatformVcs.so
244 %dir %{_libdir}/cmake/KDevPlatform
245 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfig.cmake
246 %{_libdir}/cmake/KDevPlatform/KDevPlatformConfigVersion.cmake
247 %{_libdir}/cmake/KDevPlatform/KDevPlatformMacros.cmake
248 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets.cmake
249 %{_libdir}/cmake/KDevPlatform/KDevPlatformTargets-pld.cmake
This page took 0.09551 seconds and 4 git commands to generate.