]> git.pld-linux.org Git - packages/ka5-kalarm.git/blob - ka5-kalarm.spec
- updated to 22.04.0
[packages/ka5-kalarm.git] / ka5-kalarm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %define         kdeappsver      22.04.0
5 %define         kframever       5.56.0
6 %define         qtver           5.9.0
7 %define         kaname          kalarm
8 Summary:        kalarm
9 Name:           ka5-%{kaname}
10 Version:        22.04.0
11 Release:        1
12 License:        GPL v2+/LGPL v2.1+
13 Group:          X11/Applications
14 Source0:        http://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
15 # Source0-md5:  d352525016bb3b7bef3b7f567a5f4ef0
16 URL:            http://www.kde.org/
17 BuildRequires:  Qt5Core-devel >= %{qtver}
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  ka5-akonadi-devel >= 18.04.0
20 BuildRequires:  ka5-kimap-devel >= %{kdeappsver}
21 BuildRequires:  ka5-mailcommon-devel >= %{kdeappsver}
22 BuildRequires:  kf5-extra-cmake-modules >= %{kframever}
23 BuildRequires:  kf5-kauth-devel >= %{kframever}
24 BuildRequires:  kf5-kcmutils-devel >= %{kframever}
25 BuildRequires:  kf5-kcodecs-devel >= %{kframever}
26 BuildRequires:  kf5-kcompletion-devel >= %{kframever}
27 BuildRequires:  kf5-kconfigwidgets-devel >= %{kframever}
28 BuildRequires:  kf5-kdbusaddons-devel >= %{kframever}
29 BuildRequires:  kf5-kdelibs4support-devel >= %{kframever}
30 BuildRequires:  kf5-kholidays-devel >= %{kframever}
31 BuildRequires:  kf5-kiconthemes-devel >= %{kframever}
32 BuildRequires:  kf5-kjobwidgets-devel >= %{kframever}
33 BuildRequires:  ninja
34 BuildRequires:  qt5-build >= %{qtver}
35 BuildRequires:  rpmbuild(macros) >= 1.164
36 BuildRequires:  shared-mime-info
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 KAlarm is a personal alarm message, command and email scheduler.
43
44 Features
45
46 • Display alarms using your own text message, the text generated by
47 a command, or a text or image file. • Audible alarm using a sound
48 file • Recurring alarm on an hours/minutes, daily, weekly, monthly
49 or annual basis, or set it to trigger every time you log in. •
50 Display alarms color and font customization • Support for multiple
51 alarm calendars, which for example enables you to share alarms between
52 a laptop and desktop computer.
53
54 %description -l pl.UTF-8
55 KAlarm jest osobistym budzikiem i harmonogramem.
56
57 Własciwości
58
59 • Wyświetla własne wiadomości tekstowe, lub tekst wygenerowany
60 przez program, lub wyświetla plik tekstowy bądź obrazek •
61 Dźwiękowe powiadomomienia • Powtarzalne alarmy, o określonej
62 godzinie/minucie, dzienne, tygodniowe, miesięczne lub roczne a także
63 wyzwalane wtedy gdy się zalogujesz • Możliwość konfiguracji
64 koloru i rodzaju czcionki • Wsparcie dla wielu kalendarzy
65 powiadomień, co pozwala na przykład współdzielić alarmy między
66 laptopem a komputerem stacjonarnym
67
68 %prep
69 %setup -q -n %{kaname}-%{version}
70
71 %build
72 install -d build
73 cd build
74 %cmake \
75         -G Ninja \
76         %{!?with_tests:-DBUILD_TESTING=OFF} \
77         -DHTML_INSTALL_DIR=%{_kdedocdir} \
78         -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
79         ..
80 %ninja_build
81
82 %if %{with tests}
83 ctest
84 %endif
85
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 %ninja_install -C build
90
91 %find_lang %{kaname} --all-name --with-kde
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files -f %{kaname}.lang
100 %defattr(644,root,root,755)
101 /etc/xdg/autostart/kalarm.autostart.desktop
102 %attr(755,root,root) %{_bindir}/kalarm
103 %attr(755,root,root) %{_bindir}/kalarmautostart
104 %{_prefix}/libexec/kauth/kalarm_helper
105 %{_desktopdir}/org.kde.kalarm.desktop
106 %{_datadir}/config.kcfg/kalarmconfig.kcfg
107 %{_datadir}/dbus-1/interfaces/org.kde.kalarm.kalarm.xml
108 %{_iconsdir}/hicolor/128x128/apps/kalarm.png
109 %{_iconsdir}/hicolor/16x16/apps/kalarm.png
110 %{_iconsdir}/hicolor/22x22/apps/kalarm.png
111 %{_iconsdir}/hicolor/32x32/apps/kalarm.png
112 %{_iconsdir}/hicolor/48x48/apps/kalarm.png
113 %{_iconsdir}/hicolor/64x64/apps/kalarm.png
114 %{_datadir}/kalarm
115 %dir %{_datadir}/kxmlgui5/kalarm
116 %{_datadir}/kxmlgui5/kalarm/kalarmui.rc
117 %{_datadir}/metainfo/org.kde.kalarm.appdata.xml
118 %{_datadir}/polkit-1/actions/org.kde.kalarm.rtcwake.policy
119 %{_datadir}/dbus-1/system-services/org.kde.kalarm.rtcwake.service
120 %{_datadir}/dbus-1/system.d/org.kde.kalarm.rtcwake.conf
121 %{_datadir}/qlogging-categories5/kalarm.categories
122 %{_datadir}/qlogging-categories5/kalarm.renamecategories
123 %{_datadir}/knotifications5/kalarm.notifyrc
124 %ghost %{_libdir}/libkalarmprivate.so.5
125 %attr(755,root,root) %{_libdir}/libkalarmprivate.so.*.*.*
This page took 0.052923 seconds and 4 git commands to generate.