]> git.pld-linux.org Git - packages/json-c.git/blob - json-c.spec
f617ce1200c996371dffe3191c1440fa04c64bb8
[packages/json-c.git] / json-c.spec
1 Summary:        A JSON implementation in C
2 Summary(pl.UTF-8):      Implementacja JSON w C
3 Name:           json-c
4 Version:        0.9
5 Release:        2
6 License:        MIT
7 Group:          Development/Libraries
8 Source0:        http://oss.metaparadigm.com/json-c/%{name}-%{version}.tar.gz
9 # Source0-md5:  3a13d264528dcbaf3931b0cede24abae
10 URL:            http://oss.metaparadigm.com/json-c/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 JSON-C implements a reference counting object model that allows you to
15 easily construct JSON objects in C, output them as JSON formatted
16 strings and parse JSON formatted strings back into the C
17 representation of JSON objects.
18
19 %description -l pl.UTF-8
20 JSON-C implementuje model obiektów ze zliczaniem odwołań, pozwalający
21 łatwo konstruować obiekty JSON w C, wypisywać je w postaci łańcuchów w
22 formacie JSON i analizować łańcuchy w formacie JSON tworząc z powrotem
23 reprezentacje obiektów JSON w C.
24
25 %package devel
26 Summary:        Header files for the json-c library
27 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki json-c
28 Group:          Development/Libraries
29 Requires:       %{name} = %{version}-%{release}
30
31 %description devel
32 Header files for the json-c library.
33
34 %description devel -l pl.UTF-8
35 Pliki nagłówkowe biblioteki json-c.
36
37 %package static
38 Summary:        Static json-c library
39 Summary(pl.UTF-8):      Statyczna biblioteka json-c
40 Group:          Development/Libraries
41 Requires:       %{name}-devel = %{version}-%{release}
42
43 %description static
44 Static json-c library.
45
46 %description static -l pl.UTF-8
47 Statyczna biblioteka json-c.
48
49 %prep
50 %setup -q
51
52 %build
53 %configure
54 %{__make}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %post   -p /sbin/ldconfig
66 %postun -p /sbin/ldconfig
67
68 %files
69 %defattr(644,root,root,755)
70 %doc AUTHORS COPYING ChangeLog README README.html
71 %attr(755,root,root) %{_libdir}/libjson.so.*.*.*
72 %attr(755,root,root) %ghost %{_libdir}/libjson.so.0
73
74 %files devel
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_libdir}/libjson.so
77 %{_libdir}/libjson.la
78 %{_includedir}/json
79 %{_pkgconfigdir}/json.pc
80
81 %files static
82 %defattr(644,root,root,755)
83 %{_libdir}/libjson.a
This page took 0.055928 seconds and 3 git commands to generate.