]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- new %%doc
[packages/john.git] / john.spec
1 #
2 # Conditional build:
3 # _with_mmx     - MMX optimization
4 # Optimization must be chosen at compile time :(
5 # Maybe some patch...? But not yet.
6 #
7 Summary:        Password cracker
8 Summary(pl):    £amacz hase³
9 Name:           john
10 Version:        1.6
11 Release:        6
12 License:        GPL
13 Group:          Applications/System
14 Source0:        http://www.openwall.com/john/%{name}-%{version}.tar.gz
15 Patch0:         %{name}-%{version}.PLD.diff
16 Patch1:         %{name}-%{version}.ini.diff
17 Patch2:         %{name}-%{version}.makefile.diff
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 John the Ripper is a password cracker, currently available for UNIX,
22 DOS, WinNT/Win95. Its primary purpose is to detect weak UNIX
23 passwords. It has been tested with Linux x86/Alpha/SPARC, FreeBSD x86,
24 OpenBSD x86, Solaris 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and
25 IRIX.
26
27 %description -l pl
28 John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX,
29 DOS, WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych"
30 hase³. By³ testowany z Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86,
31 Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36 %patch1 -p1
37 %patch2 -p1
38
39 %build
40 cd src
41 COPT="%{rpmcflags}"
42
43 # bleh... MMX code must be chosen at compile time :(
44 # cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
45 # K6 optimization exists only in Makefile
46 %ifarch %{ix86}
47         %if %{?_with_mmx:1}%{!?_with_mmx:0}
48                 TARG=linux-x86-mmx-elf
49         %else
50                 TARG=linux-x86-any-elf
51         %endif
52 %else
53         %ifarch alpha
54                 TARG=linux-alpha
55         %else
56                 %ifarch sparc sparc64
57                         TARG=linux-sparc
58                 %else
59                         TARG=generic
60                 %endif
61         %endif
62 %endif
63
64 %{__make} OPT="$COPT" CC="%{__cc}" $TARG
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/john}
69 install run/{*.chr,john.ini} $RPM_BUILD_ROOT%{_libdir}/john
70 install run/john $RPM_BUILD_ROOT%{_bindir}
71 rm -f doc/INSTALL
72
73 cd $RPM_BUILD_ROOT%{_bindir}
74 ln -sf john unafs
75 ln -sf john unique
76 ln -sf john unshadow
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc doc/* run/mailer
84 %attr(755,root,root) %{_bindir}/*
85 %{_libdir}/john
This page took 0.083285 seconds and 4 git commands to generate.