]> git.pld-linux.org Git - packages/john.git/blob - john.spec
- fixed usage of macros
[packages/john.git] / john.spec
1 Summary:        Password cracker
2 Summary(pl):    £amacz hase³
3 Name:           john
4 Version:        1.6
5 Release:        4
6 Copyright:      GPL
7 Group:          Utilities/System
8 Group(pl):      Narzêdzia/System
9 URL:            http://www.false.com/security/john/
10 Source:         %{name}-%{version}.tar.gz
11 Patch0:         %{name}-%{version}.PLD.diff
12 Patch1:         %{name}-%{version}.ini.diff
13 Patch2:         %{name}-%{version}.makefile.diff
14 Buildroot:      /tmp/%{name}-%{version}-root
15
16 %description
17 John the Ripper is a password cracker, currently available for UNIX, DOS,
18 WinNT/Win95. Its primary purpose is to detect weak UNIX passwords. It has
19 been tested with Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86, Solaris
20 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and IRIX.
21   
22 %description -l pl
23 John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX, DOS,
24 WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych" hase³.
25   
26 %prep
27 %setup -q
28 %patch0 -p1
29 %patch1 -p1
30 %patch2 -p1
31
32 %build
33 cd src
34 # Hmm. I don't know what is in /proc/cpuinfo on other processors than Intel MMX
35 if grep -q "MMX" /proc/cpuinfo; then
36         make OPT="$RPM_OPT_FLAGS" linux-x86-mmx-elf
37 elif grep -q "K6" /proc/cpuinfo; then
38         make OPT="$RPM_OPT_FLAGS" linux-x86-k6-elf
39 elif grep -q "Alpha" /proc/cpuinfo; then
40         make OPT="$RPM_OPT_FLAGS" linux-alpha
41 elif grep -q "SPARC" /proc/cpuinfo; then
42         make OPT="$RPM_OPT_FLAGS" linux-sparc
43 else
44         make OPT="$RPM_OPT_FLAGS" linux-x86-any-elf
45 fi
46         
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/john}
50 install run/*.chr $RPM_BUILD_ROOT%{_libdir}/john
51 install run/john.ini $RPM_BUILD_ROOT%{_libdir}/john
52 install run/john $RPM_BUILD_ROOT%{_bindir}
53
54 gzip -9nf doc/* run/mailer
55
56 cd $RPM_BUILD_ROOT%{_bindir}
57 ln -s john unafs; ln -s john unique; ln -s john unshadow
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc doc/* run/mailer.gz
65 %attr(755,root,root) %{_bindir}/*
66
67 %dir %{_libdir}/john
68 %{_libdir}/john/*
This page took 0.069201 seconds and 4 git commands to generate.