]> git.pld-linux.org Git - packages/jack-audio-connection-kit.git/blob - jack-audio-connection-kit.spec
- there is one shared library
[packages/jack-audio-connection-kit.git] / jack-audio-connection-kit.spec
1 #
2 # Conditional build:
3 %bcond_without  cap             # don't use capabilities to get real-time priority (needs suid root binary)
4 %bcond_without  alsa            # don't build ALSA driver
5 %bcond_without  posix_shm       # don't use posix shm
6 %bcond_without  static_libs     # don't build static libs
7 #
8 Summary:        The JACK Audio Connection Kit
9 Summary(pl):    JACK - zestaw do po³±czeñ audio
10 Name:           jack-audio-connection-kit
11 Version:        0.100.0
12 Release:        1
13 License:        LGPL v2.1+ (libjack), GPL v2+ (the rest)
14 Group:          Daemons
15 Source0:        http://dl.sourceforge.net/jackit/%{name}-%{version}.tar.gz
16 # Source0-md5:  dc28b3e8a663c090227e83be6fc1f2d4
17 Patch0:         %{name}-optimized-cflags.patch
18 URL:            http://jackit.sourceforge.net/
19 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  doxygen
23 %{?with_cap:BuildRequires:      libcap-devel}
24 BuildRequires:  libsndfile-devel >= 1.0.0
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  readline-devel
28 Obsoletes:      jack-audio-connection-kit-driver-iec61883
29 Requires:       %{name}-libs = %{version}-%{release}
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 JACK is a low-latency audio server, written primarily for the Linux
34 operating system. It can connect a number of different applications to
35 an audio device, as well as allowing them to share audio between
36 themselves. Its clients can run in their own processes (ie. as a
37 normal application), or can they can run within a JACK server (ie. a
38 "plugin").
39
40 JACK is different from other audio server efforts in that it has been
41 designed from the ground up to be suitable for professional audio
42 work. This means that it focuses on two key areas: synchronous
43 execution of all clients, and low latency operation.
44
45 %description -l pl
46 JACK to serwer d¼wiêku o ma³ych opó¼nieniach, napisany g³ównie dla
47 systemu operacyjnego Linux. Mo¿e przyj±æ po³±czenia od wielu ró¿nych
48 aplikacji do urz±dzenia d¼wiêkowego, a tak¿e pozwoliæ im na dzielenie
49 d¼wiêku pomiêdzy siebie. Programy klienckie dzia³aj± jako w³asne
50 procesy (tzn. normalne aplikacje) lub mog± dzia³aæ wewn±trz serwera
51 JACK (jako wtyczki).
52
53 JACK ró¿ni siê od innych serwerów d¼wiêku tym, ¿e zosta³
54 zaprojektowany od pocz±tku z my¶l± o profesjonalnej obróbce d¼wiêku.
55 Oznacza to, ¿e skupia siê na dwóch rzeczach: synchronicznym
56 wykonywaniu wszystkich klientów i ma³ych opó¼nieniach dzia³ania.
57
58 %package devel
59 Summary:        Header files for JACK
60 Summary(pl):    JACK - pliki nag³ówkowe
61 License:        LGPL
62 Group:          Development/Libraries
63 Requires:       %{name}-libs = %{version}-%{release}
64
65 %description devel
66 Header files for the JACK Audio Connection Kit.
67
68 %description devel -l pl
69 Pliki nag³ówkowe dla zestawu do po³±czeñ audio JACK.
70
71 %package static
72 Summary:        Static JACK library
73 Summary(pl):    Statyczna biblioteka JACK
74 License:        LGPL
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static JACK library.
80
81 %description static -l pl
82 Statyczna biblioteka JACK.
83
84 %package libs
85 Summary:        JACK library
86 Summary(pl):    Biblioteka JACK-a
87 License:        GPL
88 Group:          Libraries
89
90 %description libs
91 Shared JACK library.
92
93 %description libs -l pl
94 Biblioteka wspó³dzielona JACK-a.
95
96 %package driver-alsa
97 Summary:        ALSA driver for JACK
98 Summary(pl):    Sterownik ALSA dla JACK-a
99 License:        GPL
100 Group:          Libraries
101 Requires:       %{name} = %{version}-%{release}
102
103 %description driver-alsa
104 ALSA driver for JACK.
105
106 %description driver-alsa -l pl
107 Sterownik ALSA dla JACK-a.
108
109 %package example-clients
110 Summary:        Example clients that use JACK
111 Summary(pl):    Przyk³adowe programy kliencie u¿ywaj±ce JACK-a
112 License:        GPL
113 Group:          Applications/Sound
114 Requires:       %{name} = %{version}-%{release}
115
116 %description example-clients
117 Small example clients that use the JACK Audio Connection Kit.
118
119 %description example-clients -l pl
120 Ma³e, przyk³adowe programy klienckie, które u¿ywaj± zestawu do
121 po³±czeñ audio JACK.
122
123 %package example-jackrec
124 Summary:        Example JACK client: jackrec
125 Summary(pl):    Przyk³adowy klient zestawu JACK: jackrec
126 License:        GPL
127 Group:          Applications/Sound
128 Requires:       %{name} = %{version}-%{release}
129
130 %description example-jackrec
131 Example JACK client: jackrec. It's separated because it uses
132 libsndfile library.
133
134 %description example-jackrec
135 Przyk³adowy klient zestawu JACK: jackrec. Jest wydzielony, poniewa¿
136 wymaga biblioteki libsndfile.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141
142 %build
143 cp -f /usr/share/automake/config.sub config
144 %{__libtoolize}
145 %{__aclocal} -I config
146 %{__autoheader}
147 %{__automake}
148 %{__autoconf}
149
150 %configure \
151         %{?debug:--enable-debug} \
152         --disable-coreaudio \
153         --disable-oldtrans \
154         --disable-portaudio \
155         --enable-optimize \
156         --enable-oss \
157         %{!?with_alsa:--disable-alsa} \
158         %{?with_cap:--enable-capabilities %{!?debug:--enable-stripped-jackd}} \
159         --%{?with_posix_shm:en}%{!?with_posix_shm:dis}able-posix-shm \
160         %{?with_static_libs:--enable-static} \
161 %ifarch athlon pentium3 pentium4 amd64
162         --enable-mmx \
163 %else
164         --disable-mmx \
165 %endif
166 %ifarch pentium3 pentium4 amd64
167         --enable-sse \
168 %else
169         --disable-sse \
170 %endif
171 %ifarch ppc
172         --enable-altivec \
173 %else
174         --disable-altivec \
175 %endif
176         --enable-shared \
177         --enable-static \
178         --enable-resize \
179         --enable-ensure-mlock \
180         --enable-timestamps \
181         --enable-preemption-check \
182         --with-html-dir=%{_gtkdocdir} \
183         --with-default-tmpdir=/tmp
184
185 %{__make}
186
187 %install
188 rm -rf $RPM_BUILD_ROOT
189
190 %{__make} install \
191         DESTDIR=$RPM_BUILD_ROOT \
192         HTML_DIR=%{_gtkdocdir}
193
194 rm -f $RPM_BUILD_ROOT%{_libdir}/jack/*.{la,a}
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %post   libs -p /sbin/ldconfig
200 %postun libs -p /sbin/ldconfig
201
202 %files
203 %defattr(644,root,root,755)
204 # note: COPYING only specifies which parts fall under GPL and LGPL
205 %doc AUTHORS TODO COPYING
206 %{?with_cap:%attr(4755,root,root) %{_bindir}/jackstart}
207 %attr(755,root,root) %{_bindir}/jackd
208 %attr(755,root,root) %{_bindir}/jack_load
209 %attr(755,root,root) %{_bindir}/jack_unload
210 %dir %{_libdir}/jack
211 %attr(755,root,root) %{_libdir}/jack/jack_dummy.so
212 %attr(755,root,root) %{_libdir}/jack/jack_oss.so
213 %{_mandir}/man1/*
214
215 %files devel
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libjack.so
218 %{_libdir}/libjack.la
219 %{_includedir}/jack
220 %{_pkgconfigdir}/jack.pc
221 %{_gtkdocdir}/*
222
223 %if %{with static_libs}
224 %files static
225 %defattr(644,root,root,755)
226 %{_libdir}/libjack.a
227 %endif
228
229 %files libs
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/libjack.so.*.*
232
233 %if %{with alsa}
234 %files driver-alsa
235 %defattr(644,root,root,755)
236 %attr(755,root,root) %{_libdir}/jack/jack_alsa.so
237 %endif
238
239 %files example-clients
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_bindir}/jack_bufsize
242 %attr(755,root,root) %{_bindir}/jack_connect
243 %attr(755,root,root) %{_bindir}/jack_disconnect
244 %attr(755,root,root) %{_bindir}/jack_freewheel
245 %attr(755,root,root) %{_bindir}/jack_impulse_grabber
246 %attr(755,root,root) %{_bindir}/jack_lsp
247 %attr(755,root,root) %{_bindir}/jack_metro
248 %attr(755,root,root) %{_bindir}/jack_monitor_client
249 %attr(755,root,root) %{_bindir}/jack_showtime
250 %attr(755,root,root) %{_bindir}/jack_simple_client
251 %attr(755,root,root) %{_bindir}/jack_transport
252 %attr(755,root,root) %{_libdir}/jack/inprocess.so
253 %attr(755,root,root) %{_libdir}/jack/intime.so
254
255 %files example-jackrec
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_bindir}/jackrec
This page took 0.049619 seconds and 3 git commands to generate.