]> git.pld-linux.org Git - packages/jack-audio-connection-kit.git/blob - jack-audio-connection-kit.spec
- added link patch to avoid linking libjack with -lreadline; release 4
[packages/jack-audio-connection-kit.git] / jack-audio-connection-kit.spec
1 #
2 # Conditional build:
3 %bcond_with     cap             # use capabilities to get real-time priority (needs suid root binary)
4 %bcond_without  alsa            # don't build ALSA driver
5 %bcond_without  iec61883        # don't build IEC61883 (FireWire) driver
6 %bcond_without  static_libs     # don't build static libs
7 #
8 Summary:        The JACK Audio Connection Kit
9 Summary(pl):    JACK - zestaw do po³±czeñ audio
10 Name:           jack-audio-connection-kit
11 Version:        0.98.1
12 Release:        4
13 License:        LGPL (libjack), GPL (the rest)
14 Group:          Daemons
15 Source0:        http://dl.sourceforge.net/jackit/%{name}-%{version}.tar.gz
16 # Source0-md5:  6ebd659a431e75b841fa5e0c397372ee
17 Patch0:         %{name}-link.patch
18 URL:            http://jackit.sourceforge.net/
19 %{?with_alsa:BuildRequires:     alsa-lib-devel >= 0.9.0}
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  doxygen
23 %{?with_cap:BuildRequires:      libcap-devel}
24 %{?with_iec61883:BuildRequires: libraw1394-devel >= 0.10}
25 BuildRequires:  libsndfile-devel >= 1.0.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  readline-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 JACK is a low-latency audio server, written primarily for the Linux
32 operating system. It can connect a number of different applications to
33 an audio device, as well as allowing them to share audio between
34 themselves. Its clients can run in their own processes (ie. as a
35 normal application), or can they can run within a JACK server (ie. a
36 "plugin").
37
38 JACK is different from other audio server efforts in that it has been
39 designed from the ground up to be suitable for professional audio
40 work. This means that it focuses on two key areas: synchronous
41 execution of all clients, and low latency operation.
42
43 %description -l pl
44 JACK to serwer d¼wiêku o ma³ych opó¼nieniach, napisany g³ównie dla
45 systemu operacyjnego Linux. Mo¿e przyj±æ po³±czenia od wielu ró¿nych
46 aplikacji do urz±dzenia d¼wiêkowego, a tak¿e pozwoliæ im na dzielenie
47 d¼wiêku pomiêdzy siebie. Programy klienckie dzia³aj± jako w³asne
48 procesy (tzn. normalne aplikacje) lub mog± dzia³aæ wewn±trz serwera
49 JACK (jako wtyczki).
50
51 JACK ró¿ni siê od innych serwerów d¼wiêku tym, ¿e zosta³
52 zaprojektowany od pocz±tku z my¶l± o profesjonalnej obróbce d¼wiêku.
53 Oznacza to, ¿e skupia siê na dwóch rzeczach: synchronicznym
54 wykonywaniu wszystkich klientów i ma³ych opó¼nieniach dzia³ania.
55
56 %package devel
57 Summary:        Header files for JACK
58 Summary(pl):    JACK - pliki nag³ówkowe
59 License:        LGPL
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Header files for the JACK Audio Connection Kit.
65
66 %description devel -l pl
67 Pliki nag³ówkowe dla zestawu do po³±czeñ audio JACK.
68
69 %package static
70 Summary:        Static JACK library
71 Summary(pl):    Statyczna biblioteka JACK
72 License:        LGPL
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static JACK library.
78
79 %description static -l pl
80 Statyczna biblioteka JACK.
81
82 %package driver-alsa
83 Summary:        ALSA driver for JACK
84 Summary(pl):    Sterownik ALSA dla JACKa
85 License:        GPL
86 Group:          Libraries
87 Requires:       %{name} = %{version}-%{release}
88
89 %description driver-alsa
90 ALSA driver for JACK.
91
92 %description driver-alsa -l pl
93 Sterownik ALSA dla JACKa.
94
95 %package driver-iec61883
96 Summary:        IEC61883 (FireWire audio) driver for JACK
97 Summary(pl):    Sterownik IEC61883 (FireWire audio) dla JACKa
98 License:        GPL
99 Group:          Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       libraw1394 >= 0.10
102
103 %description driver-iec61883
104 IEC61883 (FireWire audio) driver for JACK.
105
106 %description driver-iec61883 -l pl
107 Sterownik IEC61883 (FireWire audio) dla JACKa.
108
109 %package example-clients
110 Summary:        Example clients that use JACK
111 Summary(pl):    Przyk³adowe programy kliencie u¿ywaj±ce JACKa
112 License:        GPL
113 Group:          Applications/Sound
114 Requires:       %{name} = %{version}-%{release}
115
116 %description example-clients
117 Small example clients that use the JACK Audio Connection Kit.
118
119 %description example-clients -l pl
120 Ma³e, przyk³adowe programy klienckie, które u¿ywaj± zestawu do
121 po³±czeñ audio JACK.
122
123 %package example-jackrec
124 Summary:        Example JACK client: jackrec
125 Summary(pl):    Przyk³adowy klient zestawu JACK: jackrec
126 License:        GPL
127 Group:          Applications/Sound
128 Requires:       %{name} = %{version}-%{release}
129
130 %description example-jackrec
131 Example JACK client: jackrec. It's separated because it uses
132 libsndfile library.
133
134 %description example-jackrec
135 Przyk³adowy klient zestawu JACK: jackrec. Jest wydzielony, poniewa¿
136 wymaga biblioteki libsndfile.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141
142 %build
143 cp -f /usr/share/automake/config.sub config
144 %{__autoconf}
145 # --enable-optimize is heavy broken, it uses information from /proc/cpuinfo to set compilator flags
146 %configure \
147         %{!?with_alsa:--disable-alsa} \
148         %{?with_cap:--enable-capabilities %{!?debug:--enable-stripped-jackd}} \
149         %{?debug:--enable-debug} \
150         %{?with_iec61883:--enable-iec61883} \
151         --disable-optimize \
152         --enable-posix-shm \
153         %{?with_static_libs:--enable-static} \
154         --with-html-dir=%{_gtkdocdir}
155
156 %{__make}
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT \
163         HTML_DIR=%{_gtkdocdir}
164
165 rm -f $RPM_BUILD_ROOT%{_libdir}/jack/*.{la,a}
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   -p /sbin/ldconfig
171 %postun -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 # note: COPYING only specifies which parts fall under GPL and LGPL
176 %doc AUTHORS TODO COPYING
177 %{?_with_cap:%attr(4755,root,root) %{_bindir}/jackstart}
178 %attr(755,root,root) %{_bindir}/jackd
179 %attr(755,root,root) %{_bindir}/jack_load
180 %attr(755,root,root) %{_bindir}/jack_unload
181 %attr(755,root,root) %{_libdir}/libjack.so.*.*
182 %dir %{_libdir}/jack
183 %attr(755,root,root) %{_libdir}/jack/jack_dummy.so
184 %attr(755,root,root) %{_libdir}/jack/jack_oss.so
185 %{_mandir}/man1/*
186
187 %files devel
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_libdir}/libjack.so
190 %{_libdir}/libjack.la
191 %{_includedir}/jack
192 %{_pkgconfigdir}/jack.pc
193 %{_gtkdocdir}/*
194
195 %if %{with static_libs}
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libjack.a
199 %endif
200
201 %if %{with alsa}
202 %files driver-alsa
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/jack/jack_alsa.so
205 %endif
206
207 %if %{with iec61883}
208 %files driver-iec61883
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/jack/jack_iec61883.so
211 %endif
212
213 %files example-clients
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/jack_bufsize
216 %attr(755,root,root) %{_bindir}/jack_connect
217 %attr(755,root,root) %{_bindir}/jack_disconnect
218 %attr(755,root,root) %{_bindir}/jack_freewheel
219 %attr(755,root,root) %{_bindir}/jack_impulse_grabber
220 %attr(755,root,root) %{_bindir}/jack_lsp
221 %attr(755,root,root) %{_bindir}/jack_metro
222 %attr(755,root,root) %{_bindir}/jack_monitor_client
223 %attr(755,root,root) %{_bindir}/jack_showtime
224 %attr(755,root,root) %{_bindir}/jack_simple_client
225 %attr(755,root,root) %{_bindir}/jack_transport
226 %attr(755,root,root) %{_libdir}/jack/inprocess.so
227 %attr(755,root,root) %{_libdir}/jack/intime.so
228
229 %files example-jackrec
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/jackrec
This page took 0.075493 seconds and 3 git commands to generate.