]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
- updated to 0.3.0
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.3.0
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://kohei.us/files/ixion/src/libixion_%{version}.tar.bz2
13 # Source0-md5:  96a36a0016f968a5a7c4b167eeb1643b
14 Patch0:         %{name}-am.patch
15 URL:            http://gitorious.org/ixion/pages/Home
16 BuildRequires:  autoconf >= 2.63
17 BuildRequires:  automake
18 BuildRequires:  boost-devel >= 1.36
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Ixion aims to provide a library for calculating the results of formula
25 expressions stored in multiple named targets, or "cells". The cells
26 can be referenced from each other, and the library takes care of
27 resolving their dependencies automatically upon calculation. The
28 caller can run the calculation routine either in a single-threaded
29 mode, or a multi-threaded mode. The library also supports
30 re-calculation where the contents of one or more cells have been
31 modified since the last calculation, and a partial calculation of only
32 the affected cells gets performed. It is written entirely in C++, and
33 makes extensive use of the boost library to achieve portability across
34 different platforms.
35
36 %description -l pl.UTF-8
37 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
38 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
39 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
40 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
41 obliczeniach. Procedura obliczająca może być wywołana w trybie
42 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
43 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
44 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
45 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
46 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
47 przenośność na wiele platform.
48
49 %package devel
50 Summary:        Development files for ixion
51 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       boost-devel >= 1.36
55 Requires:       libstdc++-devel
56
57 %description devel
58 This package contains the header files for developing applications
59 that use ixion.
60
61 %description devel -l pl.UTF-8
62 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
63 ixion.
64
65 %package static
66 Summary:        Static ixion library
67 Summary(pl.UTF-8):      Statyczna biblioteka ixion
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static ixion library.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka ixion.
76
77 %prep
78 %setup -q -n libixion_%{version}
79 %patch0 -p1
80
81 %build
82 %{__libtoolize}
83 %{__aclocal} -I m4
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         boost_cv_lib_thread=yes \
88         boost_cv_lib_thread_LIBS="-lboost_thread -lboost_system" \
89         %{!?with_static_libs:--disable-static}
90
91 %{__make}
92
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS COPYING README
111 %attr(755,root,root) %{_bindir}/ixion-parser
112 %attr(755,root,root) %{_bindir}/ixion-sorter
113 %attr(755,root,root) %{_libdir}/libixion-0.4.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libixion-0.4.so.0
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libixion-0.4.so
119 %{_includedir}/libixion-0.4
120 %{_pkgconfigdir}/libixion-0.4.pc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libixion-0.4.a
126 %endif
This page took 0.063178 seconds and 4 git commands to generate.