]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
- - rebuild with boost 1.55.0
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.5.0
9 Release:        4
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: http://gitorious.org/ixion/pages/Download
13 Source0:        http://kohei.us/files/ixion/src/libixion-%{version}.tar.bz2
14 # Source0-md5:  ebaeab9ffe1e6bd68b2a20bfa430b3af
15 Patch0:         %{name}-am.patch
16 URL:            http://gitorious.org/ixion/pages/Home
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:1.5
22 BuildRequires:  mdds-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Ixion aims to provide a library for calculating the results of formula
27 expressions stored in multiple named targets, or "cells". The cells
28 can be referenced from each other, and the library takes care of
29 resolving their dependencies automatically upon calculation. The
30 caller can run the calculation routine either in a single-threaded
31 mode, or a multi-threaded mode. The library also supports
32 re-calculation where the contents of one or more cells have been
33 modified since the last calculation, and a partial calculation of only
34 the affected cells gets performed. It is written entirely in C++, and
35 makes extensive use of the boost library to achieve portability across
36 different platforms.
37
38 %description -l pl.UTF-8
39 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
40 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
41 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
42 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
43 obliczeniach. Procedura obliczająca może być wywołana w trybie
44 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
45 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
46 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
47 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
48 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
49 przenośność na wiele platform.
50
51 %package devel
52 Summary:        Development files for ixion
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       boost-devel >= 1.36
57 Requires:       libstdc++-devel
58 Requires:       mdds-devel
59
60 %description devel
61 This package contains the header files for developing applications
62 that use ixion.
63
64 %description devel -l pl.UTF-8
65 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
66 ixion.
67
68 %package static
69 Summary:        Static ixion library
70 Summary(pl.UTF-8):      Statyczna biblioteka ixion
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static ixion library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka ixion.
79
80 %prep
81 %setup -q -n libixion-%{version}
82 %patch0 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         boost_cv_lib_thread=yes \
91         boost_cv_lib_thread_LIBS="-lboost_thread -lboost_system" \
92         %{!?with_static_libs:--disable-static}
93
94 %{__make}
95
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # obsoleted by pkg-config
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS COPYING README
114 %attr(755,root,root) %{_bindir}/ixion-parser
115 %attr(755,root,root) %{_bindir}/ixion-sorter
116 %attr(755,root,root) %{_libdir}/libixion-0.6.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libixion-0.6.so.0
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libixion-0.6.so
122 %{_includedir}/libixion-0.6
123 %{_pkgconfigdir}/libixion-0.6.pc
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libixion-0.6.a
129 %endif
This page took 0.052178 seconds and 3 git commands to generate.