]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
af67e00fc5b9426b983416b352705ffd63b4a6a4
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.11.1
9 Release:        1
10 License:        MPL v2.0
11 Group:          Libraries
12 #Source0Download: https://gitlab.com/ixion/ixion
13 Source0:        http://kohei.us/files/ixion/src/libixion-%{version}.tar.xz
14 # Source0-md5:  891fac2bb0d0e17382526649ed4ad9ea
15 Patch0:         %{name}-flags.patch
16 URL:            https://gitlab.com/ixion/ixion
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  mdds-devel >= 1.2.0
23 BuildRequires:  pkgconfig
24 BuildRequires:  python3 >= 1:3.2
25 BuildRequires:  python3-devel >= 1:3.2
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Ixion aims to provide a library for calculating the results of formula
32 expressions stored in multiple named targets, or "cells". The cells
33 can be referenced from each other, and the library takes care of
34 resolving their dependencies automatically upon calculation. The
35 caller can run the calculation routine either in a single-threaded
36 mode, or a multi-threaded mode. The library also supports
37 re-calculation where the contents of one or more cells have been
38 modified since the last calculation, and a partial calculation of only
39 the affected cells gets performed. It is written entirely in C++, and
40 makes extensive use of the boost library to achieve portability across
41 different platforms.
42
43 %description -l pl.UTF-8
44 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
45 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
46 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
47 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
48 obliczeniach. Procedura obliczająca może być wywołana w trybie
49 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
50 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
51 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
52 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
53 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
54 przenośność na wiele platform.
55
56 %package devel
57 Summary:        Development files for ixion
58 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       boost-devel >= 1.36
62 Requires:       libstdc++-devel
63 Requires:       mdds-devel >= 1.2.0
64
65 %description devel
66 This package contains the header files for developing applications
67 that use ixion.
68
69 %description devel -l pl.UTF-8
70 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
71 ixion.
72
73 %package static
74 Summary:        Static ixion library
75 Summary(pl.UTF-8):      Statyczna biblioteka ixion
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static ixion library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka ixion.
84
85 %package -n python3-ixion
86 Summary:        Python 3 interface to ixion library
87 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki ixion
88 Group:          Libraries/Python
89 Requires:       %{name} = %{version}-%{release}
90 # python 2 is no longer supported
91 Obsoletes:      python-ixion
92
93 %description -n python3-ixion
94 Python 3 interface to ixion library.
95
96 %description -n python3-ixion -l pl.UTF-8
97 Interfejs Pythona 3 do biblioteki ixion.
98
99 %prep
100 %setup -q -n libixion-%{version}
101 %patch0 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__automake}
108 %configure \
109         --disable-silent-rules \
110         %{?with_static_libs:--enable-static}
111
112 %{__make}
113
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.la
121 %if %{with static_libs}
122 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/ixion.a
123 %endif
124 # obsoleted by pkg-config
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS LICENSE README
136 %attr(755,root,root) %{_bindir}/ixion-parser
137 %attr(755,root,root) %{_bindir}/ixion-sorter
138 %attr(755,root,root) %{_libdir}/libixion-0.11.so.*.*.*
139 %attr(755,root,root) %ghost %{_libdir}/libixion-0.11.so.0
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libixion-0.11.so
144 %{_includedir}/libixion-0.11
145 %{_pkgconfigdir}/libixion-0.11.pc
146
147 %if %{with static_libs}
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libixion-0.11.a
151 %endif
152
153 %files -n python3-ixion
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{py3_sitedir}/ixion.so
This page took 0.087966 seconds and 3 git commands to generate.