]> git.pld-linux.org Git - packages/ixion.git/blob - ixion.spec
525fa0041df00240e05b6b499569f9425f3935d8
[packages/ixion.git] / ixion.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Generic formula compulation library
6 Summary(pl.UTF-8):      Ogólna biblioteka do obliczania wzorów
7 Name:           ixion
8 Version:        0.7.0
9 Release:        2
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: http://gitorious.org/ixion/pages/Download
13 Source0:        http://kohei.us/files/ixion/src/libixion-%{version}.tar.bz2
14 # Source0-md5:  000157117801f9507f34b26ba998c4d1
15 Patch0:         %{name}-am.patch
16 URL:            http://gitorious.org/ixion/pages/Home
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool >= 2:2
22 BuildRequires:  mdds-devel >= 0.7.1
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Ixion aims to provide a library for calculating the results of formula
27 expressions stored in multiple named targets, or "cells". The cells
28 can be referenced from each other, and the library takes care of
29 resolving their dependencies automatically upon calculation. The
30 caller can run the calculation routine either in a single-threaded
31 mode, or a multi-threaded mode. The library also supports
32 re-calculation where the contents of one or more cells have been
33 modified since the last calculation, and a partial calculation of only
34 the affected cells gets performed. It is written entirely in C++, and
35 makes extensive use of the boost library to achieve portability across
36 different platforms.
37
38 %description -l pl.UTF-8
39 Projekt Ixion ma na celu dostarczenie biblioteki do obliczania wyników
40 wyrażeń określonych wzorami zapisanymi w wielu nazwanych miejscach -
41 "komórkach". Komórki mogą odwoływać się do siebie nawzajem, a
42 biblioteka dba o automatyczne rozwiązywanie ich zależności przy
43 obliczeniach. Procedura obliczająca może być wywołana w trybie
44 jednowątkowym lub wielowątkowym. Biblioteka obsługuje także ponowne
45 przeliczanie w przypadku zmiany zawartości jednej lub większej liczby
46 komórek od poprzednich obliczeń; wykonywane jest tylko przeliczanie
47 komórek, których zmiana dotyczy. Biblioteka jest napisana całkowicie w
48 C++ i intensywnie wykorzystuje bibliotekę boost, aby osiągnąć
49 przenośność na wiele platform.
50
51 %package devel
52 Summary:        Development files for ixion
53 Summary(pl.UTF-8):      Pliki nagłówkowe dla ixion
54 Group:          Development/Libraries
55 Requires:       %{name} = %{version}-%{release}
56 Requires:       boost-devel >= 1.36
57 Requires:       libstdc++-devel
58 Requires:       mdds-devel >= 0.7.1
59
60 %description devel
61 This package contains the header files for developing applications
62 that use ixion.
63
64 %description devel -l pl.UTF-8
65 Pen pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
66 ixion.
67
68 %package static
69 Summary:        Static ixion library
70 Summary(pl.UTF-8):      Statyczna biblioteka ixion
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 Static ixion library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka ixion.
79
80 %prep
81 %setup -q -n libixion-%{version}
82 %patch0 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal} -I m4
87 %{__autoconf}
88 %{__automake}
89 %configure \
90         boost_cv_lib_thread=yes \
91         boost_cv_lib_thread_LIBS="-lboost_thread -lboost_system" \
92         --disable-silent-rules \
93         %{?with_static_libs:--enable-static}
94
95 %{__make}
96
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # obsoleted by pkg-config
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS COPYING README
115 %attr(755,root,root) %{_bindir}/ixion-parser
116 %attr(755,root,root) %{_bindir}/ixion-sorter
117 %attr(755,root,root) %{_libdir}/libixion-0.8.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libixion-0.8.so.0
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libixion-0.8.so
123 %{_includedir}/libixion-0.8
124 %{_pkgconfigdir}/libixion-0.8.pc
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libixion-0.8.a
130 %endif
This page took 0.064155 seconds and 3 git commands to generate.