]> git.pld-linux.org Git - packages/irqbalance.git/blob - irqbalance.spec
- updated to 0.12
[packages/irqbalance.git] / irqbalance.spec
1 Summary:        Balancing of IRQs between multiple CPUs
2 Summary(pl):    Rozdzielanie IRQ pomiêdzy wiele procesorów
3 Name:           irqbalance
4 Version:        0.12
5 Release:        1
6 License:        OSL v1.1
7 Group:          Applications/System
8 Source0:        http://people.redhat.com/arjanv/irqbalance/%{name}-%{version}.tar.gz
9 # Source0-md5:  1f225b73a01380955231b77d9be60c7a
10 Source1:        %{name}.init
11 Patch0:         %{name}-opt.patch
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Balancing of IRQs between multiple CPUs.
16
17 %description -l pl
18 Narzêdzie do rozdzielania przerwañ IRQ pomiêdzy wiele procesorów.
19
20 %prep
21 %setup -q -n %{name}
22 %patch -p1
23
24 %build
25 %{__make} %{?debug:debug} \
26         CC="%{__cc}" \
27         CFLAGS="%{rpmcflags}"
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1,/etc/rc.d/init.d}
32
33 install %{name} $RPM_BUILD_ROOT%{_sbindir}
34 install %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
35 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %post
41 /sbin/chkconfig --add irqbalance
42 if [ -f /var/lock/subsys/irqbalance ]; then
43         /etc/rc.d/init.d/irqbalance restart 1>&2
44 else
45         echo "Run \"/etc/rc.d/init.d/irqbalance start\" to start irqbalance daemon."
46 fi
47
48 %preun
49 if [ "$1" = "0" ]; then
50         if [ -f /var/lock/subsys/irqbalance ]; then
51                 /etc/rc.d/init.d/irqbalance stop 1>&2
52         fi
53         /sbin/chkconfig --del irqbalance
54 fi
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changelog TODO
59 %attr(755,root,root) %{_sbindir}/*
60 %{_mandir}/man1/*
61 %attr(754,root,root) /etc/rc.d/init.d/irqbalance
This page took 0.077718 seconds and 4 git commands to generate.