]> git.pld-linux.org Git - packages/irqbalance.git/blob - irqbalance.spec
- license changed (acc. Changelog), let the source be on some URL.
[packages/irqbalance.git] / irqbalance.spec
1 Summary:        Balancing of IRQs between multiple CPUs
2 Summary(pl):    Rozdzielanie IRQ pomiêdzy wiele procesorów
3 Name:           irqbalance
4 Version:        0.13
5 Release:        1
6 License:        GPL
7 Group:          Applications/System
8 #Source0:       http://people.redhat.com/arjanv/irqbalance/%{name}-%{version}.tar.gz
9 # Currently no known URL - taken from FC6 src.rpm:
10 Source0:        http://www.blues.gda.pl/SOURCES/%{name}-%{version}.tar.gz
11 # Source0-md5:  837f1d69e9b6ef0a58bbd4cf4e0d7f28
12 Source1:        %{name}.init
13 Patch0:         %{name}-opt.patch
14 Patch1:         %{name}-classes.patch
15 Patch2:         %{name}-norebalance-zeroints.patch
16 Patch3:         %{name}-pie.patch
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Requires:       rc-scripts
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 irqbalance is a daemon that evenly distributes IRQ load across
24 multiple CPUs for enhanced performance.
25
26 %description -l pl
27 Narzêdzie do rozdzielania przerwañ IRQ pomiêdzy wiele procesorów
28 w celu zwiêkszenia wydajno¶ci systemu.
29
30 %prep
31 %setup -q -n %{name}
32 %patch0 -p1
33 %patch1 -p2
34 %patch2 -p2
35 # For gcc4 ?
36 #%patch3 -p2
37
38 %build
39 %{__make} %{?debug:debug} \
40         CC="%{__cc}" \
41         CFLAGS="%{rpmcflags}"
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1,/etc/rc.d/init.d}
46
47 install %{name} $RPM_BUILD_ROOT%{_sbindir}
48 install %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
49 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/chkconfig --add irqbalance
56 %service irqbalance restart "irqbalance daemon"
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %service irqbalance stop
61         /sbin/chkconfig --del irqbalance
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changelog TODO
67 %attr(755,root,root) %{_sbindir}/*
68 %{_mandir}/man1/*
69 %attr(754,root,root) /etc/rc.d/init.d/irqbalance
This page took 0.090474 seconds and 3 git commands to generate.