]> git.pld-linux.org Git - packages/irqbalance.git/blob - irqbalance.spec
7988fa9a16b474adb38d956adedf6f040253e871
[packages/irqbalance.git] / irqbalance.spec
1 Summary:        Balancing of IRQs between multiple CPUs
2 Summary(pl.UTF-8):      Rozdzielanie IRQ pomiędzy wiele procesorów
3 Name:           irqbalance
4 Version:        0.55
5 Release:        3
6 License:        GPL
7 Group:          Applications/System
8 Source0:        http://www.irqbalance.org/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  9f6b314ff1fdc14173abeb40592d4edf
10 Source1:        %{name}.init
11 Patch0:         %{name}-opt.patch
12 Patch1:         %{name}-pie.patch
13 Patch2:         %{name}-cputree-parse.patch
14 URL:            http://www.irqbalance.org/
15 BuildRequires:  glib2-devel
16 # due to -fpie
17 BuildRequires:  gcc >= 5:3.4
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 BuildRequires:  xorg-util-gccmakedep
20 Requires(post,preun):   /sbin/chkconfig
21 Requires:       rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 irqbalance is a daemon that evenly distributes IRQ load across
26 multiple CPUs for enhanced performance.
27
28 %description -l pl.UTF-8
29 Narzędzie do rozdzielania przerwań IRQ pomiędzy wiele procesorów
30 w celu zwiększenia wydajności systemu.
31
32 %prep
33 %setup -q
34 %patch0 -p1
35 %patch1 -p1
36 %patch2 -p2
37
38 %build
39 %{__make} \
40         CC="%{__cc}" \
41         OPT="%{rpmcflags}%{?debug: debug.c -DDEBUG}" \
42         LDFLAGS="%{rpmldflags}"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man1,/etc/rc.d/init.d}
47
48 install %{name} $RPM_BUILD_ROOT%{_sbindir}
49 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %post
55 /sbin/chkconfig --add irqbalance
56 %service irqbalance restart "irqbalance daemon"
57
58 %preun
59 if [ "$1" = "0" ]; then
60         %service irqbalance stop
61         /sbin/chkconfig --del irqbalance
62 fi
63
64 %files
65 %defattr(644,root,root,755)
66 %attr(755,root,root) %{_sbindir}/*
67 %attr(754,root,root) /etc/rc.d/init.d/irqbalance
This page took 0.029306 seconds and 2 git commands to generate.