]> git.pld-linux.org Git - packages/ipython.git/blob - ipython.spec
- mass commit: remove obsolete BR: rpm-pythonprov
[packages/ipython.git] / ipython.spec
1 %define         pname   IPython
2 Summary:        An enhanced Interactive Python shell
3 Summary(pl):    Interaktywna pow³oka jêzyka Python
4 Name:           ipython
5 Version:        0.6.4
6 Release:        2
7 License:        LGPL
8 Group:          Applications/Shells
9 Source0:        http://ipython.scipy.org/dist/%{name}-%{version}.tar.gz
10 # Source0-md5:  14261f8f921d6b35e343c2910bb6a974
11 Patch0:         %{name}-import_path.patch
12 URL:            http://ipython.scipy.org
13 %pyrequires_eq  python
14 Requires:       python-%{name} = %{version}
15 BuildRequires:  python-devel
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 IPython is a free software project which tries to:
21
22 1. Provide an interactive interpreter superior to Python's default.
23 IPython has many features for object introspection, shell access, and
24 its own special command system for adding functionality when working
25 interactively.
26
27 2. Serve as an embeddable, ready to use interpreter for your own
28 programs. IPython can be started with a single call from inside
29 another program, providing access to the current namespace. This can
30 be very useful both for debugging purposes and for situations where a
31 blend of batch-processing and interactive exploration are needed.
32
33 3. Offer a flexible framework which can be used as the base
34 environment for other systems with Python as the underlying language.
35 Specifically scientific environments like Mathematica, IDL and Mathcad
36 inspired its design, but similar ideas can be useful in many fields.
37
38 This package contains IPython shell.
39
40 %description -l pl
41 IPython jest wolnym oprogramowaniem, którego celem jest:
42
43 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej
44 dostarczanej z jêzykiem Python. IPython umo¿liwia badanie obiektów,
45 dostêp do pow³oki oraz w³asny system poleceñ, który umo¿liwia
46 rozszerzanie funkcjonalno¶ci podczas pracy interaktywnej.
47
48 2. Dostarczenie gotowego interpretera, który mo¿na do³±czaæ do w³asnej
49 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
50 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
51 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
52 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
53 wymagane po³±czenie przetwarzania wsadowego z interaktywn±
54 introspekcj±.
55
56 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
57 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
58 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
59 Mathematica, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
60 w wielu przypadkach.
61
62 Pakiet ten zawiera pow³okê IPython.
63
64 %package -n python-ipython
65 Summary:        An enhanced Interactive Python shell modules
66 Summary(pl):    Modu³y interaktywnej pow³oki jêzyka Python
67 Group:          Libraries/Python
68 %pyrequires_eq  python-devel-tools
69 %pyrequires_eq  pydoc
70
71 %description -n python-ipython
72 IPython is a free software project which tries to:
73
74 1. Provide an interactive interpreter superior to Python's default.
75 IPython has many features for object introspection, shell access, and
76 its own special command system for adding functionality when working
77 interactively.
78
79 2. Serve as an embeddable, ready to use interpreter for your own
80 programs. IPython can be started with a single call from inside
81 another program, providing access to the current namespace. This can
82 be very useful both for debugging purposes and for situations where a
83 blend of batch-processing and interactive exploration are needed.
84
85 3. Offer a flexible framework which can be used as the base
86 environment for other systems with Python as the underlying language.
87 Specifically scientific environments like Mathematica, IDL and Mathcad
88 inspired its design, but similar ideas can be useful in many fields.
89
90 This package contains IPython modules.
91
92 %description -n python-ipython -l pl
93 IPython jest wolnym oprogramowaniem, którego celem jest:
94
95 1. Dostarczenie interaktywnej pow³oki lepszej od standardowej
96 dostarczanej z jêzykiem Python. IPython umo¿liwia badanie obiektów,
97 dostêp do pow³oki oraz w³asny system poleceñ, który umo¿liwia
98 rozszerzanie funkcjonalno¶ci podczas pracy interaktywnej.
99
100 2. Dostarczenie gotowego interpretera, który mo¿na do³±czaæ do w³asnej
101 aplikacji. IPython mo¿e zostaæ uruchomiony za pomoc± wywo³ania jednej
102 funkcji z poziomu innego programu umo¿liwiaj±c jednocze¶nie dostêp do
103 aktualnej przestrzeni nazw tego programu. Mo¿e to byæ bardzo u¿yteczne
104 do celów takich jak ¶ledzenie programu czy te¿ sytuacji gdzie jest
105 wymagane po³±czenie przetwarzania wsadowego z interaktywn±
106 introspekcj±.
107
108 3. Dostarczenie szkieletu, który mo¿e zostaæ u¿yty jako podstawa
109 systemu, którego polecenia opieraj± siê na zasadach jêzyka Python.
110 Projekt zosta³ zainspirowany przez oprogramowanie naukowe takie jak
111 Mathematica, IDL oraz Mathcad, gdzie podobne idee mog± byæ realizowane
112 w wielu przypadkach.
113
114 Pakiet ten zawiera modu³y interaktywnej pow³oki jêzyka Python.
115
116 %prep
117 %setup -q
118 %patch0 -p1
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 python ./setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/*
131 %exclude %{_bindir}/*.orig
132 %{_mandir}/man1/*
133
134 %files -n python-ipython
135 %defattr(644,root,root,755)
136 %doc README doc/{ChangeLog,NEWS} doc/manual doc/*.pdf
137 %dir %{py_sitescriptdir}/%{pname}
138 %dir %{py_sitescriptdir}/%{pname}/Extensions
139 %dir %{py_sitescriptdir}/%{pname}/UserConfig
140 %{py_sitescriptdir}/%{pname}/*.py?
141 %{py_sitescriptdir}/%{pname}/Extensions/*.py?
142 %{py_sitescriptdir}/%{pname}/UserConfig
This page took 0.054162 seconds and 4 git commands to generate.